You are not logged in.

#1 2022-04-07 14:25:07

computernoob
Member
Registered: 2021-12-07
Posts: 7

[Solved] Ethernet down after system upgrade

Yesterday after I upgraded my system I got a couple issues. Certain videos wouldn't play, and a few programs broke (I think its due ffmpeg and other packages being updated), and my networking was acting weird. After the first reboot the network was still working but slow, after 4 hours or so of use it died (no reboot). I'm not sure what could have caused it. I was trying to revert ffmpeg and other packages to an earlier version at the time, so I thought that it might had something to do with it but after un-doing that the network was still down. So tried in to revert to the previous version of networkmanager (pacman -U /var/cache/pacman/pkg/networkmanager-1.32.12-2-x86_64.pkg.tar.zst), no luck, and same with the kernel (pacman -U .../linux-5.16.1.arch1-1-x86_64.pkg.tar.zst) which broke my x session, and network was still down. What I've tried is using arch-chroot to upgrade system hoping for a new version, enabling/disabling services and also creating /etc/NetworkManager/conf.d/no-systemd-resolved.conf.
To be honest I'm bad with network configuration, when I first installed arch I installed networkmanager, enabled the service and it have worked ever since I didn't mess with it. I have looked at the arch page for Network configuration and NetworkManager, couldn't find my issue (possible that I have missed it). All I really now is that I'm missing LOWER_UP from my interface. Thanks for reading!

Note: There is nothing wrong with the network, works with live-usb (which is how I'm posting this), router have been restarted, the issue is with arch.

$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 04:d9:f5:d4:33:87 brd ff:ff:ff:ff:ff:ff

$ systemctl list-unit-files --state=enabled
UNIT FILE                          STATE   VENDOR PRESET
getty@.service                     enabled enabled
NetworkManager-dispatcher.service  enabled disabled
NetworkManager-wait-online.service enabled disabled
NetworkManager.service             enabled disabled
remote-fs.target                   enabled enabled

5 unit files listed.

$ ip route show


$ ping 192.168.1.1
ping: connect: Network is unreachable

$ ping archlinux.org
ping: archlinux.org: Temporary failure in name resolution

Last edited by computernoob (2022-04-07 19:23:50)

Offline

#2 2022-04-07 14:30:13

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,404

Re: [Solved] Ethernet down after system upgrade

As a sanity check, verify that uname -a and pacman -Q linux  yield the same revision number (that second command assumes the stock kernel, modify as necessary if you are not)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2022-04-07 15:51:08

computernoob
Member
Registered: 2021-12-07
Posts: 7

Re: [Solved] Ethernet down after system upgrade

ewaller wrote:

As a sanity check, verify that uname -a and pacman -Q linux  yield the same revision number (that second command assumes the stock kernel, modify as necessary if you are not)

The revison number is indeed the same:

$ uname -a
Linux arch-pc 5.17.1-arch1-1 #1 SMP PREEMPT Mon, 28 Mar 2022 20:55:33 +0000 x86_64 GNU/Linux
$ pacman -Q linux
linux 5.17.1.arch1-1

Offline

#4 2022-04-07 17:08:02

seth
Member
Registered: 2012-09-03
Posts: 29,931

Re: [Solved] Ethernet down after system upgrade

You have neither an IP nor (therefore) a route, likely the dhcp request fails.
=> check your system journal (or post it in doubt), NM is for sure recording this error.

Offline

#5 2022-04-07 19:23:02

computernoob
Member
Registered: 2021-12-07
Posts: 7

Re: [Solved] Ethernet down after system upgrade

seth wrote:

You have neither an IP nor (therefore) a route, likely the dhcp request fails.
=> check your system journal (or post it in doubt), NM is for sure recording this error.

Found this from journalctl -b

Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9337] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-bluetooth.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9341] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-adsl.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9345] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-wwan.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9353] Loaded device plugin: NMOvsFactory (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-ovs.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9359] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-wifi.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9425] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/1.32.12-2/libnm-device-plugin-team.so)
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9427] manager: rfkill: Wi-Fi enabled by radio killswitch; enabled by state file
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9427] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
Apr 07 19:54:34 arch-pc NetworkManager[723]: <info>  [1649354074.9427] manager: Networking is disabled by state file

Everything that I don't use is enabled except for Networking (last line).  NM state file was located at /var/lib/NetworkManager/NetworkManager.state and here I thought changing it from "false" to "true" would solve my issue but it didn't. I used nmcli networking on, radio wifi off, wwan off, and this would be remembered after a reboot which also solved my Network issue! Before I had tried "ip link set enp4s0 up" which did not work.
Still curious how the options set with nmcli is being remembered, and if there is a way to disable plugins such as bluetooth and wifi from loading. Thanks for letting me know about journal, will mark solved.

Last edited by computernoob (2022-04-07 19:25:05)

Offline

Board footer

Powered by FluxBB