You are not logged in.

#1 2022-04-24 15:32:45

lirannl
Member
Registered: 2021-10-15
Posts: 9

Can't boot kernels beyond 5.15 (5.16 and up)

I'm currently making this post booted on 5.15 LTS, however I'd like to keep up with the linux kernel and use 5.17. I have also tried booting the latest fedora liveiso (it's 5.17 based), same result:
My laptop endlessly reboots without reaching any init hooks. I also tried 5.16 kernels, all of which resulted in that. Edit: Just tested with mainline 5.18 from the miffe repository. No difference.
As soon as I try to boot a 5.15 kernel it works fine. I tried removing my microcode with no effect (doesn't boot anything above 5.15).

CPU: AMD 5800HS
Device: ROG Flow X13 (a laptop)

Last edited by lirannl (2022-04-24 15:38:48)

Offline

#2 2022-04-24 16:25:24

loqs
Member
Registered: 2014-03-06
Posts: 14,922

Re: Can't boot kernels beyond 5.15 (5.16 and up)

Have you considered bisecting between 5.15 and 5.15 to find what is causing the issue?
https://bbs.archlinux.org/viewtopic.php … 9#p2016749 contains some prebuilt kernels from bisecting an issue between 5.15 and 5.16.

Offline

#3 2022-04-24 16:27:47

lirannl
Member
Registered: 2021-10-15
Posts: 9

Re: Can't boot kernels beyond 5.15 (5.16 and up)

I'm guessing the best course of action would be to download the latest first and then the earliest, and go from there?

Offline

#4 2022-04-24 16:34:15

loqs
Member
Registered: 2014-03-06
Posts: 14,922

Re: Can't boot kernels beyond 5.15 (5.16 and up)

Start with the midpoint I linked to.  Bisecting works by dividing the range of commits in half at each step.  The later kernels are based on the results from the previous steps.  You can keep using the prebuilt kernels until your results differ.

Offline

#5 2022-04-24 22:52:08

lirannl
Member
Registered: 2021-10-15
Posts: 9

Re: Can't boot kernels beyond 5.15 (5.16 and up)

My results differed almost immediately - the midpoint you linked to doesn't work, the very next one does, and I tried the one after that just out of curiosity - works flawlessly.
g2219b0ceefe8: bad
gfc02cb2b37fe: good
gb7b98f868987: good
g6e5772c8d9cf: good

Last edited by lirannl (2022-04-24 23:29:15)

Offline

#6 2022-04-24 23:52:08

loqs
Member
Registered: 2014-03-06
Posts: 14,922

Re: Can't boot kernels beyond 5.15 (5.16 and up)

It saved a couple of steps

$ git bisect log
git bisect start
# bad: [df0cc57e057f18e44dac8e6c18aba47ab53202f9] Linux 5.16
git bisect bad df0cc57e057f18e44dac8e6c18aba47ab53202f9
# good: [8bb7eca972ad531c9b149c0a51ab43a417385813] Linux 5.15
git bisect good 8bb7eca972ad531c9b149c0a51ab43a417385813
# bad: [2219b0ceefe835b92a8a74a73fe964aa052742a2] Merge tag 'soc-5.16' of git://git.kernel.org/pub/scm/linux/kernel/git/soc/soc
git bisect bad 2219b0ceefe835b92a8a74a73fe964aa052742a2
# good: [fc02cb2b37fe2cbf1d3334b9f0f0eab9431766c4] Merge tag 'net-next-for-5.16' of git://git.kernel.org/pub/scm/linux/kernel/git/netdev/net-next
git bisect good fc02cb2b37fe2cbf1d3334b9f0f0eab9431766c4

https://drive.google.com/file/d/1_PoAmZ … sp=sharing linux-5.15rc7.r1283.gd9bd054177fb-1-x86_64.pkg.tar.zst
https://drive.google.com/file/d/115dLB6 … sp=sharing linux-headers-5.15rc7.r1283.gd9bd054177fb-1-x86_64.pkg.tar.zst

Offline

#7 2022-04-25 00:24:13

lirannl
Member
Registered: 2021-10-15
Posts: 9

Re: Can't boot kernels beyond 5.15 (5.16 and up)

gd9bd054177fb: good

Offline

#8 2022-04-25 00:58:05

loqs
Member
Registered: 2014-03-06
Posts: 14,922

Re: Can't boot kernels beyond 5.15 (5.16 and up)

git bisect good
Bisecting: 812 revisions left to test after this (roughly 10 steps)
[dcd68326d29b62f3039e4f4d23d3e38f24d37360] Merge tag 'devicetree-for-5.16' of git://git.kernel.org/pub/scm/linux/kernel/git/robh/linux

https://drive.google.com/file/d/1a5IW8K … sp=sharing linux-5.15.r6700.gdcd68326d29b-1-x86_64.pkg.tar.zst
https://drive.google.com/file/d/1buRGMp … sp=sharing linux-headers-5.15.r6700.gdcd68326d29b-1-x86_64.pkg.tar.zst

Offline

#9 2022-04-25 01:24:06

lirannl
Member
Registered: 2021-10-15
Posts: 9

Re: Can't boot kernels beyond 5.15 (5.16 and up)

gdcd68326d29b: good

Offline

#10 2022-04-25 02:00:27

lirannl
Member
Registered: 2021-10-15
Posts: 9

Re: Can't boot kernels beyond 5.15 (5.16 and up)

I just added rootflags=subvol=/@ to my kernel params and that apparently fixed it even though I have a default btrfs subvol setup (/@). Should I report this as a bug to btrfs, or linux?

Offline

#11 2022-04-25 11:18:49

loqs
Member
Registered: 2014-03-06
Posts: 14,922

Re: Can't boot kernels beyond 5.15 (5.16 and up)

As the issue was introduced by changing the kernel the issue is in the kernel.  From MAINTAINERS:

BTRFS FILE SYSTEM
M:	Chris Mason <clm@fb.com>
M:	Josef Bacik <josef@toxicpanda.com>
M:	David Sterba <dsterba@suse.com>
L:	linux-btrfs@vger.kernel.org
S:	Maintained
W:	http://btrfs.wiki.kernel.org/
Q:	http://patchwork.kernel.org/project/linux-btrfs/list/
C:	irc://irc.libera.chat/btrfs
T:	git git://git.kernel.org/pub/scm/linux/kernel/git/kdave/linux.git
F:	Documentation/filesystems/btrfs.rst
F:	fs/btrfs/
F:	include/linux/btrfs*
F:	include/uapi/linux/btrfs*

You could try contacting them on IRC first.  You could also check https://btrfs.wiki.kernel.org/index.php/Problem_FAQ

Offline

Board footer

Powered by FluxBB