You are not logged in.

#1 2022-06-06 18:12:22

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

I tried Recently To get my nividia drivers working starting by turning ibt=off in the kernel parameters thru grub and was successful
However it seems even with ibt=off enabled I still can't get my games to boot.
One in Particular Said that you need a graphics card that can handle support of Direct X11 this is with using proton
Then I noticed when I used lspci - v I saw that my graphics card was disabled

 $ lspci -v
 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: PNY Device 11c3
        Flags: bus master, fast devsel, latency 0, IRQ 133
        Memory at de000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at df000000 [virtual] [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia 

    But I found in -lspci -k that its using the onboard graphics of my intel apu

 $ lspci -k
VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
        DeviceName:  Onboard IGD
        Subsystem: Hewlett-Packard Company Device 828a
        Kernel driver in use: i915
        Kernel modules: i915 

  How do I switch to my graphics card and its drivers without killing my gui?
thanks - Jedh

Last edited by Jedhless (2022-06-09 06:09:29)

Offline

#2 2022-06-06 19:47:16

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Kernel driver in use: nvidia

W/o ibt=off the kernel module wouldn't load.

I'm not sure what your problem is ("Games still won't launch" is a tiny bit generic), but since this is an optimus system, see https://wiki.archlinux.org/title/NVIDIA_Optimus
In the default setup you can run "game" on the nvidia chip w/ "prime-run superturboturkeypuncher3", https://archlinux.org/packages/extra/any/nvidia-prime/

Offline

#3 2022-06-06 19:48:49

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

I updated my post to be more clear. Hopefully that helps. I will check out the links you posted

Offline

#4 2022-06-06 19:54:01

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Nvidia Prime is apparently for laptops only. Will it work with a desktop that has a intel apu and a Nvidia Graphics card installed in the pci-slot?
Intel seems to have disabled my graphics card somehow I am wondering how to enable it to get it to work

Offline

#5 2022-06-06 19:58:48

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Post

xrandr --listproviders

and also your xorg log, https://wiki.archlinux.org/title/Xorg#General

The gpu is visible and assigned a kernel module, so "Intel seems to have disabled my graphics card somehow" is a false assumption.

If you cannot use the system in a hybrid fashion, you'll have to tell the X11 server which GPU to use (nvidia only, covered in the previous link)

Offline

#6 2022-06-06 20:13:02

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

 $ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x1b7 cap: 0x1, Source Output crtcs: 4 outputs: 4 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x1fc cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 4 associated providers: 1 name:Intel
$ grep -e Log -e tty Xorg.0.log 
grep: Xorg.0.log: No such file or directory 

I double checked in dolphin the Xorg.0.log isn't there in .local/share . there isn't a .xinitrc file in my $HOME either. Are there other places where I can find the logs?
Edit just saw your other links. Sorry I thought those were a banner.
btw I just barely installed the nvidia-settings package apparently it wasn't there to begin with.

Last edited by Jedhless (2022-06-06 20:39:24)

Offline

#7 2022-06-06 20:24:37

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Please use code tags, https://bbs.archlinux.org/help.php#bbcode

The four links on the bottom are indeed a signature.
What is "grep -e Log -e tty Xorg.0.log" supposed to be?
The log is in /var/log, ~/.local/share/xorg or the system journal, depending on how you start X11 (see the Xorg#General link for details)

Offline

#8 2022-06-06 20:33:36

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Apparently I did not have xorg-twm and xorg-xclock packages installed either. I did have xterm though which is interesting. I'm going to scour those links you gave me for a bit and check if I missed even more packages somehow.

Offline

#9 2022-06-06 20:41:58

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

You don't need those.
Again: the links below are a generic signature to address common issues.
Depending on how you start the session, you're not using the xinitrc at all (and since there's apparently no log in ~/.local/share/xorg, there'sa  good chance you're not using xinit)

Offline

#10 2022-06-06 20:55:13

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

How can I post the logfile? Its probably too big to just copy and paste it here.  Also this seems important

    22.577] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    22.577] (--) NVIDIA(0):     DFP-0
[    22.577] (--) NVIDIA(0):     DFP-1 (boot)
[    22.577] (--) NVIDIA(0):     DFP-2
[    22.577] (--) NVIDIA(0):     DFP-3
[    22.578] (II) NVIDIA(0): NVIDIA GPU NVIDIA GeForce GTX 1050 Ti (GP107-A) at PCI:1:0:0
[    22.578] (II) NVIDIA(0):     (GPU-0)
[    22.578] (--) NVIDIA(0): Memory: 4194304 kBytes
[    22.578] (--) NVIDIA(0): VideoBIOS: 86.07.39.00.46
[    22.578] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    22.578] (--) NVIDIA(GPU-0): DFP-0: disconnected
[    22.578] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS 

That's just a snippet. so it says that the gpu is Disconnected somehow?
Let me know how to post the log file too

Offline

#11 2022-06-06 21:04:29

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

so it says that the gpu is Disconnected somehow?

Let me know how to post the log file too

That is actually covered by the links in the signature… the first one tongue

Offline

#12 2022-06-06 21:14:06

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

https://0x0.st/oMQL.json
There's the log
I'm off to work now hopefully I am not late!
I wanted to at least give you this log first before I left.
I'll be back in around 5 hours.

Offline

#13 2022-06-06 21:30:09

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

You've an nvidia-settings generated xorg.conf and are therefore running X11 on the nvidia GPU.

The updated OP wrote:

I still can't get my games to boot.
One in Particular Said that you need a graphics card that can handle support of Direct X11 this is with using proton

You should post the actual proton output when trying to run a game, but chances are you're simply missing the lib32 versions, https://archlinux.org/packages/multilib … dia-utils/

Offline

#14 2022-06-08 02:37:51

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Alright I tried installing the 32 bit versions. I still have the same issues nothing from steam launches successfully even Valheim with it does not start with proton and without it. Does Steam Runtime repository have issues that would cause this? Is Steam 1.0.0.74-1 any better? I have steam Runtime installed currently and whats weird is that I can watch videos on browsers fine I just can't play any of my steam games. Which makes me think this is a Steam problem and not a Nvidia issue especially because ibt is off.
Sorry for the late reply I was exhausted after work yesterday.
Also I can give you the logs but they don't tell much the only errs was this

 34911.197:0020:00d0:err:steam:initialize_vr_data Could not load libopenvr_api.so.

 34913.156:0134:0138:err:vulkan:__wine_create_vk_instance_with_callback Failed to create instance, res=-1 

Last edited by Jedhless (2022-06-08 03:01:28)

Offline

#15 2022-06-08 06:10:36

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Also I can give you the logs but they don't tell much

How about I take a look myself.

From the posted bits:
https://wiki.archlinux.org/title/Vulkan … initialize - make sure vulkaninfo works
Perhaps https://archlinux.org/packages/community/x86_64/vkd3d/

Offline

#16 2022-06-08 16:58:29

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Space Engineers steam proton log
http://0x0.st/oMy5.txt

Valheim steam proton log
http://0x0.st/oMyR.txt

Thanks - Jedh

Offline

#17 2022-06-08 20:32:37

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Did you check the links I posted (notably the first one)?
Cause you meet https://bbs.archlinux.org/viewtopic.php?id=268353 in "OpenXR: Unable to get required Vulkan instance extensions size" (while that one required the radeon vulkan description and you need the nvidia one)

Edit: also https://github.com/ValveSoftware/steam- … issues/312 confirms that you'll probably have to specify the vulkan driver

Last edited by seth (2022-06-08 20:35:18)

Offline

#18 2022-06-09 05:12:45

Jedhless
Member
Registered: 2022-06-06
Posts: 10

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Alright Games are working now. Thank you so much. I have a git where I am trying to record all of what I do so I won't forget for the next time this happens. https://github.com/Jedhless-Huudie/Debu … ux-Records

Yeah having to blacklist all the drivers that I don't have is pretty smooth valve. That's sarcasm by the way. If they had a option in the steam play settings to set which vulkan driver you want to run, it would help

Also I am pretty sure the stuttering from my game Space Engineers is from it making a log each time I run it. I think I just have to comment out the wine debug in user-settings in the proton directory
I'll let you know how that turns out.

Also the specifics of what I actually did is right here https://github.com/Jedhless-Huudie/Debu … -nvidia.md

Thanks again! - Jedh

Last edited by Jedhless (2022-06-09 05:14:44)

Offline

#19 2022-06-09 05:21:35

seth
Member
Registered: 2012-09-03
Posts: 29,732

Re: Enabling Nvidia graphics for Steam Runtime [ RESOLVED ]

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

Board footer

Powered by FluxBB