You are not logged in.

#1 2022-06-06 20:46:34

sfabius
Member
Registered: 2007-07-07
Posts: 146

wireless interface disappeared on reboot

Upon rebooting machine today (everything updated, no new kernel updates AFAIK), my wlan0 interface disappeared. Tried rebooting again, twice, no luck.
ip link:

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether a4:4c:c8:32:b3:68 brd ff:ff:ff:ff:ff:ff

Previously there was a wlan0 interface

Here's the relevant part of lspci:

 02:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
	Subsystem: Intel Corporation Device 0050
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

suggesting driver is in use.

Here's dmesg |grep iwl:

 [   37.540761] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[   37.610204] iwlwifi 0000:02:00.0: loaded firmware version 36.ca7b901d.0 8265-36.ucode op_mode iwlmvm
[   38.866801] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
[   38.929587] iwlwifi 0000:02:00.0: base HW address: 90:61:ae:14:eb:cd, OTP minor version: 0x0

I'm not sure what else to check or how else to troubleshoot.

Any suggestions on where/what to try next?
Thx

Offline

#2 2022-06-06 20:49:58

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,369

Re: wireless interface disappeared on reboot

I know it seems to have found the driver, but as a sanity check, compare are the output of uname -a and of pacman -Q linux to ensure they are the same kernel version.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2022-06-06 20:53:42

sfabius
Member
Registered: 2007-07-07
Posts: 146

Re: wireless interface disappeared on reboot

Thanks, the output here matches, both are "5.18.1.arch1-1"

Offline

#4 2022-06-06 21:08:04

sfabius
Member
Registered: 2007-07-07
Posts: 146

Re: wireless interface disappeared on reboot

So I just decided what the heck try rebooting again and lo and behold the interface is back. If anyone has any idea why this happened or what I can do to not have to wait a few hours and reboot 4 times, it's a mystery waiting to be solved....
Not sure if it makes any difference, but the interfaces are numbered 1,2,4:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s31f6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether a4:4c:c8:32:b3:68 brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 90:61:ae:14:eb:cd brd ff:ff:ff:ff:ff:ff

Offline

#5 2022-06-06 21:16:33

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,369

Re: wireless interface disappeared on reboot

Thinking outload.  Perhaps a race condition where something is not ready in time?
Do you have different outcomes with a cold start versus a warm start?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#6 2022-06-09 12:12:51

sfabius
Member
Registered: 2007-07-07
Posts: 146

Re: wireless interface disappeared on reboot

By cold I imagine you mean from when the machine is off and has been for a while and warm is a reboot?
I don't think so as I just rebooted several times (working on my insanity) and then the last time the interface came up.  Will definitely pay attention to this though.

Offline

#7 2022-06-09 12:21:31

progandy
Member
Registered: 2012-05-17
Posts: 4,965

Re: wireless interface disappeared on reboot

Does unloading and reloading the driver help when the interface is missing?
Or maybe resetting the device?

echo 1 > "/sys/bus/pci/devices/0000:02:00.0/remove" # or maybe .../reset
sleep 1
echo 1 > /sys/bus/pci/rescan

Last edited by progandy (2022-06-09 12:25:23)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#8 2022-06-09 17:53:58

sfabius
Member
Registered: 2007-07-07
Posts: 146

Re: wireless interface disappeared on reboot

By cold I imagine you mean from when the machine is off and has been for a while and warm is a reboot?
I don't think so as I just rebooted several times (working on my insanity) and then the last time the interface came up.  Will definitely pay attention to this though.

Offline

#9 2022-06-09 20:22:37

seth
Member
Registered: 2012-09-03
Posts: 29,723

Re: wireless interface disappeared on reboot

Also check rfkill and the journal for microcode/firmware crashes.
Ceterum censeo: 3rd link below.

Offline

Board footer

Powered by FluxBB