You are not logged in.

#1 2022-05-31 17:54:32

zynex
Member
Registered: 2019-03-20
Posts: 14

[SOLVED] Upgrading to MariaDB 10.8.3-1 failes to start service

I just upgraded my server and got MariaDB v10.8.3-1, after a reboot my web pages didn't load because failed database connection. Looking in the logs is seems that InnoDB returned an error, and stopped the service.

2022-05-31 19:36:51 0 [ERROR] InnoDB: Upgrade after a crash is not supported. The redo log was created with MariaDB 10.6.4.
2022-05-31 19:36:51 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2022-05-31 19:36:51 0 [Note] InnoDB: Starting shutdown...
2022-05-31 19:36:51 0 [ERROR] Plugin 'InnoDB' init function returned error.
2022-05-31 19:36:51 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2022-05-31 19:36:51 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2022-05-31 19:36:51 0 [ERROR] Aborting

Did a little search and found some old posts on different forums regarding the problem, but nothing that solved it. After doing a downgrade to v10.7.4-1 it worked again.
Anyone experienced this problem to after upgrading to v10.8.3-1, and maybe have a fix for it? I looked in Arch Wiki, but nothing there helped because the service is down.

-- Mike

[EDIT]

After some more digging I solved it. Using mysql_upgrade didn't work at first because of the failed service. After downgrading the service started, and the mysql_upgrade could be executed so the database was upgraded. After that I could restart the service again without issues smile

Last edited by zynex (2022-05-31 18:04:22)

Offline

#2 2022-08-24 15:21:52

wall75
Member
Registered: 2022-08-24
Posts: 1

Re: [SOLVED] Upgrading to MariaDB 10.8.3-1 failes to start service

I have the same problem but I can't downgrade to a previous version, it shows me a dependency error!!!!.
Right now I'm stuck, I don't know how to fix it.

EDIT:  OK, fixed, downgrade solved

Last edited by wall75 (2022-08-24 15:51:55)

Offline

Board footer

Powered by FluxBB