You are not logged in.

#1 2022-11-09 15:28:15

joanmanel
Member
Registered: 2012-11-06
Posts: 196

Cannot connect to eduroam since system update this morning.

Hi All,

This morning I connected to Eduroam and it worked as expected. I did a system update, and after the reboot it does not connect to Eduroam.

I tried to do the second option described here to get it working: https://www.reddit.com/r/archlinux/comm … er_update/

But this did not work. I use Gnome and NetworkManager. Usually I just select the Wifi network from the menu in Gnome, but when I click over Eduroam, somehow it doesnt do anything. It is quite strange, it doesn't even try to connect or anything.

I tried to do what it says here: https://www.reddit.com/r/archlinux/comm … ifi_using/

Because when I try to do nmcli device wifi connect eduroam I also get an error saying "Failed to determine AP security information". But following those steps doesnt work for me.

I guess what surprises me the most is that when I click on Eduoram, through the gnome menu, it doesnt do anything.

EDIT: Now at least I can click on eduroam, although it does not connect. Journalctl returns:

Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.8891] device (wlp2s0): supplicant interface state: scanning -> authenticating
Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.8892] device (p2p-dev-wlp2s0): supplicant management interface state: scanning -> authenticating
Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.9158] device (wlp2s0): supplicant interface state: authenticating -> associating
Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.9159] device (p2p-dev-wlp2s0): supplicant management interface state: authenticating -> associating
Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.9278] device (wlp2s0): supplicant interface state: associating -> associated
Nov 09 16:04:39 latitude NetworkManager[337]: <info>  [1668009879.9279] device (p2p-dev-wlp2s0): supplicant management interface state: associating -> associated
Nov 09 16:04:40 latitude NetworkManager[337]: <info>  [1668009880.6125] device (wlp2s0): supplicant interface state: associated -> disconnected
Nov 09 16:04:40 latitude NetworkManager[337]: <info>  [1668009880.6126] device (p2p-dev-wlp2s0): supplicant management interface state: associated -> disconnected
Nov 09 16:04:40 latitude NetworkManager[337]: <info>  [1668009880.7116] device (wlp2s0): supplicant interface state: disconnected -> scanning
Nov 09 16:04:40 latitude NetworkManager[337]: <info>  [1668009880.7117] device (p2p-dev-wlp2s0): supplicant management interface state: disconnected -> scanning
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.6827] device (wlp2s0): supplicant interface state: scanning -> authenticating
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.6827] device (p2p-dev-wlp2s0): supplicant management interface state: scanning -> authenticating
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.7255] device (wlp2s0): supplicant interface state: authenticating -> associating
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.7256] device (p2p-dev-wlp2s0): supplicant management interface state: authenticating -> associating
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.7369] device (wlp2s0): supplicant interface state: associating -> associated
Nov 09 16:04:51 latitude NetworkManager[337]: <info>  [1668009891.7370] device (p2p-dev-wlp2s0): supplicant management interface state: associating -> associated
Nov 09 16:04:52 latitude NetworkManager[337]: <info>  [1668009892.4082] device (wlp2s0): supplicant interface state: associated -> disconnected
Nov 09 16:04:52 latitude NetworkManager[337]: <info>  [1668009892.4083] device (p2p-dev-wlp2s0): supplicant management interface state: associated -> disconnected
Nov 09 16:04:52 latitude NetworkManager[337]: <info>  [1668009892.5078] device (wlp2s0): supplicant interface state: disconnected -> scanning
Nov 09 16:04:52 latitude NetworkManager[337]: <info>  [1668009892.5079] device (p2p-dev-wlp2s0): supplicant management interface state: disconnected -> scanning
Nov 09 16:05:04 latitude NetworkManager[337]: <warn>  [1668009904.1950] device (wlp2s0): Activation: (wifi) association took too long
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.1951] device (wlp2s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Nov 09 16:05:04 latitude NetworkManager[337]: <warn>  [1668009904.1963] device (wlp2s0): Activation: (wifi) asking for new secrets
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.1985] device (wlp2s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.1994] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2001] device (wlp2s0): Activation: (wifi) connection 'eduroam' has security, and secrets exist.  No new secrets needed.
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2002] Config: added 'ssid' value 'eduroam'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2002] Config: added 'scan_ssid' value '1'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2002] Config: added 'bgscan' value 'simple:30:-65:300'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2002] Config: added 'key_mgmt' value 'WPA-EAP FT-EAP FT-EAP-SHA384 WPA-EAP-SHA256'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'password' value '<hidden>'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'eap' value 'PEAP'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'fragment_size' value '1266'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'phase2' value 'auth=MSCHAPV2'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'identity' value 'myemail@myemail.uk'
Nov 09 16:05:04 latitude NetworkManager[337]: <info>  [1668009904.2003] Config: added 'proactive_key_caching' value '1'
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1099] device (wlp2s0): supplicant interface state: scanning -> authenticating
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1100] device (p2p-dev-wlp2s0): supplicant management interface state: scanning -> authenticating
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1489] device (wlp2s0): supplicant interface state: authenticating -> associating
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1489] device (p2p-dev-wlp2s0): supplicant management interface state: authenticating -> associating
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1619] device (wlp2s0): supplicant interface state: associating -> associated
Nov 09 16:05:05 latitude NetworkManager[337]: <info>  [1668009905.1620] device (p2p-dev-wlp2s0): supplicant management interface state: associating -> associated
Nov 09 16:05:08 latitude NetworkManager[337]: <info>  [1668009908.2913] device (wlp2s0): supplicant interface state: associated -> disconnected
Nov 09 16:05:08 latitude NetworkManager[337]: <info>  [1668009908.2914] device (p2p-dev-wlp2s0): supplicant management interface state: associated -> disconnected
Nov 09 16:05:08 latitude NetworkManager[337]: <info>  [1668009908.3911] device (wlp2s0): supplicant interface state: disconnected -> scanning
Nov 09 16:05:08 latitude NetworkManager[337]: <info>  [1668009908.3911] device (p2p-dev-wlp2s0): supplicant management interface state: disconnected -> scanning

Last edited by joanmanel (2022-11-09 16:06:38)

Offline

#2 2022-11-09 16:16:26

laser-beans
Member
Registered: 2022-11-09
Posts: 1

Re: Cannot connect to eduroam since system update this morning.

I was experiencing the exact same problem. I updated yesterday (11/8/22) and Eduroam stopped working.

No other networks were affected (I could not find any other networks that I would normally connect to on Arch that were affected by this problem). Eduroam was working immediately before my update and stop working after. I could connect to Eduroam on other devices (different OS).

I just updated wpa_supplicant again, and it now works.

Last edited by laser-beans (2022-11-09 16:18:01)

Offline

#3 2022-11-09 16:17:11

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,827

Re: Cannot connect to eduroam since system update this morning.

Offline

#4 2022-11-09 17:48:24

joanmanel
Member
Registered: 2012-11-06
Posts: 196

Re: Cannot connect to eduroam since system update this morning.

laser-beans wrote:

I was experiencing the exact same problem. I updated yesterday (11/8/22) and Eduroam stopped working.

No other networks were affected (I could not find any other networks that I would normally connect to on Arch that were affected by this problem). Eduroam was working immediately before my update and stop working after. I could connect to Eduroam on other devices (different OS).

I just updated wpa_supplicant again, and it now works.

What do you mean by just updating wpa_supplicant ?

Offline

#5 2022-11-10 04:17:55

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,840

Re: Cannot connect to eduroam since system update this morning.

joanmanel wrote:

What do you mean by just updating wpa_supplicant ?

https://github.com/archlinux/svntogit-p … 9ad49c7a44

Update your system again (pacman -Syu) and see if the latest version of wpa_supplicant solves the problem. It enables some things to workaround issues on networks like eduroam, until those networks are (hopefully) eventually updated (probably sometime after it stops working for Windows users).


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

Board footer

Powered by FluxBB