You are not logged in.

#1 2022-07-17 14:08:56

angrynapkin
Member
Registered: 2022-07-17
Posts: 15

No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

I just installed arch fresh on this laptop and seems sound has issues.
I have gone thru the Alsa section with trying to unmute channels with zero success.
alsa-ucm-conf is installed as well as sof-firmware
version: alsa-ucm-conf 1.2.7.2-1 , sof-firmware 2.2-1

When I install sof-firmware i get hangs on shutdown where the system locks up indefinitely.
removing sof-firmware solves the shutdown issues, but neither having it installed or uninstalled has any affect on sound working or not.
Below is some info.

lspci -k
0000:00:1f.3 Multimedia audio controller: Intel Corporation Alder Lake PCH-P High Definition Audio Controller (rev 01)
Subsystem: Dell Device 0afe
Kernel driver in use: sof-audio-pci-intel-tgl
Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

journalctl -b
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Jul 16 23:15:36 olderman kernel: fbcon: i915drmfb (fb0) is primary device
Jul 16 23:15:36 olderman kernel: Console: switching to colour frame buffer device 240x75
Jul 16 23:15:36 olderman kernel: i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: use msi interrupt mode
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: hda codecs found, mask 4
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:19:1
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: warn: FW ABI is more recent than kernel
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: unknown sof_ext_man header type 3 size 0x30
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware info: version 2:2:0-57864
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: Firmware: ABI 3:22:1 Kernel ABI 3:19:1
Jul 16 23:15:36 olderman kernel: sof-audio-pci-intel-tgl 0000:00:1f.3: warn: FW ABI is more recent than kernel
...
Jul 16 23:15:38 olderman kernel: soundwire sdw:3:025d:0714:01: Probe not complete, timed out
Jul 16 23:15:38 olderman kernel: soundwire sdw:3:025d:0714:01: Update Slave status failed:-110
Jul 16 23:15:38 olderman kernel: soundwire sdw:2:025d:1316:01: Probe not complete, timed out
Jul 16 23:15:38 olderman kernel: soundwire sdw:2:025d:1316:01: Update Slave status failed:-110
Jul 16 23:15:38 olderman kernel: soundwire sdw:1:025d:1316:01: Probe not complete, timed out
Jul 16 23:15:38 olderman kernel: soundwire sdw:1:025d:1316:01: Update Slave status failed:-110
Jul 16 23:15:38 olderman kernel: soundwire sdw:0:025d:0711:01: Probe not complete, timed out
Jul 16 23:15:38 olderman kernel: soundwire sdw:0:025d:0711:01: Update Slave status failed:-110
...
Jul 16 23:15:39 olderman kernel: sof_sdw sof_sdw: snd_soc_register_card failed -517
Jul 16 23:15:40 olderman kernel: sof_sdw sof_sdw: snd_soc_register_card failed -517
Jul 16 23:15:40 olderman kernel: sof_sdw sof_sdw: snd_soc_register_card failed -517
Jul 16 23:15:40 olderman kernel: sof_sdw sof_sdw: snd_soc_register_card failed -517
Jul 16 23:15:40 olderman kernel: sof_sdw sof_sdw: snd_soc_register_card failed -517
...
ul 16 23:16:39 olderman systemd-udevd[368]: sdw:0:025d:0711:01: Worker [374] processing SEQNUM=5150 is taking a long time
Jul 16 23:16:39 olderman systemd-udevd[368]: sdw:3:025d:0714:01: Worker [422] processing SEQNUM=5162 is taking a long time
Jul 16 23:18:39 olderman systemd-udevd[368]: sdw:0:025d:0711:01: Worker [374] processing SEQNUM=5150 killed
Jul 16 23:18:39 olderman systemd-udevd[368]: sdw:3:025d:0714:01: Worker [422] processing SEQNUM=5162 killed
...
ul 16 23:19:36 olderman kernel: INFO: task systemd-udevd:374 blocked for more than 122 seconds.
Jul 16 23:19:36 olderman kernel: Tainted: P OE 5.18.12-arch1-1 #1
Jul 16 23:19:36 olderman kernel: "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Jul 16 23:19:36 olderman kernel: task:systemd-udevd state:D stack: 0 pid: 374 ppid: 368 flags:0x00000006
Jul 16 23:19:36 olderman kernel: Call Trace:
Jul 16 23:19:36 olderman kernel:

Offline

#2 2022-08-02 08:40:52

potens
Member
Registered: 2016-03-14
Posts: 14

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

Hi,

I don't know if it can help you, but I had a similar issue on XPS 9320

See my post

So, for me the problem was having the i915 module in intird. (may not apply to you)

Otherwise, to avoid the hang, you have to stop gdm, remove all snd-* modules and soundwire* modules

Hope it helps

Offline

#3 2022-08-02 09:27:58

LaLampada
Member
Registered: 2021-03-19
Posts: 38

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

The new 5.19 kernel will be fix the sound on my 9520.. Probably it fix the 9720 too

Offline

#4 2022-08-19 01:54:16

Grandfather-Paradox
Member
Registered: 2017-08-22
Posts: 11

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

Any luck with this @angrynapkin? I just got a 9720 and have the same exact issue. Tried both the LTS kernel and current (5.19) kernel with no luck.

Offline

#5 2022-10-19 12:54:22

angrynapkin
Member
Registered: 2022-07-17
Posts: 15

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

No Luck, we seem to have hit a road block as to how to proceed troubleshooting this.
I Posted in the kernel section here: https://bbs.archlinux.org/viewtopic.php?id=279942
And in the SOF git section here: https://github.com/thesofproject/linux/issues/3777

Quick and dirty, it seem there is a conflict going on when the kernel is installed using the package manager. Be it how its created or the package manager itself, I have no clue. Arch Forum @Lone_Wolf is leaning towards it being an issue with SOF not waiting fully for the Hardware to become available, where as the SOF group is saying its something with Arch and Debian as these seem to be the only distros affected.

Manual compile and manual install works just fine. Building the kernel with the Arch Build System and installing with pacman it will not work.
Building the kernel with Arch Build System, then manually install from the build directory, sound will work.

Inside the PKGBUILD file there is a section "_package() "
Building with "INSTALL_MOD_STRIP=1 " in that section and installing via pacman, the sound will work.

So I am with everyone else scratching my head not really know how to proceed.

Offline

#6 2022-10-23 16:44:13

iusedarchbtw
Member
Registered: 2022-10-23
Posts: 2

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

Hey @angrynapkin,

I've had the same issue on my XPS 9720. My research seems to confirm there is a race condition, which led me to a workaround - defer loading of the module snd_sof_pci_intel_tgl until the system has booted.
Here's what works for me.

First of all, I blacklisted the module snd_sof_pci_intel_tgl module. For people not familiar with the process, you can just create a file /etc/modprobe.d/sound-workaround.conf with the following content:

# This is to disable loading the module at boot automatically, because of the race condition.
# The module has to be somehow loaded later, e.g. through a systemd service.
# Explanation: https://bbs.archlinux.org/viewtopic.php?id=278139

blacklist snd_sof_pci_intel_tgl

After that the module would not be automatically loaded at boot any longer, which means I had to make it load automatically in some other way. For that purpose I created a simplictic systemd unit in /etc/systemd/system/sound-workaround.service:

[Unit]
Description=Load the blacklisted sound module to mitigate race condition

[Service]
Type=oneshot
ExecStart=/usr/bin/modprobe snd_sof_pci_intel_tgl

[Install]
WantedBy=multi-user.target

Lastly, I enabled the service:

systemctl enable sound-workaround.service

and restarted my lovely XPS.

Let me know if that worked for you.

Offline

#7 2022-11-29 15:02:16

Oles
Member
Registered: 2022-10-10
Posts: 1

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

This 'workaround' work. But this is not solution.
My system: Linux xps17 5.15.80-1-lts  - XPS 17 9720 with Alder Lake.
I have a little problem with hibernation. On resume i see only black screen but mouse cursor.
Temporary solution:

xrandr --output e-DP1 --off
xrandr --output HDMI-1 --off   # for external monitor

This of course in openbox with keyboard shortcut
then:

xrandr --output eDP-1 --auto     #eDP-1 for my laptop screen

or

xrandr --output DP-1 --mode 3440x1440 --right-of eDP-1 --primary

for external monitor

Offline

#8 2022-12-01 16:05:27

iusedarchbtw
Member
Registered: 2022-10-23
Posts: 2

Re: No Sound - XPS 17 9720 - Linux 5.18.12-arch1-1

Oles wrote:

This 'workaround' work. But this is not solution.

Clearly, there is no pleasing some people. The solution would require fixing the kernel module, which by the way seems to have happened in Manajro kernel 6.0.8, so would be worth checking in Arch too, so I don't need the workaround anymore.

Offline

Board footer

Powered by FluxBB