You are not logged in.

#1 2022-12-11 08:56:41

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Removing unused packages (orphans)

hello,
in the pacman/Tips and tricks Wiki it says that to remove unused packages you need to type this command:

# pacman -Qtdq | pacman -Rns -

https://wiki.archlinux.org/title/pacman … _(orphans)

i have tried it but it removes all my packages! o_O

# pacman -Qtdq | pacman -Rns -
checking dependencies...
:: alsa-plugins optionally requires libavtp: for pcm_aaf plugin
:: avahi optionally requires python-gobject: avahi-bookmarks, avahi-discover
:: avahi optionally requires python-dbus: avahi-bookmarks, avahi-discover
:: cups optionally requires colord: for ICC color profile support
:: cups-filters optionally requires foomatic-db-engine: drivers use Ghostscript to convert PostScript to a printable form directly
:: cups-filters optionally requires imagemagick: for Braille embosser support
:: cups-filters optionally requires liblouis: for Braille embosser support
:: gdk-pixbuf2 optionally requires libwmf: Load .wmf and .apm
:: gdk-pixbuf2 optionally requires libjxl: Load .jxl
:: gettext optionally requires git: for autopoint infrastructure updates
:: gnupg optionally requires libusb-compat: scdaemon
:: gutenprint optionally requires gimp: adds gutenprint plugin to gimp
:: libinput optionally requires gtk4: libinput debug-gui
:: libisoburn optionally requires sudo: for use with xorriso-dd-target
:: liblangtag optionally requires gobject-introspection-runtime: use with liblangtag-gobject
:: libreoffice-fresh optionally requires java-environment: required by extension-wiki-publisher and extension-nlpsolver
:: libreoffice-fresh optionally requires gtk4: for GTK4 integration (experimental)
:: lv2 optionally requires python-pygments: for lv2specgen.py
:: openal optionally requires fluidsynth: MIDI rendering
:: opencv optionally requires glew: for the viz module
:: openssh optionally requires xorg-xauth: X11 forwarding
:: pcsx2 optionally requires qt6-wayland: Wayland support
:: phonon-qt5-gstreamer optionally requires gst-plugins-good: PulseAudio support and good codecs
:: phonon-qt5-gstreamer optionally requires gst-plugins-bad: additional codecs
:: phonon-qt5-gstreamer optionally requires gst-plugins-ugly: additional codecs
:: python-pyqt5 optionally requires python-dbus: for python-dbus mainloop support
:: python-pyqt6 optionally requires qt6-svg: QtSvg bindings
:: python-pyqt6 optionally requires qt6-multimedia: QtMultimedia bindings
:: python-pyqt6 optionally requires dbus-python: for python-dbus mainloop support
:: qt5-multimedia optionally requires gst-plugins-good: camera support, additional plugins
:: qt5-multimedia optionally requires gst-plugins-bad: camera support, additional plugins
:: qt5-multimedia optionally requires gst-plugins-ugly: additional plugins
:: qt6-base optionally requires qt6-wayland: to run Qt6 applications in a Wayland session
:: sigil optionally requires python-pillow: recommended for plugins
:: subversion optionally requires java-environment: for Java support
:: tor-browser optionally requires gst-plugins-good: H.264 video
:: udisks2 optionally requires ntfs-3g: NTFS filesystem management support
:: vlc optionally requires libgme: Game Music Emu plugin
:: vlc optionally requires libmicrodns: mDNS services discovery (chromecast etc)
:: vlc optionally requires libshout: shoutcast/icecast output plugin
:: vlc optionally requires zvbi: VBI/Teletext/webcam/v4l2 capture/decoding
:: vlc optionally requires libkate: Kate codec
:: vlc optionally requires aalib: ASCII art video output
:: vlc optionally requires libcaca: colored ASCII art video output
:: webkit2gtk optionally requires gst-plugins-good: media decoding
:: webkit2gtk optionally requires gst-plugins-bad: media decoding
:: webkit2gtk-4.1 optionally requires gst-plugins-good: media decoding
:: webkit2gtk-4.1 optionally requires gst-plugins-bad: media decoding
:: wine optionally requires lib32-gnutls
:: wine optionally requires lib32-libxcomposite
:: wine optionally requires lib32-libxinerama
:: yt-dlp-git optionally requires rtmpdump: for rtmp streams support
warning: dependency cycle detected:
warning: qt6-multimedia-ffmpeg will be removed after its qt6-multimedia dependency
warning: pacman is designated as a HoldPkg.
:: HoldPkg was found in target list. Do you want to continue? [y/N] y

Packages (494) aalib-1.4rc5-14  abseil-cpp-20220623.1-1
               android-udev-20220903-2  anthy-9100h-6  apparmor-3.1.2-1
               avidemux-cli-2.8.1-1  babl-0.1.98-1  c-ares-1.18.1-1
               cairo-perl-1.109-2  cdrdao-1.2.4-2  cdrtools-3.02a09-5
               chromaprint-1.5.1-5  cmake-3.25.0-1  cmark-0.30.2-1
               colord-1.4.6-1  cower-18-1  crypto++-8.7.0-1
               dbus-python-1.2.18-3  diffutils-3.8-1  dvd+rw-tools-7.1-9
               exiv2-0.27.5-3  expac-10-5  faac-1.30-3  fcitx-4.2.9.9-1
               fluidsynth-2.3.0-2  foomatic-db-engine-4:20220521-1
               fuse2-2.9.9-4  gawk-5.2.1-1  gdb-common-12.1-2  gegl-0.4.40-1
               geoip-1.6.12-2  geoip-database-20221118-1  gimp-2.10.32-2
               git-2.38.1-2  glew-2.2.0-6  glib-perl-1.329.3-3
               glibmm-2.68-2.74.0-1  gnome-icon-theme-symbolic-3.12.0-6
               gobject-introspection-runtime-1.74.0-1  gperftools-2.10-1
               graphviz-7.0.2-1  grep-3.8-2  groff-1.22.4-7
               grub-2:2.06.r380.g151467888-1  gssdp-1.6.2-1
               gst-plugin-gtk-1.20.4-3  gst-plugins-bad-1.20.4-3
               gst-plugins-bad-libs-1.20.4-3  gst-plugins-good-1.20.4-3
               gst-plugins-ugly-1.20.4-3  gtk-engines-2.21.0-5  gtk4-1:4.8.2-1
               gtksourceview5-5.6.1-1  gts-0.7.6.121130-2  gupnp-1:1.6.2-1
               gupnp-igd-1.2.0-3  highway-1.0.2-1  hplip-1:3.22.10-1
               imagemagick-7.1.0.52-1  imlib2-1.9.1-2  jasper-3.0.6-1
               java-environment-common-3-3  jdk-openjdk-19.0.1.u10-3
               jdk11-openjdk-11.0.17.u1-1  jsoncpp-1.9.5-2  lensfun-1:0.3.3-1
               lib32-at-spi2-core-2.46.0-2  lib32-cairo-1.17.6-2
               lib32-fribidi-1.0.12-1  lib32-gdk-pixbuf2-2.42.10-1
               lib32-gmp-6.2.1-1  lib32-gnutls-3.7.8-1  lib32-gtk2-2.24.33-2
               lib32-libcups-2.4.2-2  lib32-libdatrie-0.2.13-2
               lib32-libtasn1-4.19.0-1  lib32-libthai-0.1.29-2
               lib32-libxcomposite-0.4.5-2  lib32-libxft-2.3.6-1
               lib32-libxinerama-1.1.5-1  lib32-nettle-3.8.1-1
               lib32-p11-kit-0.24.1-1  lib32-pango-1:1.50.12-1
               lib32-pixman-0.42.2-1  libadwaita-1:1.2.0-1  libao-1.2.2-5
               libavtp-0.2.0-1  libbsd-0.11.7-1  libcaca-0.99.beta20-1
               libdispatch-5.5.0-1  libdv-1.0.0-9  libev-4.33-2
               libfdk-aac-2.0.2-1  libfreeaptx-0.1.1-1  libgee-0.20.6-1
               libgexiv2-0.14.0-3  libgme-0.6.3-1  libgusb-0.4.2-1
               libimagequant-4.0.4-1  libinstpatch-1.1.6-1  libjxl-0.7.0-3
               libkate-0.4.1-8  libkeybinder2-0.3.1-4  libldac-2.0.2.3-1
               liblouis-3.23.0-1  liblqr-0.4.2-3  liblrdf-0.6.1-4
               libltc-1.3.2-1  libmd-1.0.4-1  libmediainfo-22.09-1
               libmicrodns-0.2.0-1  libmms-0.6.4-3  libmng-2.0.3-3
               libmypaint-1.6.1-1  libnice-0.1.19-1  libopenmpt-0.6.6-2
               libotf-0.9.16-3  libpipeline-1.5.7-1  libportal-0.6-1
               libportal-gtk3-0.6-1  libraqm-0.9.0-1  libraw-0.20.2-2
               libshout-1:2.4.6-2  libsidplay-1.36.59-10  libsigc++-3.0-3.2.0-1
               libspeechd-0.11.4-1  libspiro-1:20221101-1  libsrtp-1:2.4.2-1
               libusb-compat-0.1.7-1  libutempter-1.2.1-3  libwmf-0.2.12-2
               libwnck-2.31.0-3  libx86-1.1-8  libxcvt-0.1.2-1
               libxfont2-2.0.6-1  libxnvctrl-520.56.06-1  libxres-1.2.1-1
               libzen-0.4.39-1  lua-5.4.4-2  lua53-5.3.6-1  luit-20221028-1
               lxappearance-0.6.3-4  lxpanel-0.10.1-1  m17n-db-1.8.0-3
               m17n-lib-1.8.0-13  m4-1.4.19-1  mariadb-clients-10.9.4-2
               mjpegtools-2.2.1-1  mkinitcpio-33-1  mkinitcpio-busybox-1.35.0-1
               mkvtoolnix-cli-72.0.0-1  multiload-ng-common-1.5.2-3
               mypaint-brushes1-1.3.1-1  netpbm-10.73.37-2  node-gyp-9.3.0-1
               nodejs-19.1.0-1  nodejs-nopt-7.0.0-1  npm-8.19.2-1
               ntfs-3g-2022.10.3-1  openbox-3.6.1-9  openssl-1.0-1.0.2.u-1
               openssl-1.1-1.1.1.s-2  opusfile-0.12-3  package-query-1.12-1
               pacman-6.0.2-5  pacman-mirrorlist-20221016-1  pahole-1:1.24-1
               pango-perl-1.227-15  perl-alien-build-2.72-1
               perl-alien-libxml2-0.19-1  perl-cairo-gobject-1.004-12
               perl-capture-tiny-0.48-6  perl-dbi-1.643-4  perl-error-0.17029-4
               perl-ffi-checklib-0.31-2  perl-file-chdir-0.1011-4
               perl-file-which-1.27-2  perl-glib-object-introspection-0.049-3
               perl-gtk3-0.038-2  perl-libintl-perl-1.32-3
               perl-locale-gettext-1.07-12  perl-mailtools-2.21-6
               perl-path-tiny-0.142-1  perl-xml-libxml-2.0208-1
               perl-xml-namespacesupport-1.12-4  perl-xml-sax-1.02-1
               perl-xml-sax-base-1.09-4  python-async-timeout-4.0.2-1
               python-cairo-1.22.0-1  python-colorama-0.4.6-1
               python-commonmark-0.9.1-6  python-deprecation-2.1.0-6
               python-docutils-1:0.19-2  python-future-0.18.2-7
               python-gobject-3.42.2-1  python-ifaddr-0.2.0-1
               python-msgpack-1.0.4-1  python-netifaces-0.11.0-3
               python-pikepdf-6.2.4-1  python-pillow-9.3.0-1
               python-pycups-2.0.1-5  python-pycurl-7.45.1-2
               python-pygments-2.13.0-1  python-zeroconf-0.39.4-1
               python-zipp-3.10.0-1  python2-pyparsing-2.4.7-6
               qrencode-4.1.1-1  qt6-5compat-6.4.1-1  qt6-imageformats-6.4.1-1
               qt6-multimedia-6.4.1-1  qt6-multimedia-ffmpeg-6.4.1-1
               qt6-svg-6.4.1-1  qt6-wayland-6.4.1-1  rhash-1.4.3-1
               rnnoise-0.4.1-1  rtmpdump-1:2.4.r99.f1b83c1-2  sbc-2.0-1
               sdl2_image-2.6.2-2  seatd-0.7.0-2  sed-4.8-1  semver-7.3.8-1
               smartmontools-7.3-1  source-highlight-3.1.9-9  spandsp-0.0.6-3
               squashfs-tools-4.5.1-2  sudo-1.9.12.p1-1  suitesparse-6.0.1-1
               svt-hevc-1.5.1-2  tinyxml2-9.0.0-1  totem-pl-parser-3.26.6-2
               traceroute-2.1.0-5  tre-0.8.0-6  ttf-opensans-1.101-2
               vte-common-0.70.1-1  vte-legacy-0.28.2-10  wget-1.21.3-1
               which-2.21-5  wildmidi-0.4.4-1  wimlib-1.13.6-2
               wireless_tools-30.pre9-3  xbitmaps-1.1.2-3  xcb-util-xrm-1.3-2
               xdotool-3.20211022.1-1  xf86-input-libinput-1.2.1-1
               xorg-server-common-21.1.4-1  xorg-setxkbmap-1.3.3-1
               xorg-xauth-1.1.2-1  xorg-xkbcomp-1.4.5-1  xorg-xmodmap-1.0.11-1
               xorg-xrdb-1.2.1-1  xterm-376-1  yajl-2.1.0-5  zbar-0.23.90-1
               zip-3.0-10  zvbi-0.2.37-1  zxing-cpp-1.4.0-1
               adobe-source-han-sans-jp-fonts-2.004-1  alsa-utils-1.2.8-1
               amule-1:2.3.3-5  android-file-transfer-4.2-3
               android-tools-33.0.3-2  ant-1.10.12-2  antimicrox-2.25-1
               apache-2.4.54-3  arch-install-scripts-28-1
               archlinux-keyring-20221123-1  atari800-3.1.0-3
               audio-recorder-2.2.3-3  autoconf-2.71-1  automake-1.16.5-1
               avidemux-qt-2.8.1-1  bison-3.8.2-4  boost-1.80.0-3
               brasero-3.12.3+r24+gd01ba738-1  brltty-6.5-3
               castnow-git-r203.0e1746b-1  cfourcc-0.1.3.1-1  chntpw-140201-4
               chromium-107.0.5304.121-1  chromium-widevine-1:4.10.1679.0-1
               conky-1.15.0-1  cpu-monitor-extension-lxpanel-plugin-1.5-1
               djview-4.12-3  doxygen-1.9.5-1  dpkg-1.21.9-1  ecm-tools-1.03-3
               edid-decode-git-r171.f56f329-1  elfutils-0.187-2
               emulationstation-themes-0.2-1  enet-1.3.17-1
               extra-cmake-modules-5.100.0-1  fakeroot-1.30.1-1
               fatsort-1.6.4.625-1  fbpanel-7.0-2  fbset-2.1-7
               fcitx-anthy-0.2.4-1  feh-3.9.1-2  ffnvcodec-headers-11.1.5.2-1
               file-roller-43.0-1  flashplugin-32.0.0.453-1  flex-2.6.4-3
               florence-0.6.3-2  fx_cast-0.1.0-1  gaupol-1.11-1  gdb-12.1-2
               geany-1.38-3  gendesk-1.0.9-3  gftp-2.9.1b-3  ghex-43.0-1
               gimp-plugin-bimp-2.0-1  gnome-calculator-43.0.1-1
               gnome-icon-theme-3.12.0-6  gnome-screenshot-41.0+r25+g45f08f0-1
               gparted-1.4.0-1  gpicview-0.2.5-7  gprename-20220807-1
               grub-reboot-poweroff-0.1.0.r2.g20d6bcc-2  gsmartcontrol-1.1.4-1
               gtest-1.12.1-1  gtksourceview4-4.8.4-1  haveged-1.9.18-1
               hdparm-9.65-1  hpoj-0.91-21  hunspell-it-2.4-11  i3-wm-4.21.1-1
               iat-0.1.7-4  img2pdf-0.4.4-1  inetutils-2.3-1  inxi-2.3.56-1
               iputils-20211215-1  java-service-wrapper-3.5.49-1  jmtpfs-0.5-2
               jpegoptim-1.5.0-1  js78-78.15.0-4
               jstest-gtk-git-0.1.0.r78.g3d8af5d-1  kidletime-5.100.0-1
               leafpad-0.8.18.1-9  leptonica-1.82.0-2  lftp-4.9.2-1
               lib32-gtk-engines-2.21.0-3  lib32-libpng12-1.2.59-2
               lib32-libtxc_dxtn-1.0.1-5  lib32-ncurses5-compat-libs-6.1-2
               lib32-openssl-1.0-1.0.2.u-2  lib32-pcre-8.45-3
               lib32-readline-8.2.001-2  libcddb-1.3.2-6  libcmis-0.5.2-12
               libcroco-0.6.13-2  libibus-1.5.27-1  libofa-0.9.3-9
               libpipewire02-0.2.7-2  libpng12-1.2.59-2  libstatgrab-0.92.1-1
               libva-utils-2.16.0-1  licenses-20220125-1
               linux-headers-6.0.9.arch1-1  linux-lts-5.15.79-1
               linux-lts-headers-5.15.79-1  lsb-release-2.0.r48.3cf5103-1
               lxappearance-obconf-0.2.3-3  lxde-common-0.99.2-3
               lxhotkey-0.1.1-2  lxinput-0.3.5-3  lxlauncher-0.2.5-4
               lxpanel-multiload-ng-plugin-gtk2-1.5.2-3  lxrandr-0.3.2-3
               lxsession-1:0.5.5-1  lxtask-0.1.10-2  lxterminal-gtk2-0.3.1-2
               lzip-1.23-2  macchanger-1.7.0-5  man-db-2.11.1-1
               man-pages-6.01-1  mariadb-10.9.4-2  mediainfo-22.09-1
               megatools-1.11.0+20220519-1  memtest86+-6.00-2
               mercurial-6.3.1-1  metis-5.1.0.p10-2  miniupnpc-2.2.4-1
               minizip-ng-3.0.7-2  mkvtoolnix-gui-72.0.0-1  mp3wrap-0.5-6
               mtpfs-1.1-4  nano-7.0-1  ncurses5-compat-libs-6.1-1
               ninja-1.11.1-2  nload-0.7.4-7  nmap-7.93-1
               noto-fonts-emoji-20220920-1  noto-fonts-sc-20170603-2
               ntp-4.2.8.p15-2  numlockx-1.2-5  obconf-2.0.4-8
               otf-ipafont-003.03-8  pacaur-4.7.90-1  parcellite-1.2.1-4
               pasystray-0.8.0-2  pcmciautils-018-7  pdfgrep-2.1.2-2
               perl-archive-zip-1.68-7  perl-rename-1.11-1  pkgconf-1.8.0-1
               pkgfile-21-2  powerstat-git-0.02.15.r0.gbb31d9f-1
               powertop-2.15-1  progsreiserfs-0.3.0.5-10
               python-cachecontrol-1:0.12.11-1  python-contextlib2-21.6.0-1
               python-distlib-0.3.6-1  python-importlib-metadata-5.0.0-1
               python-nspektr-0.4.0-2  python-platformdirs-2.5.4-1
               python-progress-1.6-5  python-pyaudio-0.2.12-1
               python-pychromecast-git-458.00027dc-1  python-resolvelib-0.9.0-1
               python-retrying-1.3.3-13  python-rich-12.6.0-2
               python-tenacity-8.1.0-1  python-toml-0.10.2-8
               python2-appdirs-1.4.4-6  python2-ordered-set-3.1.1-4
               python2-packaging-20.9-7  qjoypad-4.3.0-2
               qt5-quickcontrols2-5.15.7+kde+r6-1  qt5ct-1.5-2
               qvkbd-git20190819-1  rar-5.5.0-1  read-edid-3.0.2-4
               rest-0.8.1+r4+ge5ee6ef-1  scalpel-git-r24.47815c2-1
               scantailor-advanced-1.0.16-4  sdl2_gfx-1:1.0.4-2
               sdl2_mixer-2.6.2-1  semt-1.1.1-1  sensors-lxpanel-plugin-1.7-2
               sfml-2.5.1-3  simplescreenrecorder-0.4.4-1  smpeg-2.0.0-2
               snapd-2.39.2-1  sndio-1.9.0-1  spectre-meltdown-checker-0.45-1
               sshfs-3.7.3-1  strace-6.0-1  sub2srt-0.5.5-3
               subtitleripper-0.3_4-1  swig-4.0.2-5
               system-config-printer-1.5.18-1  t1lib-5.1.2-8  tcsh-6.24.02-1
               telegram-desktop-4.3.4-1  testdisk-7.1-4  texinfo-7.0-1
               tixati-3.11-1  transcode-1.1.7-40  translate-shell-git-0.9.6.8-1
               tree-2.0.4-1  trickle-1.07-11  ttf-baekmuk-2.2-13
               ttf-hannom-2005-6  ttf-indic-otf-0.2-11
               ttf-sazanami-20040629-11  tvtime-1.0.11-4  ucl-1.03-9
               uim-1.8.8-5  upx-4.0.1-1  uriparser-0.9.7-1  v4l2ucp-2.0.2-6
               vdhcoapp-bin-1.2.4-2  vi-1:070224-6  vice-3.6.1-2
               vlfeat-0.9.20-1  vnstat-2.10-1  vsftpd-3.0.3-8  waf-2.0.24-2
               weston-11.0.0-1  winff-1.5.4-3  woeusb-5.2.2-1
               wondershaper-git-20130306-2  xbindkeys-1.8.7-4
               xchat-se-1.2.21-1  xf86-input-mouse-1.9.3-1
               xf86-video-ati-1:19.1.0.r15.g7a6a34af-1  xf86-video-vesa-2.5.0-3
               xorg-server-21.1.4-1  xorg-xinit-1.4.1-3  xorg-xlsfonts-1.0.7-1
               yaourt-1.9-1  yay-11.2.0-1  zd1211-firmware-1.5-3
               zeit-git-0.5.0.r46.g8ea139d-1  zsh-5.9-1

Total Removed Size:  3603.36 MiB

:: Do you want to remove these packages? [Y/n] n

why?

Last edited by quellen (2022-12-11 09:00:36)


sorry for my bad english

Offline

#2 2022-12-11 09:11:35

ProfessorNavigator
Member
Registered: 2022-11-24
Posts: 2

Re: Removing unused packages (orphans)

It could happen. Batter not to remove orphaned packages automatically. Do:

pacman -Qdt

Check showed list, then remove everything you do not need any more by:

pacman -Rs 'package'

Such way is much more safe.

Offline

#3 2022-12-11 09:24:15

mpan
Member
Registered: 2012-08-01
Posts: 1,250
Website

Re: Removing unused packages (orphans)

quellen: you did not provide the output of `pacman -Qdtq`, so is hard to tell, what is being removed and why.

ProfessorNavigator: `pacman -Qdt` lists only orphans, which are never needed.


Sometimes I seem a bit harsh — don’t get offended too easily!

Offline

#4 2022-12-11 09:59:46

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

pacman -Qdt and pacman -Qdtq seems to have the same output. but they aren't unused packages.

$ pacman -Qdt
adobe-source-han-sans-jp-fonts 2.004-1
alsa-utils 1.2.8-1
amule 1:2.3.3-5
android-file-transfer 4.2-3
android-tools 33.0.3-2
ant 1.10.12-2
antimicrox 2.25-1
apache 2.4.54-3
arch-install-scripts 28-1
archlinux-keyring 20221123-1
atari800 3.1.0-3
audio-recorder 2.2.3-3
autoconf 2.71-1
automake 1.16.5-1
avidemux-qt 2.8.1-1
bison 3.8.2-4
boost 1.80.0-3
brasero 3.12.3+r24+gd01ba738-1
brltty 6.5-3
castnow-git r203.0e1746b-1
cfourcc 0.1.3.1-1
chntpw 140201-4
chromium 107.0.5304.121-1
chromium-widevine 1:4.10.1679.0-1
conky 1.15.0-1
cpu-monitor-extension-lxpanel-plugin 1.5-1
djview 4.12-3
doxygen 1.9.5-1
dpkg 1.21.9-1
ecm-tools 1.03-3
edid-decode-git r171.f56f329-1
elfutils 0.187-2
emulationstation-themes 0.2-1
enet 1.3.17-1
extra-cmake-modules 5.100.0-1
fakeroot 1.30.1-1
fatsort 1.6.4.625-1
fbpanel 7.0-2
fbset 2.1-7
fcitx-anthy 0.2.4-1
feh 3.9.1-2
ffnvcodec-headers 11.1.5.2-1
file-roller 43.0-1
flashplugin 32.0.0.453-1
flex 2.6.4-3
florence 0.6.3-2
fx_cast 0.1.0-1
gaupol 1.11-1
gdb 12.1-2
geany 1.38-3
gendesk 1.0.9-3
gftp 2.9.1b-3
ghex 43.0-1
gimp-plugin-bimp 2.0-1
gnome-calculator 43.0.1-1
gnome-icon-theme 3.12.0-6
gnome-screenshot 41.0+r25+g45f08f0-1
gparted 1.4.0-1
gpicview 0.2.5-7
gprename 20220807-1
grub-reboot-poweroff 0.1.0.r2.g20d6bcc-2
gsmartcontrol 1.1.4-1
gtest 1.12.1-1
gtksourceview4 4.8.4-1
haveged 1.9.18-1
hdparm 9.65-1
hpoj 0.91-21
hunspell-it 2.4-11
i3-wm 4.21.1-1
iat 0.1.7-4
img2pdf 0.4.4-1
inetutils 2.3-1
inxi 2.3.56-1
iputils 20211215-1
java-service-wrapper 3.5.49-1
jmtpfs 0.5-2
jpegoptim 1.5.0-1
js78 78.15.0-4
jstest-gtk-git 0.1.0.r78.g3d8af5d-1
kidletime 5.100.0-1
leafpad 0.8.18.1-9
leptonica 1.82.0-2
lftp 4.9.2-1
lib32-gtk-engines 2.21.0-3
lib32-libpng12 1.2.59-2
lib32-libtxc_dxtn 1.0.1-5
lib32-ncurses5-compat-libs 6.1-2
lib32-openssl-1.0 1.0.2.u-2
lib32-pcre 8.45-3
lib32-readline 8.2.001-2
libcddb 1.3.2-6
libcmis 0.5.2-12
libcroco 0.6.13-2
libibus 1.5.27-1
libofa 0.9.3-9
libpipewire02 0.2.7-2
libpng12 1.2.59-2
libstatgrab 0.92.1-1
libva-utils 2.16.0-1
licenses 20220125-1
linux-headers 6.0.9.arch1-1
linux-lts 5.15.79-1
linux-lts-headers 5.15.79-1
lsb-release 2.0.r48.3cf5103-1
lxappearance-obconf 0.2.3-3
lxde-common 0.99.2-3
lxhotkey 0.1.1-2
lxinput 0.3.5-3
lxlauncher 0.2.5-4
lxpanel-multiload-ng-plugin-gtk2 1.5.2-3
lxrandr 0.3.2-3
lxsession 1:0.5.5-1
lxtask 0.1.10-2
lxterminal-gtk2 0.3.1-2
lzip 1.23-2
macchanger 1.7.0-5
man-db 2.11.1-1
man-pages 6.01-1
mariadb 10.9.4-2
mediainfo 22.09-1
megatools 1.11.0+20220519-1
memtest86+ 6.00-2
mercurial 6.3.1-1
metis 5.1.0.p10-2
miniupnpc 2.2.4-1
minizip-ng 3.0.7-2
mkvtoolnix-gui 72.0.0-1
mp3wrap 0.5-6
mtpfs 1.1-4
nano 7.0-1
ncurses5-compat-libs 6.1-1
ninja 1.11.1-2
nload 0.7.4-7
nmap 7.93-1
noto-fonts-emoji 20220920-1
noto-fonts-sc 20170603-2
ntp 4.2.8.p15-2
numlockx 1.2-5
obconf 2.0.4-8
otf-ipafont 003.03-8
pacaur 4.7.90-1
parcellite 1.2.1-4
pasystray 0.8.0-2
pcmciautils 018-7
pdfgrep 2.1.2-2
perl-archive-zip 1.68-7
perl-rename 1.11-1
pkgconf 1.8.0-1
pkgfile 21-2
powerstat-git 0.02.15.r0.gbb31d9f-1
powertop 2.15-1
progsreiserfs 0.3.0.5-10
python-cachecontrol 1:0.12.11-1
python-contextlib2 21.6.0-1
python-distlib 0.3.6-1
python-importlib-metadata 5.0.0-1
python-nspektr 0.4.0-2
python-platformdirs 2.5.4-1
python-progress 1.6-5
python-pyaudio 0.2.12-1
python-pychromecast-git 458.00027dc-1
python-resolvelib 0.9.0-1
python-retrying 1.3.3-13
python-rich 12.6.0-2
python-tenacity 8.1.0-1
python-toml 0.10.2-8
python2-appdirs 1.4.4-6
python2-ordered-set 3.1.1-4
python2-packaging 20.9-7
qjoypad 4.3.0-2
qt5-quickcontrols2 5.15.7+kde+r6-1
qt5ct 1.5-2
qvkbd git20190819-1
rar 5.5.0-1
read-edid 3.0.2-4
rest 0.8.1+r4+ge5ee6ef-1
scalpel-git r24.47815c2-1
scantailor-advanced 1.0.16-4
sdl2_gfx 1:1.0.4-2
sdl2_mixer 2.6.2-1
semt 1.1.1-1
sensors-lxpanel-plugin 1.7-2
sfml 2.5.1-3
simplescreenrecorder 0.4.4-1
smpeg 2.0.0-2
snapd 2.39.2-1
sndio 1.9.0-1
spectre-meltdown-checker 0.45-1
sshfs 3.7.3-1
strace 6.0-1
sub2srt 0.5.5-3
subtitleripper 0.3_4-1
swig 4.0.2-5
system-config-printer 1.5.18-1
t1lib 5.1.2-8
tcsh 6.24.02-1
telegram-desktop 4.3.4-1
testdisk 7.1-4
texinfo 7.0-1
tixati 3.11-1
transcode 1.1.7-40
translate-shell-git 0.9.6.8-1
tree 2.0.4-1
trickle 1.07-11
ttf-baekmuk 2.2-13
ttf-hannom 2005-6
ttf-indic-otf 0.2-11
ttf-sazanami 20040629-11
tvtime 1.0.11-4
ucl 1.03-9
uim 1.8.8-5
upx 4.0.1-1
uriparser 0.9.7-1
v4l2ucp 2.0.2-6
vdhcoapp-bin 1.2.4-2
vi 1:070224-6
vice 3.6.1-2
vlfeat 0.9.20-1
vnstat 2.10-1
vsftpd 3.0.3-8
waf 2.0.24-2
weston 11.0.0-1
winff 1.5.4-3
woeusb 5.2.2-1
wondershaper-git 20130306-2
xbindkeys 1.8.7-4
xchat-se 1.2.21-1
xf86-input-mouse 1.9.3-1
xf86-video-ati 1:19.1.0.r15.g7a6a34af-1
xf86-video-vesa 2.5.0-3
xorg-server 21.1.4-1
xorg-xinit 1.4.1-3
xorg-xlsfonts 1.0.7-1
yaourt 1.9-1
yay 11.2.0-1
zd1211-firmware 1.5-3
zeit-git 0.5.0.r46.g8ea139d-1
zsh 5.9-1
$ pacman -Qdtq
adobe-source-han-sans-jp-fonts
alsa-utils
amule
android-file-transfer
android-tools
ant
antimicrox
apache
arch-install-scripts
archlinux-keyring
atari800
audio-recorder
autoconf
automake
avidemux-qt
bison
boost
brasero
brltty
castnow-git
cfourcc
chntpw
chromium
chromium-widevine
conky
cpu-monitor-extension-lxpanel-plugin
djview
doxygen
dpkg
ecm-tools
edid-decode-git
elfutils
emulationstation-themes
enet
extra-cmake-modules
fakeroot
fatsort
fbpanel
fbset
fcitx-anthy
feh
ffnvcodec-headers
file-roller
flashplugin
flex
florence
fx_cast
gaupol
gdb
geany
gendesk
gftp
ghex
gimp-plugin-bimp
gnome-calculator
gnome-icon-theme
gnome-screenshot
gparted
gpicview
gprename
grub-reboot-poweroff
gsmartcontrol
gtest
gtksourceview4
haveged
hdparm
hpoj
hunspell-it
i3-wm
iat
img2pdf
inetutils
inxi
iputils
java-service-wrapper
jmtpfs
jpegoptim
js78
jstest-gtk-git
kidletime
leafpad
leptonica
lftp
lib32-gtk-engines
lib32-libpng12
lib32-libtxc_dxtn
lib32-ncurses5-compat-libs
lib32-openssl-1.0
lib32-pcre
lib32-readline
libcddb
libcmis
libcroco
libibus
libofa
libpipewire02
libpng12
libstatgrab
libva-utils
licenses
linux-headers
linux-lts
linux-lts-headers
lsb-release
lxappearance-obconf
lxde-common
lxhotkey
lxinput
lxlauncher
lxpanel-multiload-ng-plugin-gtk2
lxrandr
lxsession
lxtask
lxterminal-gtk2
lzip
macchanger
man-db
man-pages
mariadb
mediainfo
megatools
memtest86+
mercurial
metis
miniupnpc
minizip-ng
mkvtoolnix-gui
mp3wrap
mtpfs
nano
ncurses5-compat-libs
ninja
nload
nmap
noto-fonts-emoji
noto-fonts-sc
ntp
numlockx
obconf
otf-ipafont
pacaur
parcellite
pasystray
pcmciautils
pdfgrep
perl-archive-zip
perl-rename
pkgconf
pkgfile
powerstat-git
powertop
progsreiserfs
python-cachecontrol
python-contextlib2
python-distlib
python-importlib-metadata
python-nspektr
python-platformdirs
python-progress
python-pyaudio
python-pychromecast-git
python-resolvelib
python-retrying
python-rich
python-tenacity
python-toml
python2-appdirs
python2-ordered-set
python2-packaging
qjoypad
qt5-quickcontrols2
qt5ct
qvkbd
rar
read-edid
rest
scalpel-git
scantailor-advanced
sdl2_gfx
sdl2_mixer
semt
sensors-lxpanel-plugin
sfml
simplescreenrecorder
smpeg
snapd
sndio
spectre-meltdown-checker
sshfs
strace
sub2srt
subtitleripper
swig
system-config-printer
t1lib
tcsh
telegram-desktop
testdisk
texinfo
tixati
transcode
translate-shell-git
tree
trickle
ttf-baekmuk
ttf-hannom
ttf-indic-otf
ttf-sazanami
tvtime
ucl
uim
upx
uriparser
v4l2ucp
vdhcoapp-bin
vi
vice
vlfeat
vnstat
vsftpd
waf
weston
winff
woeusb
wondershaper-git
xbindkeys
xchat-se
xf86-input-mouse
xf86-video-ati
xf86-video-vesa
xorg-server
xorg-xinit
xorg-xlsfonts
yaourt
yay
zd1211-firmware
zeit-git
zsh

I think I will manually remove unneeded packages.

Last edited by quellen (2022-12-11 10:23:32)


sorry for my bad english

Offline

#5 2022-12-11 12:18:21

mpan
Member
Registered: 2012-08-01
Posts: 1,250
Website

Re: Removing unused packages (orphans)

Almost all packages in your system are marked as being dependencies. Since most of what I see could only be installed explicitly,⁽¹⁾ you must have set them as such yourself by invoking `pacman -D --asdeps` on pretty much entire system. Since they are now marked as dependencies and clearly they are not dependencies, `pacman -Qdt` reports them as orphans.

For all practical purposes, at this point pacman’s local database is garbage. To fix that, go over each and every package (one by one) and use `pacman -D --asexplicit` to fix those, which should be installed explicitly. pacman’s log may be helpful in determining, which packages were affected. But it should not be trusted blindly: you can only use it as a hint.
____
⁽¹⁾ Technically possible to not be true, but it’s impossible with official packages only.

Last edited by mpan (2022-12-11 12:18:35)


Sometimes I seem a bit harsh — don’t get offended too easily!

Offline

#6 2022-12-11 14:07:46

astralc
Member
Registered: 2022-09-17
Posts: 74

Re: Removing unused packages (orphans)

I wonder why pacman is in the remove list in the first post. it should be dependency of 'base', that is only explicitly installed.
also: yaourt & python2-*. How old is the install? do you have 'base' installed there?

Offline

#7 2022-12-11 14:15:01

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,805

Re: Removing unused packages (orphans)

If you really want to know why, post your entire pacman.log.

Offline

#8 2022-12-11 14:25:18

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

i installed Archlinux on 2018.
pacman.log:
http://quellen.altervista.org/pacman.log.zip


sorry for my bad english

Offline

#9 2022-12-11 14:30:39

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,912
Website

Re: Removing unused packages (orphans)

I don't (yet) see anything that would directly explain these symptoms, but I do see a long history of partial upgrades.  In fact, it looks like most of them were immediately after an attempt to install a package failed.  This will cause all sorts of breakage ... just to my knowledge, not the variety currently being dealt with in this thread.


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#10 2022-12-11 14:34:32

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,805

Re: Removing unused packages (orphans)

[2022-03-01T19:02:31+0100] [PACMAN] Running 'pacman -D --asdeps adobe-source-han-sans-jp-fonts alsa-utils amule android-file-transfer android-tools android-udev anki anthy antimicrox apache arch-install-scripts atari800 audacity audio-recorder autoconf automake avidemux-qt bash binutils bison boost brasero bzip2 calibre castnow-git cdemu-client cdrdao cdrtools cfourcc chntpw chromium chromium-widevine cmake conky coreutils cower cpu-monitor-extension-lxpanel-plugin cryptsetup cups dbus-python device-mapper dhclient dhcpcd dialog diffutils djview dmidecode dosbox dosemu dosfstools dpkg dvd+rw-tools e2fsprogs ecm-tools edid-decode-git emulationstation-themes epub2txt-git evince fakeroot fatsort fbpanel fbset fcitx-anthy feh file file-roller filesystem findutils firefox firefox-i18n-it flashplugin flex florence fonts-tlwg foomatic-db-gutenprint-ppds fx_cast gaupol gawk gcc gcc-libs gcdemu gdb geany gettext gftp ghex gimp gimp-plugin-bimp glibc gnome-calculator gnome-icon-theme gnome-screenshot google-earth-pro gpart gparted gpicview gprename grep grub grub-reboot-poweroff gsmartcontrol gtk-engines gutenprint gvfs gvfs-mtp gzip haveged hdparm hplip hpoj hunspell-it i3-wm iat imagemagick img2pdf inetutils intel-ucode inxi ipp-usb iproute2 iputils jack2 jdk-openjdk jfsutils jmtpfs jpegoptim jre-openjdk jstest-gtk-git leafpad leptonica less lftp lib32-alsa-lib lib32-alsa-plugins lib32-gtk-engines lib32-jack2 lib32-libpng12 lib32-libpulse lib32-libtxc_dxtn lib32-mpg123 lib32-ncurses5-compat-libs lib32-openssl-1.0 lib32-simplescreenrecorder lib32-vkd3d libisoburn libmicrodns libpng12 libretro-mame2010-git libstatgrab libva-intel-driver libva-utils licenses linux linux-headers linux-lts linux-lts-headers logrotate lsb-release lvm2 lxappearance lxappearance-obconf lxde-common lxde-icon-theme lxhotkey lxinput lxlauncher lxpanel lxpanel-multiload-ng-plugin-gtk2 lxrandr lxsession lxtask lxterminal-gtk2 lzip m4 macchanger make man-db man-pages mariadb mdadm mediainfo megatools memtest86+ mencoder mesa-demos mkvtoolnix-gui mp3wrap mpv mtools mtpfs nano ncurses5-compat-libs net-tools netctl networkmanager nload nmap noto-fonts-emoji noto-fonts-sc nss-mdns ntfs-3g ntp numlockx obconf openbox openssh openssl-1.0 os-prober otf-ipafont p7zip pacaur package-query pacman parcellite pasystray patch pavucontrol pciutils pcloudcc pcmanfm pcmciautils pdfgrep pepper-flash perl perl-archive-zip perl-file-mimeinfo perl-rename phoronix-test-suite pkgconf pkgfile podofo poppler powerstat-git powertop procps-ng protobuf psmisc pulseaudio pulseaudio-alsa python-cairo python-pychromecast-git python-requests qemu qjoypad qrencode qt5ct qvkbd rar read-edid reiserfsprogs retroarch retroarch-assets-xmb s-nail scalpel-git scantailor-advanced sdl2_gfx sdl2_mixer sed semt sensors-lxpanel-plugin shadow sigil simplescreenrecorder smartmontools snapd spectre-meltdown-checker sshfs strace sub2srt subtitleripper sudo syncthing sysfsutils syslinux system-config-printer systemd-sysvcompat tagainijisho-git tar tcsh telegram-desktop testdisk texinfo tixati tor-browser traceroute transcode translate-shell-git tree trickle ttf-baekmuk ttf-bitstream-vera ttf-dejavu ttf-hannom ttf-indic-otf ttf-ms-fonts ttf-sazanami tvtime uim unace unetbootin unrar upx usbutils util-linux v4l2ucp vdhcoapp-bin vi vice virtualbox vlfeat vnstat vsftpd vte-legacy vulkan-intel weston wget which wine wine-mono winetricks winff woeusb wondershaper-git wpa_supplicant xbindkeys xchat-se xf86-input-mouse xf86-video-ati xf86-video-vesa xfsprogs xorg-server xorg-xdpyinfo xorg-xinit xorg-xlsfonts xsane xterm yaourt yay yt-dlp zd1211-firmware zeit-git zenity zsh'

This is why, you specifically ran a command on March 1st that set the install reason for all of those as deps. That, combined with not watching the news (https://archlinux.org/news/base-group-r … -required/).

Offline

#11 2022-12-11 17:48:40

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

Scimmia wrote:
[2022-03-01T19:02:31+0100] [PACMAN] Running 'pacman -D --asdeps adobe-source-han-sans-jp-fonts alsa-utils amule android-file-transfer android-tools android-udev anki anthy antimicrox apache arch-install-scripts atari800 audacity audio-recorder autoconf automake avidemux-qt bash binutils bison boost brasero bzip2 calibre castnow-git cdemu-client cdrdao cdrtools cfourcc chntpw chromium chromium-widevine cmake conky coreutils cower cpu-monitor-extension-lxpanel-plugin cryptsetup cups dbus-python device-mapper dhclient dhcpcd dialog diffutils djview dmidecode dosbox dosemu dosfstools dpkg dvd+rw-tools e2fsprogs ecm-tools edid-decode-git emulationstation-themes epub2txt-git evince fakeroot fatsort fbpanel fbset fcitx-anthy feh file file-roller filesystem findutils firefox firefox-i18n-it flashplugin flex florence fonts-tlwg foomatic-db-gutenprint-ppds fx_cast gaupol gawk gcc gcc-libs gcdemu gdb geany gettext gftp ghex gimp gimp-plugin-bimp glibc gnome-calculator gnome-icon-theme gnome-screenshot google-earth-pro gpart gparted gpicview gprename grep grub grub-reboot-poweroff gsmartcontrol gtk-engines gutenprint gvfs gvfs-mtp gzip haveged hdparm hplip hpoj hunspell-it i3-wm iat imagemagick img2pdf inetutils intel-ucode inxi ipp-usb iproute2 iputils jack2 jdk-openjdk jfsutils jmtpfs jpegoptim jre-openjdk jstest-gtk-git leafpad leptonica less lftp lib32-alsa-lib lib32-alsa-plugins lib32-gtk-engines lib32-jack2 lib32-libpng12 lib32-libpulse lib32-libtxc_dxtn lib32-mpg123 lib32-ncurses5-compat-libs lib32-openssl-1.0 lib32-simplescreenrecorder lib32-vkd3d libisoburn libmicrodns libpng12 libretro-mame2010-git libstatgrab libva-intel-driver libva-utils licenses linux linux-headers linux-lts linux-lts-headers logrotate lsb-release lvm2 lxappearance lxappearance-obconf lxde-common lxde-icon-theme lxhotkey lxinput lxlauncher lxpanel lxpanel-multiload-ng-plugin-gtk2 lxrandr lxsession lxtask lxterminal-gtk2 lzip m4 macchanger make man-db man-pages mariadb mdadm mediainfo megatools memtest86+ mencoder mesa-demos mkvtoolnix-gui mp3wrap mpv mtools mtpfs nano ncurses5-compat-libs net-tools netctl networkmanager nload nmap noto-fonts-emoji noto-fonts-sc nss-mdns ntfs-3g ntp numlockx obconf openbox openssh openssl-1.0 os-prober otf-ipafont p7zip pacaur package-query pacman parcellite pasystray patch pavucontrol pciutils pcloudcc pcmanfm pcmciautils pdfgrep pepper-flash perl perl-archive-zip perl-file-mimeinfo perl-rename phoronix-test-suite pkgconf pkgfile podofo poppler powerstat-git powertop procps-ng protobuf psmisc pulseaudio pulseaudio-alsa python-cairo python-pychromecast-git python-requests qemu qjoypad qrencode qt5ct qvkbd rar read-edid reiserfsprogs retroarch retroarch-assets-xmb s-nail scalpel-git scantailor-advanced sdl2_gfx sdl2_mixer sed semt sensors-lxpanel-plugin shadow sigil simplescreenrecorder smartmontools snapd spectre-meltdown-checker sshfs strace sub2srt subtitleripper sudo syncthing sysfsutils syslinux system-config-printer systemd-sysvcompat tagainijisho-git tar tcsh telegram-desktop testdisk texinfo tixati tor-browser traceroute transcode translate-shell-git tree trickle ttf-baekmuk ttf-bitstream-vera ttf-dejavu ttf-hannom ttf-indic-otf ttf-ms-fonts ttf-sazanami tvtime uim unace unetbootin unrar upx usbutils util-linux v4l2ucp vdhcoapp-bin vi vice virtualbox vlfeat vnstat vsftpd vte-legacy vulkan-intel weston wget which wine wine-mono winetricks winff woeusb wondershaper-git wpa_supplicant xbindkeys xchat-se xf86-input-mouse xf86-video-ati xf86-video-vesa xfsprogs xorg-server xorg-xdpyinfo xorg-xinit xorg-xlsfonts xsane xterm yaourt yay yt-dlp zd1211-firmware zeit-git zenity zsh'

This is why, you specifically ran a command on March 1st that set the install reason for all of those as deps. That, combined with not watching the news (https://archlinux.org/news/base-group-r … -required/).

thank you.
I don't remember ran that command, maybe I was drunk that day :-þ

then the only way to fix is the method recommended by mpan (pacman -D --asexplicit "packge_name")?
i have tried "pacman -Syu base" but nothing changed.


sorry for my bad english

Offline

#12 2022-12-11 17:59:47

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,912
Website

Re: Removing unused packages (orphans)

Just reinstalling a package will not change the install reason.  But you can streamline the process a bit.  Just copy that list of packages quoted by Scimmia into a text file, check the list (twice, to find out which packages are naughty and nice) and delete any that you don't explicitly need, then feed the list to pacman:

pacman -D --asexplicit < pkglist.txt

"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#13 2022-12-11 20:05:13

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,144

Re: Removing unused packages (orphans)

In addition to what Trilby said, add base to the list if it is not included.

There are circumstances in which pacman -Qtd may  return packages which are needed, even if you haven't set a bunch of packages you need as dependencies.  However, if you don't do things of that sort, it should never return packages such as those in base, the kernel etc. So the command you originally tried to execute is not one I'd recommend, but it would not normally try to remove packages essential to the core of the system itself.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#14 2022-12-11 20:23:39

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,776

Re: Removing unused packages (orphans)

This usually happens when you use badly-coded and unsupported AUR helpers that call pacman with random options that you are unaware of and shouldn't be used.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#15 2022-12-12 20:22:33

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

i would like to try to remove all packages except base and linux to have a clean installation.
i saw this wiki:
https://wiki.archlinux.org/title/Pacman … l_packages

it says to run this command:

pacman -D --asdeps $(pacman -Qqe)
pacman -D --asexplicit base linux-lts linux-firmware
pacman -Qtdq | pacman -Rns -

Is it safe? if i reboot after removing all packages, will Archlinux be able to boot?


Slithery wrote:

This usually happens when you use badly-coded and unsupported AUR helpers that call pacman with random options that you are unaware of and shouldn't be used.

i always used yaourt, but from 2022 i using yay


sorry for my bad english

Offline

#16 2022-12-12 21:12:57

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 29,912
Website

Re: Removing unused packages (orphans)

quellen wrote:

Is it safe? if i reboot after removing all packages, will Archlinux be able to boot?

Not very likely as you'd have removed your boot loader.  You also will not have networking, or much of anything else.

quellen wrote:

i always used yaourt, but from 2022 i using yay

I'm not sure that's such a good change.

Last edited by Trilby (2022-12-12 21:17:21)


"UNIX is simple and coherent" - Dennis Ritchie; "GNU's Not Unix" - Richard Stallman

Offline

#17 2022-12-12 23:17:59

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,805

Re: Removing unused packages (orphans)

See the bullet points here: https://wiki.archlinux.org/title/Instal … l_packages

Also note that you won't have any shell other than bash, so make sure that's what your user uses. And make sure the root account isn't locked, especially since you wouldn't have sudo.

Last edited by Scimmia (2022-12-12 23:24:47)

Offline

#18 2022-12-13 07:43:35

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

done.
in addition to grub I also added to asexplicit the programs I use the most (firefox, libreoffice, gimp ecc...)

these are the removed packages:

# pacman -Qtdq | pacman -Rns -
checking dependencies...
:: apr-util optionally requires postgresql-libs: enable postgres support
:: chromium optionally requires org.freedesktop.secrets: password storage backend on GNOME / Xfce
:: chromium optionally requires kwallet: support for storing passwords in KWallet on Plasma
:: cups optionally requires colord: for ICC color profile support
:: cups-filters optionally requires foomatic-db-engine: drivers use Ghostscript to convert PostScript to a printable form directly
:: cups-filters optionally requires liblouis: for Braille embosser support
:: file-roller optionally requires squashfs-tools: squashfs image support
:: git optionally requires org.freedesktop.secrets: keyring credential helper
:: gnupg optionally requires libusb-compat: scdaemon
:: libde265 optionally requires sdl: dec265 YUV overlay output
:: libmpeg2 optionally requires sdl: required for mpeg2dec
:: libreoffice-fresh optionally requires postgresql-libs: for postgresql-connector
:: libreoffice-fresh optionally requires kio: for KF5 KDE desktop integration
:: libsecret optionally requires org.freedesktop.secrets: secret storage backend
:: lv2 optionally requires python-pygments: for lv2specgen.py
:: python-pyqt5 optionally requires qt5-multimedia: QtMultimedia, QtMultimediaWidgets
:: python-pyqt5 optionally requires qt5-speech: QtTextToSpeech
:: qt5-base optionally requires qt5-wayland: to run Qt applications in a Wayland session
:: qt5-base optionally requires postgresql-libs: PostgreSQL driver
:: qt6-base optionally requires postgresql-libs: PostgreSQL driver
:: subversion optionally requires kwallet: for KWallet for auth credentials
:: vlc optionally requires kwallet: kwallet keystore
:: wine optionally requires lib32-gnutls
:: wine optionally requires lib32-libxcomposite
:: wine optionally requires lib32-libxinerama
warning: dependency cycle detected:
warning: usbmuxd will be removed after its libimobiledevice dependency

Packages (275) anthy-9100h-6  apparmor-3.1.2-1  cblas-3.11.0-1  colord-1.4.6-1
               cower-18-1  dhcpcd-dbus-0.6.1-1  expac-10-5  fcitx-4.2.9.9-1
               foomatic-db-engine-4:20220521-1  gdb-common-12.1-2
               gtk-engines-2.21.0-5  hiredis-1.1.0-1  hplip-1:3.22.10-1
               karchive-5.101.0-1  kauth-5.101.0-1  kbookmarks-5.101.0-1
               kcodecs-5.101.0-1  kcompletion-5.101.0-1  kconfig-5.101.0-1
               kconfigwidgets-5.101.0-1  kcoreaddons-5.101.0-1
               kcrash-5.101.0-1  kdbusaddons-5.101.0-1  kded-5.101.0-1
               kglobalaccel-5.101.0-1  kguiaddons-5.101.0-1  ki18n-5.101.0-1
               kiconthemes-5.101.0-1  kio-5.101.0-1  kitemviews-5.101.0-1
               kjobwidgets-5.101.0-1  knotifications-5.101.0-1
               kservice-5.101.0-1  ktextwidgets-5.101.0-1  kwallet-5.101.0-1
               kwidgetsaddons-5.101.0-1  kwindowsystem-5.101.0-1
               kxmlgui-5.101.0-1  lib32-at-spi2-core-2.46.0-2
               lib32-cairo-1.17.6-2  lib32-fribidi-1.0.12-1
               lib32-gdk-pixbuf2-2.42.10-1  lib32-gmp-6.2.1-1
               lib32-gnutls-3.7.8-1  lib32-gtk2-2.24.33-2
               lib32-libcups-2.4.2-2  lib32-libdatrie-0.2.13-2
               lib32-libtasn1-4.19.0-1  lib32-libthai-0.1.29-2
               lib32-libxcomposite-0.4.5-2  lib32-libxft-2.3.6-1
               lib32-libxinerama-1.1.5-1  lib32-nettle-3.8.1-1
               lib32-p11-kit-0.24.1-1  lib32-pango-1:1.50.12-1
               lib32-pixman-0.42.2-1  libbsd-0.11.7-1
               libdbusmenu-qt5-0.9.3+16.04.20160218-6  libev-4.33-2
               libgusb-0.4.2-1  libimobiledevice-1.3.0-5  liblouis-3.24.0-1
               libmaxminddb-1.7.1-1  libmd-1.0.4-1  libmediainfo-22.09-1
               libmms-0.6.4-3  libotf-0.9.16-3  libplist-2.2.0-5
               libspeechd-0.11.4-1  libusb-compat-0.1.8-1  libusbmuxd-2.0.2-1
               libx86-1.1-8  libzen-0.4.39-1  lmdb-0.9.29-1  m17n-db-1.8.0-3
               m17n-lib-1.8.0-13  media-player-info-24-2  oniguruma-6.9.8-1
               openssl-1.0-1.0.2.u-1  opusfile-0.12-3  perl-alien-build-2.74-1
               perl-alien-libxml2-0.19-1  perl-capture-tiny-0.48-6
               perl-dbi-1.643-4  perl-ffi-checklib-0.31-2
               perl-file-chdir-0.1011-4  perl-file-which-1.27-2
               perl-path-tiny-0.144-1  perl-xml-libxml-2.0208-1
               perl-xml-namespacesupport-1.12-4  perl-xml-sax-1.02-1
               perl-xml-sax-base-1.09-4  php-8.1.13-1  polkit-qt5-0.114.0-1
               postgresql-libs-14.6-1  python-async-timeout-4.0.2-1
               python-colorama-0.4.6-1  python-commonmark-0.9.1-6
               python-docutils-1:0.19-2  python-future-0.18.2-7
               python-ifaddr-0.2.0-1  python-msgpack-1.0.4-1
               python-netifaces-0.11.0-3  python-pygments-2.13.0-1
               python-zeroconf-0.39.4-1  python-zipp-3.11.0-1
               python2-pyparsing-2.4.7-6  qca-qt5-2.3.5-2
               qt5-multimedia-5.15.7+kde+r1-1  qt5-speech-5.15.7+kde+r1-1
               qt5-wayland-5.15.7+kde+r56-1  sdl12-compat-1.2.60-1
               seatd-0.7.0-2  smartmontools-7.3-1  solid-5.101.0-1
               sonnet-5.101.0-1  source-highlight-3.1.9-9
               squashfs-tools-4.5.1-2  tbb-2021.5.0-2  tinyxml2-9.0.0-1
               tre-0.8.0-6  upower-1.90.0-1  usbmuxd-1.1.1-1  wimlib-1.13.6-2
               xcb-util-xrm-1.3-2  ant-1.10.12-2  apache-2.4.54-3
               arch-install-scripts-28-1  bind-9.18.9-1  boost-1.80.0-3
               brltty-6.5-3  cdck-bin-0.7.0-1  cfourcc-0.1.3.1-1
               chntpw-140201-4  dhcpcd-ui-0.7.8-1  doxygen-1.9.5-1
               dpkg-1.21.12-1  dvbsnoop-1.4.50-2  dxvk-bin-1.10.1-1
               ecm-tools-1.03-3  edid-decode-git-r171.f56f329-1
               elfutils-0.188-1  enet-1.3.17-1  epub2txt-git-47.54b41e8-1
               extra-cmake-modules-5.101.0-1  fatsort-1.6.4.625-1
               fbpanel-7.0-2  fbset-2.1-7  fcitx-anthy-0.2.4-1
               ffnvcodec-headers-11.1.5.2-1  flycast-git-r5243.676cd310-1
               fx_cast-0.1.0-1  gdb-12.1-2  gendesk-1.0.9-3  gnuchess-6.2.9-3
               gsmartcontrol-1.1.4-1  gtest-1.12.1-1  gtksourceview4-4.8.4-1
               hdparm-9.65-1  hpoj-0.91-21  i3-wm-4.21.1-1  iat-0.1.7-4
               inetutils-2.3-1  inxi-2.3.56-1  java-service-wrapper-3.5.49-1
               jmtpfs-0.5-2  jpegoptim-1.5.0-1  js78-78.15.0-4
               kaffeine-2.0.18-3  kidletime-5.101.0-1  leptonica-1.82.0-2
               lftp-4.9.2-1  lib32-gtk-engines-2.21.0-3
               lib32-libpng12-1.2.59-2  lib32-libtxc_dxtn-1.0.1-5
               lib32-ncurses5-compat-libs-6.1-2  lib32-openssl-1.0-1.0.2.u-2
               lib32-pcre-8.45-3  lib32-readline-8.2.001-2  libcddb-1.3.2-7
               libcmis-0.5.2-12  libcroco-0.6.13-2  libibus-1.5.27-1
               libofa-0.9.3-9  libpipewire02-0.2.7-2  libpng12-1.2.59-2
               libstatgrab-0.92.1-1  libva-utils-2.16.0-1
               lsb-release-2.0.r48.3cf5103-1  lshw-B.02.19.2-5  lzip-1.23-2
               mediainfo-22.09-1  mercurial-6.3.1-1  metis-5.1.0.p10-2
               minecraft-launcher-1:1.0.1221-1  miniupnpc-2.2.4-1
               minizip-ng-3.0.7-2  mp3wrap-0.5-6  mpv-debug-1:0.35.0-3
               mupen64plus-2.5-23  ncurses5-compat-libs-6.1-1  ninja-1.11.1-2
               noto-fonts-emoji-20220920-1  noto-fonts-sc-20170603-2
               opencv-4.6.0-6  otf-ipafont-003.03-8  pacaur-4.7.90-1
               pangox-compat-0.0.2+2+gedb9e09-3  pasystray-0.8.0-2
               pcmciautils-018-7  pdfgrep-2.1.2-2  perl-archive-zip-1.68-7
               perl-rename-1.11-1  phoronix-test-suite-10.8.4-1
               powerstat-git-0.02.15.r0.gbb31d9f-1  powertop-2.15-1
               proftpd-2:1.3.7d-1  progsreiserfs-0.3.0.5-10
               python-cachecontrol-1:0.12.11-1  python-contextlib2-21.6.0-1
               python-distlib-0.3.6-1  python-importlib-metadata-5.0.0-1
               python-nspektr-0.4.0-2  python-platformdirs-2.6.0-1
               python-progress-1.6-5  python-pyaudio-0.2.12-1
               python-pychromecast-git-458.00027dc-1  python-resolvelib-0.9.0-1
               python-retrying-1.3.3-14  python-rich-12.6.0-2
               python-tenacity-8.1.0-1  python-toml-0.10.2-8
               python2-appdirs-1.4.4-6  python2-ordered-set-3.1.1-4
               python2-packaging-20.9-7  qt5-quickcontrols2-5.15.7+kde+r7-1
               qt5ct-1.5-2  read-edid-3.0.2-4  rest-0.8.1+r4+ge5ee6ef-1
               scalpel-git-r24.47815c2-1  sdl2_gfx-1:1.0.4-2
               sdl2_mixer-2.6.2-1  semt-1.1.1-1  sfml-2.5.1-3  smpeg-2.0.0-2
               snapd-2.39.2-1  sndio-1.9.0-1  sshfs-3.7.3-1  stockfish-1:15-3
               strace-6.0-1  sub2srt-0.5.5-3  subtitleripper-0.3_4-1
               swig-4.0.2-5  t1lib-5.1.2-8  tcsh-6.24.05-1  transcode-1.1.7-40
               translate-shell-git-0.9.6.8-1  trickle-1.07-11  ucl-1.03-9
               ufw-0.36.1-1  uim-1.8.8-5  upx-4.0.1-1  uriparser-0.9.7-1
               v4l2ucp-2.0.2-6  vdhcoapp-bin-1.2.4-2  vi-1:070224-6
               vlfeat-0.9.20-1  vsftpd-3.0.3-8  w_scan2-1.0.14-1  waf-2.0.24-2
               wayland-protocols-1.31-1  weston-11.0.0-1  woeusb-5.2.2-1
               zeit-git-0.5.0.r46.g8ea139d-1  zsh-5.9-1

Total Removed Size:  1377.21 MiB

:: Do you want to remove these packages? [Y/n]

i reinstalled gtk-engines and other packages because i need it.
now this is my pacman -Qdt and -Qdtq:

$ pacman -Qtd
dmidecode 3.4-1
freerdp 2:2.9.0-1
mesa-demos 8.5.0-2
pavucontrol 1:5.0+r61+gee77d86-2
qt5-graphicaleffects 5.15.7-1
s-nail 14.9.24-2
usbutils 015-2
xorg-xdpyinfo 1.3.3-4
$ pacman -Qtdq
dmidecode
freerdp
mesa-demos
pavucontrol
qt5-graphicaleffects
s-nail
usbutils
xorg-xdpyinfo

it's clean? maybe i need to add pavucontrol to asexplicit...

Last edited by quellen (2022-12-13 08:05:05)


sorry for my bad english

Offline

#19 2022-12-13 11:17:59

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

maybe i have solved (or did I do something stupid):

sudo pacman -Rs dmidecode freerdp intltool mesa-demos pavucontrol qt5-graphicaleffects s-nail usbutils xorg-xdpyinfo
sudo pacman -S dmidecode freerdp intltool mesa-demos pavucontrol qt5-graphicaleffects s-nail usbutils xorg-xdpyinfo

now "pacman -Qdtq" is empty.

EDIT:
i think i did a stupid thing, i reset with:

sudo pacman -D --asdeps dmidecode freerdp intltool mesa-demos pavucontrol qt5-graphicaleffects s-nail usbutils xorg-xdpyinfo

Last edited by quellen (2022-12-13 11:22:27)


sorry for my bad english

Offline

#20 2022-12-13 11:22:05

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,388

Re: Removing unused packages (orphans)

everything installed with pacman -S gets  "Explicitly installed" as install reason.

I hope you do need all of them ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

clean chroot building to complicated ?
Try clean chroot manager by graysky

Offline

#21 2022-12-13 11:23:34

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

Lone_Wolf wrote:

everything installed with pacman -S gets  "Explicitly installed" as install reason.

I hope you do need all of them ?

i think i need only pavucontrol. I will delete the others.
usbutils i don't know what is it.

EDIT:
i need usbutils because is lsusb's packages.

Last edited by quellen (2022-12-13 11:28:42)


sorry for my bad english

Offline

#22 2022-12-13 15:56:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,144

Re: Removing unused packages (orphans)

Are you sure you don't need dhcpcd, for example? Because if you do need it, removing it will break networking.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#23 2022-12-13 16:51:32

quellen
Member
From: Italy
Registered: 2014-05-24
Posts: 311

Re: Removing unused packages (orphans)

cfr wrote:

Are you sure you don't need dhcpcd, for example? Because if you do need it, removing it will break networking.

i added it to asexplicit before run "pacman -Qtdq | pacman -Rns -" ;-)

Last edited by quellen (2022-12-13 16:51:55)


sorry for my bad english

Offline

Board footer

Powered by FluxBB