You are not logged in.

#1 2023-01-23 18:12:34

GourSE
Member
Registered: 2023-01-23
Posts: 6

[Solved] wifi not working after update

NetworkManager does not scan for wifi and does not connect to saved network

$ nmcli radio wifi on 
$ nmcli device wifi list 
IN-USE  BSSID  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY
$ ip link show
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DORMANT group default qlen 1000
    link/ether 7e:f2:1f:45:7c:78 brd ff:ff:ff:ff:ff:ff permaddr 50:c2:e8:0c:71:39
$ inxi -N                                             
Network:
  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169

Tried iwd as well, not scanning either.
To be clear, it was all working out of the box, all I can imagine doing to break it is update.

Last edited by GourSE (2023-01-24 13:18:55)

Offline

#2 2023-01-23 20:49:12

seth
Member
Registered: 2012-09-03
Posts: 52,454

Re: [Solved] wifi not working after update

Does the LTS kernel still work?

Please post a complete system journal

sudo journalctl -b | curl -F 'file=@-' 0x0.st

and the output of

find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f

Ceterum censeo: Is there a parallel windows installation?
(See the 3rd link below)

Offline

#3 2023-01-24 03:01:21

GourSE
Member
Registered: 2023-01-23
Posts: 6

Re: [Solved] wifi not working after update

linux-lts does not have the drivers

system journal

$ find /etc/systemd -type l -exec test -f {} \; -print | awk -F'/' '{ printf ("%-40s | %s\n", $(NF-0), $(NF-1)) }' | sort -f
bluetooth.service                        | bluetooth.target.wants
dbus-org.bluez.service                   | system
dbus-org.freedesktop.nm-dispatcher.service | system
dbus-org.freedesktop.timesync1.service   | system
display-manager.service                  | system
fstrim.timer                             | timers.target.wants
gcr-ssh-agent.socket                     | sockets.target.wants
getty@tty1.service                       | getty.target.wants
NetworkManager.service                   | multi-user.target.wants
NetworkManager-wait-online.service       | network-online.target.wants
p11-kit-server.socket                    | sockets.target.wants
pipewire-pulse.socket                    | sockets.target.wants
pipewire-session-manager.service         | user
pipewire.socket                          | sockets.target.wants
remote-fs.target                         | multi-user.target.wants
systemd-timesyncd.service                | sysinit.target.wants
wireplumber.service                      | pipewire.service.wants

Last edited by GourSE (2023-01-24 03:54:20)

Offline

#4 2023-01-24 08:11:45

seth
Member
Registered: 2012-09-03
Posts: 52,454

Re: [Solved] wifi not working after update

There're no issues logged (particualrily no parallel runs of iwd and wpa_supplicant)
On a random guess, try to disable https://wiki.archlinux.org/title/Networ … domization

Also

seth wrote:

Ceterum censeo: Is there a parallel windows installation?

Offline

#5 2023-01-24 08:15:18

-thc
Member
Registered: 2017-03-15
Posts: 525

Re: [Solved] wifi not working after update

GourSE wrote:

linux-lts does not have the drivers

It does:

usr/lib/modules/5.15.89-1-lts/kernel/drivers/net/wireless/mediatek/mt76/mt7921/mt7921e.ko.zst

Offline

#6 2023-01-24 09:09:52

GourSE
Member
Registered: 2023-01-23
Posts: 6

Re: [Solved] wifi not working after update

seth wrote:

Ceterum censeo: Is there a parallel windows installation?

No I don't and disabling randomize mac doesn't work

-thc wrote:

It does

It does not load though

I reinstalled the whole system by the way, still doesn't work.
Silly to me because apparently it isn't working on archinst iso either

Offline

#7 2023-01-24 09:17:21

seth
Member
Registered: 2012-09-03
Posts: 52,454

Re: [Solved] wifi not working after update

and disabling randomize mac doesn't work

Did you reboot and check the journal to make sure the MAC was no longer altered?

What do you mean "it doesn't load"?
Do you have a journal for the LTS kernel?

Silly to me because apparently it isn't working on archinst iso either

To be clear, it was all working out of the box, all I can imagine doing to break it is update.

Are we sure there're any SSIDs in range and did you maybe just got a lease using the Realtek RTL8111/8168/8411 ?

Offline

#8 2023-01-24 09:39:27

GourSE
Member
Registered: 2023-01-23
Posts: 6

Re: [Solved] wifi not working after update

seth wrote:

Do you have a journal for the LTS kernel?

linux-lts journal

seth wrote:

Are we sure there're any SSIDs in range

I am certain

Offline

#9 2023-01-24 09:48:12

GourSE
Member
Registered: 2023-01-23
Posts: 6

Re: [Solved] wifi not working after update

nmcli m would have these output

$ nmcli m          
home-wifi: connection profile changed
wlan0: using connection 'dlink-SeanCheryl-2.4GHz'
wlan0: connecting (prepare)
Networkmanager is now in the 'connecting' state
wlan0: connecting (configuring)
wlan0: connecting (need authentication)
wlan0: connecting (prepare)
wlan0: connecting (configuring)
home-wifi: connection profile changed
wlan0: connection failed
Networkmanager is now in the 'disconnected' state
wlan0: disconnected

and as for my android USB tethering

usb0: device created
enp8s0f3u1: unavailable
enp8s0f3u1: disconnected
Wired connection 2: connection profile created
enp8s0f3u1: using connection 'Wired connection 2'
enp8s0f3u1: connecting (prepare)
Networkmanager is now in the 'connecting' state
enp8s0f3u1: connecting (configuring)
enp8s0f3u1: connecting (getting IP configuration)
'Wired connection 2' is now the primary connection
enp8s0f3u1: connecting (checking IP connectivity)
enp8s0f3u1: connecting (starting secondary connections)
enp8s0f3u1: connected
Networkmanager is now in the 'connected (site only)' state
Connectivity is now 'limited'
Networkmanager is now in the 'connected' state
Connectivity is now 'full'

Offline

#10 2023-01-24 13:18:40

GourSE
Member
Registered: 2023-01-23
Posts: 6

Re: [Solved] wifi not working after update

I'm going to tell a bit of a story.
My laptop has a default RGB colour of blue, and I have an automated script to make it purple, because every time my laptop shut Down for a while it switches it back.
I was working on my network problem for a day or so, and I realised that I haven't see a blue keyboard for quite a while. Since I reinstalled the system, that shouldn't be right.
I shut it down and unplug the power adapter, wait for about 30 seconds and boot it up. Here I am, blue keyboard backlight and working wifi.

I am sorry for Seth trying to help me with my problem, we are both wasting our time apparently.

Offline

Board footer

Powered by FluxBB