You are not logged in.

#1 2023-02-13 21:36:44

Registered: 2019-08-27
Posts: 7

[SOLVED] Virt-Manager guest can't access WPA2-Enterprise network

I have a Windows 10 vm on a QEMU user session in virt-manager, and it has internet access when connected to my home ethernet, but no connection on my university wifi (eduroam).  I haven't been home yet to test whether it works on my home wifi (*edit: it does), but I suspect the issue may be related to the fact that my university network is configured through iwd and doesn't appear in my list of networks for NetworkManager, while the ethernet connection appears only in NetworkManager.  I'm guessing this mix of the two isn't best practice, but I had a terrible time getting connected to the university wifi in the first place and stopped at the first working solution I could find.

In Virt-Manager, my network source is set to "Usermode networking", with device model "e1000e".  I tried setting up a bridged network following the tutorial here, but this stopped me from launching the vm at all, giving the error message

Error starting domain: /usr/lib/qemu/qemu-bridge-helper --use-vnet --br=nm-bridge1 --fd=31: failed to communicate with bridge helper: stderr=access denied by acl file

which I think might be because of the user session, given the "access denied," but I don't particularly want to use a bridged connection anyway - I just the connection to work.

Edit: My home wifi network works in the guest os, so it seems to only be a problem on the eduroam network
Edit 2: I solved the problem by connecting to the network using nm-applet instead of iwd, and I now have internet within my vms

Last edited by postfinem (2023-02-14 15:19:28)


Board footer

Powered by FluxBB