You are not logged in.

#1 2023-02-14 21:28:44

Strangiato
Member
Registered: 2020-01-10
Posts: 382

wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

Hello

I use Gnome, networkmanager and iwd, and my Arch is fully updated.

I keep IPv6 disabled on my system, wired connection only gets IPv4 IPs as expected, but the wi-fi connection gets both IPv4 and IPv6 IPs despite the IPv6 is disabled in the Wi-Fi module of Gnome Settings.

I have already removed my wi-fi connection but the bug persists with the new one.
Any idea on how to make my wi-fi connection to respect the IP settings?
Thanks.

Offline

#2 2023-02-15 00:09:26

wilsontulus
Member
Registered: 2023-02-15
Posts: 1

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

First off why do you want to disable IPv6 anyway?

Lots of benefits come with IPv6. You will have better performance especially if your ISP is one of the most used one which has their IPv4 routings saturated. You will have less chance of getting captchas especially if your IPv4 is behind CG-NAT. You will support the future of Internet and also able to connect to IPv6-only stuff especially in the future.

If you are concerned about the other half of MAC address, there's a way to randomize it by enabling Privacy Extensions.
Otherwise a lot of Arch wikis might help.

Offline

#3 2023-02-15 00:28:28

Strangiato
Member
Registered: 2020-01-10
Posts: 382

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

I keep IPv6 disabled due to connectivity issues with my ISP. Fortunately my IPv4 is not behind CG-NAT.

Offline

#4 2023-02-15 07:38:45

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 7,771
Website

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

Strangiato wrote:

I keep IPv6 disabled on my system

How have you done that, exactly? Have you seen https://wiki.archlinux.org/title/IPv6#NetworkManager_3?

Offline

#5 2023-02-15 14:45:46

Strangiato
Member
Registered: 2020-01-10
Posts: 382

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

Head_on_a_Stick wrote:
Strangiato wrote:

I keep IPv6 disabled on my system

How have you done that, exactly? Have you seen https://wiki.archlinux.org/title/IPv6#NetworkManager_3?

I open the Wi-Fi module of Gnome settings, click on the gear icon of my wi-fi connection, click on "IPv6" tab, select "Disable" radio button under
"IPv6 method", click on "Apply" button, then I reconnet. This worked as expected until some recent regression.

I have just tried to disable the IPv6 with these commands from your link, without success:

# nmcli connection modify <ConnectionName> ipv6.method "disabled"
# nmcli connection up <ConnectionName>

Edit:
downgrade to networkmanager 1.40.12-1 solved the problem.

Edit2:
Created a bug report:
https://gitlab.freedesktop.org/NetworkM … ssues/1216

Last edited by Strangiato (2023-02-15 15:27:46)

Offline

#6 2023-02-15 16:21:16

seth
Member
Registered: 2012-09-03
Posts: 53,319

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

I keep IPv6 disabled due to connectivity issues with my ISP.

Then maybe *really* disable it?
https://wiki.archlinux.org/title/IPv6#Disable_IPv6

On topic:
Please post your complete system journal for the boot:

sudo journalctl -b | curl -F 'file=@-' 0x0.st

to get this out of "its doesn't works" territory.

Offline

#7 2023-02-15 16:56:27

Strangiato
Member
Registered: 2020-01-10
Posts: 382

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

Here is the journal log:
http://0x0.st/HrYO.txt

Offline

#8 2023-02-15 17:06:29

seth
Member
Registered: 2012-09-03
Posts: 53,319

Re: wi-fi gets IPv6 IPs despite IPv6 is disabled in the wi-fi connection

You've a link local address and then

fev 15 13:53:03 arch-laptop avahi-daemon[307]: Joining mDNS multicast group on interface wlan0.IPv6 with address 2804:14d:4cd1:acde::1000.

avahi-daemon rather doesn't care about NM settings.

If you just want IPv6 disabled entirely, follow the link I posted.

Offline

Board footer

Powered by FluxBB