You are not logged in.

#1 2023-03-23 07:11:55

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,904
Website

[SOLVED] NetworkManager does not activate WireGuard connection

I just tried to activate a WireGuard connection to out company's intranet on my laptop using NetworkManager.
Activating the connection fails with

Mär 23 08:03:18 envy NetworkManager[623]: <info>  [1679554998.6558] audit: op="connection-activate" uuid="285e18b6-e039-415c-bc06-09840d3820a8" name="HOMEINFO" pid=1244 uid=1000 result="fail" reason="The VPN service 'org.freedesktop.NetworkManager.wireguard' was not installed."

I googled the issue and found an old and outdated topic about that here in the forums.
However, WireGuard support was integrated into NetworkManager some time ago.
Why does the activation suddenly fail?

/home/rne〉pacman -Q linux wireguard-tools networkmanager                                                                                                                 03/23/2023 08:11:18 
linux 6.2.7.arch1-1
wireguard-tools 1.0.20210914-1
networkmanager 1.42.4-2
/home/rne〉uname -a                                                                                                                                                       03/23/2023 08:11:42 
Linux envy 6.2.7-arch1-1 #1 SMP PREEMPT_DYNAMIC Sat, 18 Mar 2023 01:06:36 +0000 x86_64 GNU/Linux
/home/rne〉                                                                                                                                                               03/23/2023 08:11:44 

Update:
Same issue with nmcli:

/home/rne〉nmcli connection up HOMEINFO                                                                                                                                   03/23/2023 08:23:32 
Fehler: Aktivierung der Verbindung ist gescheitert: The VPN service 'org.freedesktop.NetworkManager.wireguard' was not installed.
/home/rne〉                                                                                                                                                               03/23/2023 08:23:42 

Last edited by schard (2023-03-23 08:06:02)

Offline

#2 2023-03-23 07:48:36

seth
Member
Registered: 2012-09-03
Posts: 48,439

Re: [SOLVED] NetworkManager does not activate WireGuard connection

The gist of https://bbs.archlinux.org/viewtopic.php?id=276161 (2022) to me seems that you're for some reason (mostly because NM sucks, I guess) are trying to use the (former) NM plugin instead of the the "new" (2019) native support, https://blogs.gnome.org/thaller/2019/03 … rkmanager/

The highlights wrote:

Having support in NetworkManager is great for … NetworkManager provides a de facto standard API for configuring breaking networking on the host.

lol

You'd either fish the plugin out of the AUR archive or somehow make NM use the native support.

Edit: from the other thread, you might actually be (still) using the plugin and that meanwhile broke?

Last edited by seth (2023-03-23 07:56:42)

Offline

#3 2023-03-23 08:05:46

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 1,904
Website

Re: [SOLVED] NetworkManager does not activate WireGuard connection

Thank you seth, but the issue was actually something completely slightly different.
I used wireguard-indicator in the past, which uses a different configuration layout.
I had to manually migrate it to the one natively used by NetworkManager in /etc/NetworkManager/system-connections/HOMEINFO-ce0d8384-afcc-4806-b511-6c3891941fad.nmconnection.
After some tinkering it's working now.
I am currently wiring a Python script to do this conversion automatically.
I'll post it here, once it's done.

Update
Configuration conversion script

Last edited by schard (2023-03-24 09:21:07)

Offline

Board footer

Powered by FluxBB