You are not logged in.

#1 2023-03-05 06:56:29

YAOMTC
Member
Registered: 2010-02-23
Posts: 204

Wiki theme issue [SOLVED]

While I'm logged in, there's something weird going on with the theme. The sidebar, footer, and top bar all fit the mode of light/dark properly. However, the content area is the opposite, and I'm not sure why. Also, this happens on seemingly all pages within the wiki *except* my Preferences page.

  • I've disabled Stylus

  • No Tampermonkey scripts affect archlinux.org

  • I've used Inspect on the content area, where I can find "dark-theme-background" but I don't see a "light-theme-background" anywhere no matter if I'm in dark mode or not?

  • I'm using Firefox on Plasma (Breeze Dark) but I haven't noticed the system theme affecting web page content for quite some time (good)

  • I've tried creating a blank CSS and Javascript file, didn't help

  • If I log out, the issue goes away until I log in again

Any idea what could be causing this?

EDIT: adding screenshots.

https://i.imgur.com/KyfVE6Y.png

https://i.imgur.com/V6sHF76.png


moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by YAOMTC (2023-05-10 16:42:31)

Offline

#2 2023-05-09 18:07:50

YAOMTC
Member
Registered: 2010-02-23
Posts: 204

Re: Wiki theme issue [SOLVED]

The content also looks off when I switch to Vector Legacy (2010) but it's at least mostly consistent.

https://i.imgur.com/JUbM89v.png

However editing is a no-go here.

https://i.imgur.com/3IgwAUZ.png


moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by 2ManyDogs (2023-05-09 22:39:28)

Offline

#3 2023-05-09 22:39:52

2ManyDogs
Forum Fellow
Registered: 2012-01-15
Posts: 4,645

Re: Wiki theme issue [SOLVED]

Please read the General Guidelines and post only thumbnails or links to images.

Offline

#4 2023-05-10 05:46:13

seth
Member
Registered: 2012-09-03
Posts: 54,446

Re: Wiki theme issue [SOLVED]

I'm using Firefox on Plasma (Breeze Dark) but I haven't noticed the system theme affecting web page content for quite some time (good)

And what happens if you're using the non-dark breeze theme?
(Ie. is it the firefox GUI theme/chrome that causes this)?

Offline

#5 2023-05-10 05:46:51

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 757

Re: Wiki theme issue [SOLVED]

You have some style modifications in your https://wiki.archlinux.org/title/User:YAOMTC/vector.css from 2020...

Offline

#6 2023-05-10 16:37:08

YAOMTC
Member
Registered: 2010-02-23
Posts: 204

Re: Wiki theme issue [SOLVED]

Well, that fixed it. Thanks.

Curious, why did that fix it? There wasn't anything in Vector (2022) which I had selected.

Offline

Board footer

Powered by FluxBB