You are not logged in.

#1 2023-05-26 11:13:14

igorborisov
Member
Registered: 2023-05-26
Posts: 4

Update notice: Please do not update. We are working on the repo...

Today I'm update my Arch Linux via yay -Syu without any issue and reboot.

But I launch yay -Syu again after two hours, and get warning:
update notice: Please do not update. We are working on the repo rebuild and reconstruction at the moment.

Offline

#2 2023-05-26 13:33:10

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,367

Re: Update notice: Please do not update. We are working on the repo...

Use better/more up to date mirrors.

Offline

#3 2023-05-26 13:33:21

philo
Member
Registered: 2015-01-26
Posts: 251

Re: Update notice: Please do not update. We are working on the repo...

Do not expect to get help  about yay here. Go to the AUR page of the package.

Offline

#4 2023-05-26 14:44:53

igorborisov
Member
Registered: 2023-05-26
Posts: 4

Re: Update notice: Please do not update. We are working on the repo...

I tried pacman also. I already switch to local mirrors

Offline

#5 2023-05-26 14:51:09

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,783

Re: Update notice: Please do not update. We are working on the repo...

What mirror? What's the full output? I'm not even sure how you could get a message like that from pacman.

Last edited by Scimmia (2023-05-26 14:51:19)

Offline

#6 2023-05-26 14:51:56

loqs
Member
Registered: 2014-03-06
Posts: 17,733

Re: Update notice: Please do not update. We are working on the repo...

igorborisov wrote:

I tried pacman also. I already switch to local mirrors

If you mean you can produce that message with pacman please post the full output of `pacman -Syu --debug`

Offline

#7 2023-05-26 15:24:04

igorborisov
Member
Registered: 2023-05-26
Posts: 4

Re: Update notice: Please do not update. We are working on the repo...

I'm run `pacman -Syu --debug` and get many errors with not readable databeses, like:
"/var/lib/pacman/sync/multilib.db.sig" is not readable

Arch Linux Tweak Tool fixes dont help me in this time.
https://github.com/arcolinux/archlinux-tweak-tool

[SOLVED]
Solution:
I'm use CachyOS repos also. I followed this instructions, and my problem solved:
https://wiki.cachyos.org/en/home/Repo

Manual steps to fix error (for more details check article above):
1) add key of needed repo via pacman-key --recv-keys from Ubuntu Keyserver
2) sudo pacman-key --lsign-key <key>
3) install *-keyring, *-mirrorlist, pacman packages via pacman
4) check repofile at /etc/pacman.conf for enabled repos
5) Successfully run pacman -Syu

Last edited by igorborisov (2023-05-26 15:25:31)

Offline

#8 2023-05-26 15:54:00

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,783

Re: Update notice: Please do not update. We are working on the repo...

None of those is anything that was asked for.

Is this Arco? Cachy? What are you running, exactly?

Offline

#9 2023-05-26 15:58:21

igorborisov
Member
Registered: 2023-05-26
Posts: 4

Re: Update notice: Please do not update. We are working on the repo...

I'm use vanilla Arch with custom repos from Cachy and Arco ;-)

Offline

#10 2023-05-26 17:20:39

loqs
Member
Registered: 2014-03-06
Posts: 17,733

Re: Update notice: Please do not update. We are working on the repo...

So the issue is from cachyos's repositories https://www.reddit.com/r/cachyos/commen … ot_update/
Edit:
Please also see https://bbs.archlinux.org/viewtopic.php?id=57855

Last edited by loqs (2023-05-26 17:29:48)

Offline

Board footer

Powered by FluxBB