You are not logged in.

#1 2023-09-04 09:34:42

kde35
Member
Registered: 2015-04-13
Posts: 71

php-fpm socket with wrong ownership [solved]

Hi, I have in my  /etc/php/php-fpm.d/cloud.conf lines

[cloud]
user = nextcloud
group = http
listen = /run/php-fpm/php-fpmcloud.sock

However, whenever php-fpm starts, the socket /run/php-fpm/php-fpmcloud.sock is created (which means this configuration file is read, otherwise there would only be the socket /run/php-fpm/php-fpm.sock) with wrong ownership http:http so I have to manually chown.  Would anyone know how to solve this?  Thank you very much in advance.

Last edited by kde35 (2023-09-06 09:08:51)

Offline

#2 2023-09-04 10:17:30

just4arch
Member
Registered: 2023-01-07
Posts: 96

Re: php-fpm socket with wrong ownership [solved]

Try setting the socket related options?

; Set permissions for unix socket, if one is used. In Linux, read/write
; permissions must be set in order to allow connections from a web server. Many
; BSD-derived systems allow connections regardless of permissions. The owner
; and group can be specified either by name or by their numeric IDs.
; Default Values: user and group are set as the running user
;                 mode is set to 0660
listen.owner = http
listen.group = http
;listen.mode = 0660

Offline

#3 2023-09-04 14:20:06

kde35
Member
Registered: 2015-04-13
Posts: 71

Re: php-fpm socket with wrong ownership [solved]

just4arch wrote:

Try setting the socket related options?

; Set permissions for unix socket, if one is used. In Linux, read/write
; permissions must be set in order to allow connections from a web server. Many
; BSD-derived systems allow connections regardless of permissions. The owner
; and group can be specified either by name or by their numeric IDs.
; Default Values: user and group are set as the running user
;                 mode is set to 0660
listen.owner = http
listen.group = http
;listen.mode = 0660

Thank you that solved the problem.

Offline

Board footer

Powered by FluxBB