You are not logged in.

#1 2023-09-10 09:38:42

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

[SOLVED] integrity: Problem loading X.509 certificate -22

Heya!
Today I installed arch linux (vanilla) manually with an USB on my laptop. I have installed arch linux multiple times before, but never ran into this problem. As always I followed the installation guide, setup Limine as my boot manager with the default configuration on their wiki page, and rebooted. Now when I want to boot into it, I get the limine screen as expected, but if I want to boot into my arch linux install, I get 2 messages:

sgx: There are zeri EPC sections
integrity: Problem loading X.509 certificate -22

After that, nothing happens, these messages stay on the screen until I turn off my laptop by force.
I installed the required packages, as well as `openssl` and `coreutils`. I also ran `pacman -Syyu` when `arch-chroot`-ing. (I used as of today the newest `.iso`, so it can't be an out-of-date error)

My partitions looks like this:

/dev/sda1 /boot
/dev/sda2 [SWAP]
/dev/sda3 /

Any idea what could have caused this/how I can fix this? A google search did not give me any useful results, if any at all.

Thanks a lot!

Last edited by LabRicecat (2023-09-10 13:06:14)

Offline

#2 2023-09-10 10:09:47

3beb6e7c46a615a
Member
Registered: 2021-03-27
Posts: 165

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Did you setup a graphical environment during installation? Can you switch to another TTY, i.e. Ctrl+Alt+F3?  The message might just have overwritten the login prompt.

The message looks as if the kernel fails to load a certificate, and the only place where certificates commonly exist for the kernel would be secure boot.  Presumably your firmware/motherboard vendor installed some weird certificates into the secure boot DB. Just guessing tho, so not sure if the following helps:

First, try clear out secure boot state and update the firmware.

If that doesn't help, try to disable secure boot entirely, or switch to classic BIOS boot as a last resort.

Last edited by 3beb6e7c46a615a (2023-09-10 10:11:54)

Offline

#3 2023-09-10 10:28:30

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

No I did not set up a graphical environment yet. Pressing Ctrl+Alt+F3 does nothing (i.e. nothing happens).
In the BIOS setting I already disabled secure boot, or more, it was never enabled in the first place. Seems to be the default.

How would you suggest I update the firmware? Is that something in the BIOS I need to do? (my second guess would be the `linux-firmware` package, but I doubt you mean that)

Offline

#4 2023-09-10 10:45:31

3beb6e7c46a615a
Member
Registered: 2021-03-27
Posts: 165

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

"Update the firmware" as in "update the BIOS".  How you do that depends on the BIOS or motherboard vendor.

That said it looks as if you successfully installed Arch from the live ISO?  How did you boot that? In EFI or BIOS mode?

Exit: You also might want to try a different kernel, eg linux-lts.

Last edited by 3beb6e7c46a615a (2023-09-10 10:47:10)

Offline

#5 2023-09-10 10:50:16

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Oh I see. I was currently trying `fwupd`, but that does not let me start a demon while `arch-chroot`ing.

Yes I successfully installed from the ISO. I simply put in the BIOS as boot option my hard drive as first entry, as it detected it.
It's EFI.

I will try to install the different kernel!

Offline

#6 2023-09-10 10:58:37

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I `arch-chroot`ed from my live USB into `/dev/sda3` (root), and ran `pacman -Sy linux-lts`, it ran the installation and setup, but on reboot the message is still there. Did I forgot to set something up or remove something?

Offline

#7 2023-09-10 11:14:04

3beb6e7c46a615a
Member
Registered: 2021-03-27
Posts: 165

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Did you actually boot the LTS kernel, ie select it in the boot manager?  Sorry if that's an obvious question, I just don't know where you are smile

Offline

#8 2023-09-10 11:31:56

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Oh whoops, I have forgotten to do that.
Also I seemed to installed it incorrectly, whoops.

In any case, I ran this:

pacman -R linux
pacman -S linux-lts linux-firmware base

And edited my boot manager config.

Now, the error message got... longer upon bootup. The original message still persists.
My retype:

<previous error shown above>
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)
CPU: 5 PID: 1 Com: swapper/0 Not tainted 6.1.52-1-lts #1 <uuid>
Hardware: <my machine>
Call Trace:
   ....

Maybe do I need to redo my `fstab` ?

Last edited by LabRicecat (2023-09-10 11:40:06)

Offline

#9 2023-09-10 11:36:38

2ManyDogs
Forum Fellow
Registered: 2012-01-15
Posts: 4,645

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

LabRicecat, markdown is not supported here. Please edit your posts and use [ code ] tags (not quote tags) when posting output. This makes the output easier to read and provides a scroll box for long output.

https://wiki.archlinux.org/title/Genera … s_and_code
https://bbs.archlinux.org/help.php#bbcode

Offline

#10 2023-09-10 11:42:06

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Sorry, I am new here. I edited my posts accordingly!

I now reran the

 genfstab 

and

 mkinitcpio 

with no success. Still the same message

Offline

#11 2023-09-10 11:57:02

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Call Trace:
   ....

Please don't paraphrase, https://bbs.archlinux.org/viewtopic.php?id=57855
In this case, linking a screenshot (dom't embed it here) is actually much better than some vague recap that skips the important parts wink

Offline

#12 2023-09-10 12:16:39

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Alright! Sorry for the broken screen, here is the image: https://imgur.com/a/ERJR56n

And again, I don't use forums that often, so please excuse that I am not used to this, I try my best.

Offline

#13 2023-09-10 12:26:41

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

The grub.cfg is borked, there's probably no root parameter at all or it's wrong.
From the install is

lsblk -f
mount /dev/sda3 /mnt
ls /mnt/boot
mount /dev/sda1 /mnt/boot
ls /mnt/boot
cat /mnt/boot/limine.cfg

https://wiki.archlinux.org/title/Limine#Configuration
The "root-uuid" in "CMDLINE=root=UUID=root-uuid rw" is a placeholder

Offline

#14 2023-09-10 12:29:30

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I don't use GRUB tho, I use limine.

This is my limine.cfg

TIMEOUT=5

:Arch Linux
    PROTOCOL=linux
    KERNEL_PATH=boot:///vmlinuz-linux-lts
    CMDLINE=root=UUID=root-uuid rw
    MODULE_PATH=boot:///initramfs-linux.img

(again, a placeholder)

Edit: I realized you mentioned limine, my bad. Still I don't get what you try to tell me..

Last edited by LabRicecat (2023-09-10 12:30:52)

Offline

#15 2023-09-10 12:30:35

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Yeah, figured that midway through.

seth wrote:

The "root-uuid" in "CMDLINE=root=UUID=root-uuid rw" is a placeholder

Edit: not sure about your last line.
Post the actual file content and contrast that w/ the output of "lsblk -f"
Also make sure it's on the right partition (in case you're eg. not actually booting from sda1)

Edit #2:
If

CMDLINE=root=UUID=root-uuid rw

is literal, that's bogus. "root-uuid" is supposed to be an actual UUID

Last edited by seth (2023-09-10 12:32:54)

Offline

#16 2023-09-10 12:37:14

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I already posted the file content, and yes, "uuid" got replaced correctly and after just checking, still matches with /dev/sda3 as provided by lsblk.

Edit: Screenshot added: https://imgur.com/a/sYIZYUv

Last edited by LabRicecat (2023-09-10 12:40:03)

Offline

#17 2023-09-10 12:39:38

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I already posted the file content, and yes, "uuid" got replaced correctly

Only one of those things can be true and if it now looks like "CMDLINE=root=UUID=root-12345678-87654321-abcdefg-hijklm rw" that's still bogus which is why you're not supposed to post vague interpretations of data.

Offline

#18 2023-09-10 12:41:06

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I have no way of sending the file, so I looked it up, and made changed to the default. I now added a screenshot so this should be more clear now.

Offline

#19 2023-09-10 12:42:26

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

cat /mnt/boot/limine.cfg | curl -F 'f:1=<-' ix.io

Offline

#20 2023-09-10 12:43:00

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I already sent it, as a screenshot, no?

Offline

#21 2023-09-10 12:48:50

seth
Member
Registered: 2012-09-03
Posts: 52,262

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

"cross-talk", can you boot the fallback initramfs?

Offline

#22 2023-09-10 12:58:39

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

Sadly no, changing "boot:///initramfs-linux-lts.img" to "boot:///initramfs-linux-lts-fallback.img" yields the exact same error message as shown above.

Offline

#23 2023-09-10 13:01:26

LabRicecat
Member
Registered: 2023-09-10
Posts: 36

Re: [SOLVED] integrity: Problem loading X.509 certificate -22

I uhm, found out why it's not working. I had a typo. I typed "MODULE-PATH" instead of "MODULE_PATH". It boots now into the tty!

Thanks a lot!!

Offline

Board footer

Powered by FluxBB