You are not logged in.

#1 2023-11-11 17:10:26

skato
Member
Registered: 2023-11-11
Posts: 5

SOLVED - ssh hanging when adding -T parameter with specific router

I'm having a very strange problem. From a couple of days I'm having problems with git, ssh and vpn but only when using amazon eero router. Using my smartphone hotspot or even just connecting directly to the modem/router I connect to the eero I don't have any problem.

This is the problem: when I try to execute any git command that require an ssh connection the command hang without any output. If instead I execute the same command but not requiring an ssh connection it works fine. Like for example, on the same repository,

git clone https://...

works fine,

git clone git@...

not.

ssh itself works fine, I can connect to my servers and also to github, but if I add the -T parameter ssh start hanging, trying to connect to github or any other server. After 10/15 minutes of hanging it says me Connection to server.x closed by remote host.

Also, in addition to this, if I try connecting to a vpn (I use NordVPN) the vpn connect but I stop having an internet connection.

All these problems, as I said, starts showing only when I connect to the Amazon eero router.

The operating system I'm using is Arch Linux. If, on the same machine, I start windows I'm instead capable both to connect to vpn or execute ssh based git commands

This is what I tried:

- Changing DNS on the eero router
- Changing DNS on the local machine
- Natting the port 22 and 9418 on the eero router and also both there and on the router giving connection to the eero
- Disabling any firewall both on router and on local machine
- Hard resetting the eero router

Nothing of this worked.

Here an example of ssh -vvv git@github.com (working) and one of ssh -Tvvv git@github.com (not working):

ssh -vvv git@github.com (working)

       OpenSSH_9.5p1, OpenSSL 3.1.4 24 Oct 2023
    debug1: Reading configuration data /home/skato/.ssh/config
    debug1: /home/skato/.ssh/config line 1: Applying options for github.com
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 2: include /etc/ssh/ssh_config.d/*.conf matched no files
    debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/home/skato/.ssh/known_hosts'
    debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/home/skato/.ssh/known_hosts2'
    debug2: resolving "github.com" port 22
    debug3: resolve_host: lookup github.com:22
    debug3: ssh_connect_direct: entering
    debug1: Connecting to github.com [140.82.121.4] port 22.
    debug3: set_sock_tos: set socket 3 IP_TOS 0x48
    debug1: Connection established.
    debug1: identity file /home/skato/.ssh/id_rsa type 0
    debug1: identity file /home/skato/.ssh/id_rsa-cert type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa-cert type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa_sk type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa_sk-cert type -1
    debug1: identity file /home/skato/.ssh/id_ed25519 type -1
    debug1: identity file /home/skato/.ssh/id_ed25519-cert type -1
    debug1: identity file /home/skato/.ssh/id_ed25519_sk type -1
    debug1: identity file /home/skato/.ssh/id_ed25519_sk-cert type -1
    debug1: identity file /home/skato/.ssh/id_xmss type -1
    debug1: identity file /home/skato/.ssh/id_xmss-cert type -1
    debug1: identity file /home/skato/.ssh/id_dsa type -1
    debug1: identity file /home/skato/.ssh/id_dsa-cert type -1
    debug1: Local version string SSH-2.0-OpenSSH_9.5
    debug1: Remote protocol version 2.0, remote software version babeld-f8b1fc6c
    debug1: compat_banner: no match: babeld-f8b1fc6c
    debug2: fd 3 setting O_NONBLOCK
    debug1: Authenticating to github.com:22 as 'git'
    debug3: record_hostkey: found key type ED25519 in file /home/skato/.ssh/known_hosts:3
    debug3: record_hostkey: found key type ECDSA in file /home/skato/.ssh/known_hosts:4
    debug3: record_hostkey: found key type RSA in file /home/skato/.ssh/known_hosts:12
    debug3: load_hostkeys_file: loaded 3 keys from github.com
    debug1: load_hostkeys: fopen /home/skato/.ssh/known_hosts2: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts2: No such file or directory
    debug3: order_hostkeyalgs: have matching best-preference key type ssh-ed25519-cert-v01@openssh.com, using HostkeyAlgorithms verbatim
    debug3: send packet: type 20
    debug1: SSH2_MSG_KEXINIT sent
    debug3: receive packet: type 20
    debug1: SSH2_MSG_KEXINIT received
    debug2: local client KEXINIT proposal
    debug2: KEX algorithms: sntrup761x25519-sha512@openssh.com,curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,ext-info-c
    debug2: host key algorithms: ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,sk-ssh-ed25519-cert-v01@openssh.com,sk-ecdsa-sha2-nistp256-cert-v01@openssh.com,rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-ed25519,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ssh-ed25519@openssh.com,sk-ecdsa-sha2-nistp256@openssh.com,rsa-sha2-512,rsa-sha2-256
    debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
    debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
    debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
    debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
    debug2: compression ctos: none,zlib@openssh.com,zlib
    debug2: compression stoc: none,zlib@openssh.com,zlib
    debug2: languages ctos:
    debug2: languages stoc:
    debug2: first_kex_follows 0
    debug2: reserved 0
    debug2: peer server KEXINIT proposal
    debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256
    debug2: host key algorithms: ssh-ed25519,ecdsa-sha2-nistp256,rsa-sha2-512,rsa-sha2-256,ssh-rsa
    debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr
    debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr
    debug2: MACs ctos: hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512,hmac-sha2-256
    debug2: MACs stoc: hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512,hmac-sha2-256
    debug2: compression ctos: none,zlib@openssh.com,zlib
    debug2: compression stoc: none,zlib@openssh.com,zlib
    debug2: languages ctos:
    debug2: languages stoc:
    debug2: first_kex_follows 0
    debug2: reserved 0
    debug1: kex: algorithm: curve25519-sha256
    debug1: kex: host key algorithm: ssh-ed25519
    debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
    debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
    debug3: send packet: type 30
    debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    debug3: receive packet: type 31
    debug1: SSH2_MSG_KEX_ECDH_REPLY received
    debug1: Server host key: ssh-ed25519 SHA256:+DiY3wvvV6TuJJhbpZisF/zLDA0zPMSvHdkr4UvCOqU
    debug3: record_hostkey: found key type ED25519 in file /home/skato/.ssh/known_hosts:3
    debug3: record_hostkey: found key type ECDSA in file /home/skato/.ssh/known_hosts:4
    debug3: record_hostkey: found key type RSA in file /home/skato/.ssh/known_hosts:12
    debug3: load_hostkeys_file: loaded 3 keys from github.com
    debug1: load_hostkeys: fopen /home/skato/.ssh/known_hosts2: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts2: No such file or directory
    debug1: Host 'github.com' is known and matches the ED25519 host key.
    debug1: Found key in /home/skato/.ssh/known_hosts:3
    debug3: send packet: type 21
    debug2: ssh_set_newkeys: mode 1
    debug1: rekey out after 134217728 blocks
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug3: receive packet: type 21
    debug1: SSH2_MSG_NEWKEYS received
    debug2: ssh_set_newkeys: mode 0
    debug1: rekey in after 134217728 blocks
    debug1: Will attempt key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug1: Will attempt key: /home/skato/.ssh/id_ecdsa
    debug1: Will attempt key: /home/skato/.ssh/id_ecdsa_sk
    debug1: Will attempt key: /home/skato/.ssh/id_ed25519
    debug1: Will attempt key: /home/skato/.ssh/id_ed25519_sk
    debug1: Will attempt key: /home/skato/.ssh/id_xmss
    debug1: Will attempt key: /home/skato/.ssh/id_dsa
    debug2: pubkey_prepare: done
    debug3: send packet: type 5
    debug3: receive packet: type 7
    debug1: SSH2_MSG_EXT_INFO received
    debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp256-cert-v01@openssh.com,sk-ssh-ed25519-cert-v01@openssh.com,sk-ecdsa-sha2-nistp256-cert-v01@openssh.com,rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,sk-ssh-ed25519@openssh.com,sk-ecdsa-sha2-nistp256@openssh.com,ssh-ed25519,ecdsa-sha2-nistp521,ecdsa-sha2-nistp384,ecdsa-sha2-nistp256,rsa-sha2-512,rsa-sha2-256,ssh-rsa>
    debug3: receive packet: type 6
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug3: send packet: type 50
    debug3: receive packet: type 51
    debug1: Authentications that can continue: publickey
    debug3: start over, passed a different list publickey
    debug3: preferred publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: send packet: type 50
    debug2: we sent a publickey packet, wait for reply
    debug3: receive packet: type 60
    debug1: Server accepts key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: sign_and_send_pubkey: using publickey with RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: sign_and_send_pubkey: signing using rsa-sha2-512 SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: send packet: type 50
    debug3: receive packet: type 52
    Authenticated to github.com ([140.82.121.4]:22) using "publickey".
    debug1: channel 0: new session [client-session] (inactive timeout: 0)
    debug3: ssh_session2_open: channel_new: 0
    debug2: channel 0: send open
    debug3: send packet: type 90
    debug1: Entering interactive session.
    debug1: pledge: filesystem
    debug3: client_repledge: enter
    debug3: receive packet: type 80
    debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
    debug3: client_input_hostkeys: received RSA key SHA256:uNiVztksCsDhcc0u9e8BujQXVUpKZIDTMczCvj3tD2s
    debug3: client_input_hostkeys: received ECDSA key SHA256:p2QAMXNIC1TJYWeIOttrVc98/R1BUFWu3/LiyKgUfQM
    debug3: client_input_hostkeys: received ED25519 key SHA256:+DiY3wvvV6TuJJhbpZisF/zLDA0zPMSvHdkr4UvCOqU
    debug1: client_input_hostkeys: searching /home/skato/.ssh/known_hosts for github.com / (none)
    debug3: hostkeys_foreach: reading file "/home/skato/.ssh/known_hosts"
    debug3: hostkeys_find: found ssh-ed25519 key at /home/skato/.ssh/known_hosts:3
    debug3: hostkeys_find: found ecdsa-sha2-nistp256 key at /home/skato/.ssh/known_hosts:4
    debug3: hostkeys_find: found ssh-rsa key at /home/skato/.ssh/known_hosts:12
    debug1: client_input_hostkeys: searching /home/skato/.ssh/known_hosts2 for github.com / (none)
    debug1: client_input_hostkeys: hostkeys file /home/skato/.ssh/known_hosts2 does not exist
    debug3: client_input_hostkeys: 3 server keys: 0 new, 3 retained, 0 incomplete match. 0 to remove
    debug1: client_input_hostkeys: no new or deprecated keys from server
    debug3: client_repledge: enter
    debug3: receive packet: type 91
    debug2: channel_input_open_confirmation: channel 0: callback start
    debug2: fd 3 setting TCP_NODELAY
    debug3: set_sock_tos: set socket 3 IP_TOS 0x48
    debug2: client_session2_setup: id 0
    debug2: channel 0: request pty-req confirm 1
    debug3: send packet: type 98
    debug2: channel 0: request shell confirm 1
    debug3: send packet: type 98
    debug3: client_repledge: enter
    debug1: pledge: fork
    debug2: channel_input_open_confirmation: channel 0: callback done
    debug2: channel 0: open confirm rwindow 32000 rmax 35000
    debug3: receive packet: type 100
    debug2: channel_input_status_confirm: type 100 id 0
    PTY allocation request failed on channel 0
    debug3: receive packet: type 99
    debug2: channel_input_status_confirm: type 99 id 0
    debug2: shell request accepted on channel 0
    debug2: channel 0: rcvd ext data 3
    debug2: channel 0: rcvd ext data 5
    debug2: channel 0: rcvd ext data 2
    debug2: channel 0: rcvd ext data 76
    debug2: channel 0: rcvd ext data 1
    debug3: receive packet: type 98
    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug3: receive packet: type 96
    debug2: channel 0: rcvd eof
    debug2: channel 0: output open -> drain
    debug3: receive packet: type 97
    debug2: channel 0: rcvd close
    debug2: chan_shutdown_read: channel 0: (i0 o1 sock -1 wfd 4 efd 6 [write])
    debug2: channel 0: input open -> closed
    debug3: channel 0: will not send data after close
    debug2: channel 0: obuf_empty delayed efd 6/(87)
    Hi sk4t0! You've successfully authenticated, but GitHub does not provide shell access.
    debug2: channel 0: written 87 to efd 6
    debug3: channel 0: will not send data after close
    debug2: channel 0: obuf empty
    debug2: chan_shutdown_write: channel 0: (i3 o1 sock -1 wfd 5 efd 6 [write])
    debug2: channel 0: output drain -> closed
    debug2: channel 0: almost dead
    debug2: channel 0: gc: notify user
    debug2: channel 0: gc: user detached
    debug2: channel 0: send close
    debug3: send packet: type 97
    debug2: channel 0: is dead
    debug2: channel 0: garbage collecting
    debug1: channel 0: free: client-session, nchannels 1
    debug3: channel 0: status: The following connections are open:
    #0 client-session (t4 [session] r43 i3/0 o3/0 e[write]/0 fd -1/-1/6 sock -1 cc -1 io 0x00/0x00)
    
    debug3: send packet: type 1
    Connection to github.com closed.
    Transferred: sent 3844, received 3076 bytes, in 0.3 seconds
    Bytes per second: sent 14869.6, received 11898.8
    debug1: Exit status 1

ssh -Tvvv git@github.com (not working)

       OpenSSH_9.5p1, OpenSSL 3.1.4 24 Oct 2023
    debug1: Reading configuration data /home/skato/.ssh/config
    debug1: /home/skato/.ssh/config line 1: Applying options for github.com
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 2: include /etc/ssh/ssh_config.d/*.conf matched no files
    debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/home/skato/.ssh/known_hosts'
    debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/home/skato/.ssh/known_hosts2'
    debug2: resolving "github.com" port 22
    debug3: resolve_host: lookup github.com:22
    debug3: ssh_connect_direct: entering
    debug1: Connecting to github.com [140.82.121.4] port 22.
    debug3: set_sock_tos: set socket 3 IP_TOS 0x48
    debug1: Connection established.
    debug1: identity file /home/skato/.ssh/id_rsa type 0
    debug1: identity file /home/skato/.ssh/id_rsa-cert type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa-cert type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa_sk type -1
    debug1: identity file /home/skato/.ssh/id_ecdsa_sk-cert type -1
    debug1: identity file /home/skato/.ssh/id_ed25519 type -1
    debug1: identity file /home/skato/.ssh/id_ed25519-cert type -1
    debug1: identity file /home/skato/.ssh/id_ed25519_sk type -1
    debug1: identity file /home/skato/.ssh/id_ed25519_sk-cert type -1
    debug1: identity file /home/skato/.ssh/id_xmss type -1
    debug1: identity file /home/skato/.ssh/id_xmss-cert type -1
    debug1: identity file /home/skato/.ssh/id_dsa type -1
    debug1: identity file /home/skato/.ssh/id_dsa-cert type -1
    debug1: Local version string SSH-2.0-OpenSSH_9.5
    debug1: Remote protocol version 2.0, remote software version babeld-f8b1fc6c
    debug1: compat_banner: no match: babeld-f8b1fc6c
    debug2: fd 3 setting O_NONBLOCK
    debug1: Authenticating to github.com:22 as 'git'
    debug3: record_hostkey: found key type ED25519 in file /home/skato/.ssh/known_hosts:3
    debug3: record_hostkey: found key type ECDSA in file /home/skato/.ssh/known_hosts:4
    debug3: record_hostkey: found key type RSA in file /home/skato/.ssh/known_hosts:12
    debug3: load_hostkeys_file: loaded 3 keys from github.com
    debug1: load_hostkeys: fopen /home/skato/.ssh/known_hosts2: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts2: No such file or directory
    debug3: order_hostkeyalgs: have matching best-preference key type ssh-ed25519-cert-v01@openssh.com, using HostkeyAlgorithms verbatim
    debug3: send packet: type 20
    debug1: SSH2_MSG_KEXINIT sent
    debug3: receive packet: type 20
    debug1: SSH2_MSG_KEXINIT received
    debug2: local client KEXINIT proposal
    debug2: KEX algorithms: sntrup761x25519-sha512@openssh.com,curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,ext-info-c
    debug2: host key algorithms: ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,sk-ssh-ed25519-cert-v01@openssh.com,sk-ecdsa-sha2-nistp256-cert-v01@openssh.com,rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-ed25519,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ssh-ed25519@openssh.com,sk-ecdsa-sha2-nistp256@openssh.com,rsa-sha2-512,rsa-sha2-256
    debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
    debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
    debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
    debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
    debug2: compression ctos: none,zlib@openssh.com,zlib
    debug2: compression stoc: none,zlib@openssh.com,zlib
    debug2: languages ctos:
    debug2: languages stoc:
    debug2: first_kex_follows 0
    debug2: reserved 0
    debug2: peer server KEXINIT proposal
    debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256
    debug2: host key algorithms: ssh-ed25519,ecdsa-sha2-nistp256,rsa-sha2-512,rsa-sha2-256,ssh-rsa
    debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr
    debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr,aes192-ctr,aes128-ctr
    debug2: MACs ctos: hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512,hmac-sha2-256
    debug2: MACs stoc: hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512,hmac-sha2-256
    debug2: compression ctos: none,zlib@openssh.com,zlib
    debug2: compression stoc: none,zlib@openssh.com,zlib
    debug2: languages ctos:
    debug2: languages stoc:
    debug2: first_kex_follows 0
    debug2: reserved 0
    debug1: kex: algorithm: curve25519-sha256
    debug1: kex: host key algorithm: ssh-ed25519
    debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
    debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
    debug3: send packet: type 30
    debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    debug3: receive packet: type 31
    debug1: SSH2_MSG_KEX_ECDH_REPLY received
    debug1: Server host key: ssh-ed25519 SHA256:+DiY3wvvV6TuJJhbpZisF/zLDA0zPMSvHdkr4UvCOqU
    debug3: record_hostkey: found key type ED25519 in file /home/skato/.ssh/known_hosts:3
    debug3: record_hostkey: found key type ECDSA in file /home/skato/.ssh/known_hosts:4
    debug3: record_hostkey: found key type RSA in file /home/skato/.ssh/known_hosts:12
    debug3: load_hostkeys_file: loaded 3 keys from github.com
    debug1: load_hostkeys: fopen /home/skato/.ssh/known_hosts2: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts: No such file or directory
    debug1: load_hostkeys: fopen /etc/ssh/ssh_known_hosts2: No such file or directory
    debug1: Host 'github.com' is known and matches the ED25519 host key.
    debug1: Found key in /home/skato/.ssh/known_hosts:3
    debug3: send packet: type 21
    debug2: ssh_set_newkeys: mode 1
    debug1: rekey out after 134217728 blocks
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug3: receive packet: type 21
    debug1: SSH2_MSG_NEWKEYS received
    debug2: ssh_set_newkeys: mode 0
    debug1: rekey in after 134217728 blocks
    debug1: Will attempt key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug1: Will attempt key: /home/skato/.ssh/id_ecdsa
    debug1: Will attempt key: /home/skato/.ssh/id_ecdsa_sk
    debug1: Will attempt key: /home/skato/.ssh/id_ed25519
    debug1: Will attempt key: /home/skato/.ssh/id_ed25519_sk
    debug1: Will attempt key: /home/skato/.ssh/id_xmss
    debug1: Will attempt key: /home/skato/.ssh/id_dsa
    debug2: pubkey_prepare: done
    debug3: send packet: type 5
    debug3: receive packet: type 7
    debug1: SSH2_MSG_EXT_INFO received
    debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp256-cert-v01@openssh.com,sk-ssh-ed25519-cert-v01@openssh.com,sk-ecdsa-sha2-nistp256-cert-v01@openssh.com,rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,sk-ssh-ed25519@openssh.com,sk-ecdsa-sha2-nistp256@openssh.com,ssh-ed25519,ecdsa-sha2-nistp521,ecdsa-sha2-nistp384,ecdsa-sha2-nistp256,rsa-sha2-512,rsa-sha2-256,ssh-rsa>
    debug3: receive packet: type 6
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug3: send packet: type 50
    debug3: receive packet: type 51
    debug1: Authentications that can continue: publickey
    debug3: start over, passed a different list publickey
    debug3: preferred publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: send packet: type 50
    debug2: we sent a publickey packet, wait for reply
    debug3: receive packet: type 60
    debug1: Server accepts key: /home/skato/.ssh/id_rsa RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: sign_and_send_pubkey: using publickey with RSA SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: sign_and_send_pubkey: signing using rsa-sha2-512 SHA256:zaBX+3TpV+3eRToKSta/UFkCrA+YnOfS25Ki4179Txg
    debug3: send packet: type 50
    debug3: receive packet: type 52
    Authenticated to github.com ([140.82.121.4]:22) using "publickey".
    debug1: channel 0: new session [client-session] (inactive timeout: 0)
    debug3: ssh_session2_open: channel_new: 0
    debug2: channel 0: send open
    debug3: send packet: type 90
    debug1: Entering interactive session.
    debug1: pledge: filesystem
    debug3: client_repledge: enter
    debug3: receive packet: type 80
    debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
    debug3: client_input_hostkeys: received RSA key SHA256:uNiVztksCsDhcc0u9e8BujQXVUpKZIDTMczCvj3tD2s
    debug3: client_input_hostkeys: received ECDSA key SHA256:p2QAMXNIC1TJYWeIOttrVc98/R1BUFWu3/LiyKgUfQM
    debug3: client_input_hostkeys: received ED25519 key SHA256:+DiY3wvvV6TuJJhbpZisF/zLDA0zPMSvHdkr4UvCOqU
    debug1: client_input_hostkeys: searching /home/skato/.ssh/known_hosts for github.com / (none)
    debug3: hostkeys_foreach: reading file "/home/skato/.ssh/known_hosts"
    debug3: hostkeys_find: found ssh-ed25519 key at /home/skato/.ssh/known_hosts:3
    debug3: hostkeys_find: found ecdsa-sha2-nistp256 key at /home/skato/.ssh/known_hosts:4
    debug3: hostkeys_find: found ssh-rsa key at /home/skato/.ssh/known_hosts:12
    debug1: client_input_hostkeys: searching /home/skato/.ssh/known_hosts2 for github.com / (none)
    debug1: client_input_hostkeys: hostkeys file /home/skato/.ssh/known_hosts2 does not exist
    debug3: client_input_hostkeys: 3 server keys: 0 new, 3 retained, 0 incomplete match. 0 to remove
    debug1: client_input_hostkeys: no new or deprecated keys from server
    debug3: client_repledge: enter
    debug3: receive packet: type 91
    debug2: channel_input_open_confirmation: channel 0: callback start
    debug2: fd 3 setting TCP_NODELAY
    debug3: set_sock_tos: set socket 3 IP_TOS 0x20
    debug2: client_session2_setup: id 0
    debug2: channel 0: request shell confirm 1
    debug3: send packet: type 98
    debug3: client_repledge: enter
    debug1: pledge: fork
    debug2: channel_input_open_confirmation: channel 0: callback done
    debug2: channel 0: open confirm rwindow 32000 rmax 35000

and around 13 minutes after:

   debug3: receive packet: type 80
    debug1: client_input_global_request: rtype keepalive@openssh.com want_reply 1
    debug3: send packet: type 82
    debug3: send packet: type 1
    debug1: channel 0: free: client-session, nchannels 1
    debug3: channel 0: status: The following connections are open:
    #0 client-session (t4 [session] r43 i0/0 o0/0 e[write]/0 fd 4/5/6 sock -1 cc -1 io 0x01/0x00)
    
    Connection to github.com closed by remote host.
    Transferred: sent 3504, received 2784 bytes, in 780.2 seconds
    Bytes per second: sent 4.5, received 3.6
    debug1: Exit status -1 
Solved

Solved the ssh -T problem. A description is given here: https://github.com/microsoft/WSL/issues/7058. Long story short it seems the eero, as the TP-Link in the link, cannot handle IPQos (used with ssh -T) correctly, so I disabled IPQos in config and it works.

edit:

For the ones with an eero: following the link shared by seth (https://community.eero.com/t/k96zzs/feature-request-qos) I tried enabling on the eero lab section the "Improve connection for video conference and games", reenabled IPQos, and it worked. So for eero users you just need to enable this feature without editing ssh config.

Last edited by skato (2023-11-16 11:57:22)

Offline

#2 2023-11-11 20:28:20

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: SOLVED - ssh hanging when adding -T parameter with specific router

Also, in addition to this, if I try connecting to a vpn (I use NordVPN) the vpn connect but I stop having an internet connection.

You're constanly using a vpn?

ip a

In doubt, try to lower the MTU - start at 1280 and then walk up to approx. 1420 and test the behavior (if it still fails for very low MTUs then it's unrelated)

sudo ip link set dev <device here> mtu 1280

Offline

#3 2023-11-11 21:01:09

skato
Member
Registered: 2023-11-11
Posts: 5

Re: SOLVED - ssh hanging when adding -T parameter with specific router

Thanks for your answer!

You're constanly using a vpn?

I shouldn't be, but in the test I did at the beginning I saw I was using nordvpn dns while not under vpn. I don't know if it was cache or anything else. Now I forced dns and I'm under the ones I defined both under vpn and not.

In doubt, try to lower the MTU - start at 1280 and then walk up to approx. 1420 and test the behavior (if it still fails for very low MTUs then it's unrelated)

I've tried but it still fails.
Anyway here is the ip a output for the specific interface I'm using:

3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether aa:bb:cc:dd:fa:89 brd ff:ff:ff:ff:ff:ff permaddr 11:22:33:44:07:4f
inet 192.168.4.140/22 brd 192.168.7.255 scope global dynamic noprefixroute wlp3s0
valid_lft 14334sec preferred_lft 14334sec
inet6 aaaa:cccc:cccc:1:dddd:eeee:e658:b221/64 scope global dynamic noprefixroute
valid_lft 2591937sec preferred_lft 604737sec
inet6 1111::2222:3333:bbbb:89ce/64 scope link noprefixroute
valid_lft forever preferred_lft forever

Let me know if you need the entire output (I've a lot of docker container bridges). I also masked something .

Offline

#4 2023-11-11 21:26:50

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: SOLVED - ssh hanging when adding -T parameter with specific router

This isn't about the DNS but where the packages are routed; fyi the MTU is (still?) at 1500

NIC 2 is wired ethernet? Does it exhbit the same behavior?
The IPv6 addresses are obfuscated by you? (one of them should start w/ fe80 and be a LLA)
You're connecting to github via IPv4, though - but some FWs show up w/ that pattern.

Can you connect to a ssh server in the LAN?
(It's not like you got a shell on the PTY-enabled github - you just get kicked immediately)

One more thing

on the same machine, I start windows I'm instead

3rd link below. Mandatory.
Disable it (it's NOT the BIOS setting!) and reboot windows and linux twice for voodo reasons.
And in this case, you probably also want to reboot the router afterwards.

Offline

#5 2023-11-12 09:25:34

skato
Member
Registered: 2023-11-11
Posts: 5

Re: SOLVED - ssh hanging when adding -T parameter with specific router

the MTU is (still?) at 1500

nono, this was took before changing the MTU

NIC 2 is wired ethernet? Does it exhbit the same behavior?

yes, but it's not connected. I didn't tried on this machine that is a desktop. But, and this is probably an important thing I forgot to mention, I have the same problem on a laptop, still with arch. I tried conneting with the wire that one but still same behavior.

The IPv6 addresses are obfuscated by you? (one of them should start w/ fe80 and be a LLA)

yes and there's actually one starting with fe80

Can you connect to a ssh server in the LAN?

Disable it (it's NOT the BIOS setting!) and reboot windows and linux twice for voodo reasons.
And in this case, you probably also want to reboot the router afterwards.

I will update on this 2 later after testing

Offline

#6 2023-11-13 09:31:04

skato
Member
Registered: 2023-11-11
Posts: 5

Re: SOLVED - ssh hanging when adding -T parameter with specific router

Can you connect to a ssh server in the LAN?

same behaviour. I can connect without -T parameter, if I add -T it hang.

Disable it (it's NOT the BIOS setting!) and reboot windows and linux twice for voodo reasons.
And in this case, you probably also want to reboot the router afterwards.

voodo didn´t work hmm lol
We joke about voodo, but for me what is happening is really like voodo, I can't really understand why ssh would work without -T and hang with -T.

Offline

#7 2023-11-13 09:53:23

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: SOLVED - ssh hanging when adding -T parameter with specific router

The voodoo part is anecdotal and probably related to some ACPI tables.
I can see why you need a PTY, but not why that hinges on your (new) router (shy of some firewall) but only with some OS

Try the behavior from the install iso or other linux live distros and wrt

I've a lot of docker container bridges

w/o those (who knows where you're actually routing)
---
You can possibly workaround that, https://unix.stackexchange.com/question … ssh-config but there are downsides, https://serverfault.com/questions/59339 … nal-in-ssh

Offline

#8 2023-11-15 07:52:51

skato
Member
Registered: 2023-11-11
Posts: 5

Re: SOLVED - ssh hanging when adding -T parameter with specific router

Sorry for the late answer. On unix stackexchange they helped me figuring out the ssh -T problem. A description is given here: https://github.com/microsoft/WSL/issues/7058. Long story short it seems the eero, as the TP-Link in the link, cannot handle IPQos (used with ssh -T) correctly, so I disabled IPQos in config and it works. No idea of the downsides btw, now I want to study better what IPQos is to better understand. About the vpn instead I solved: I'm using nordvpn and switching from nordlynx (wireguard) to openvpn solved the problem, but I really don't know why, it just was a test I did randomly. Any idea on the possible reason why, under this router, nordlynx/wireguard didn't work and openvpn yes?

Last edited by skato (2023-11-15 08:20:20)

Offline

#9 2023-11-15 08:23:40

seth
Member
Registered: 2012-09-03
Posts: 50,772

Re: SOLVED - ssh hanging when adding -T parameter with specific router

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.


https://en.wikipedia.org/wiki/Quality_of_service
tl;dr - get a router firmware fix … or replace the router: https://community.eero.com/t/k96zzs/feature-request-qos


About VPN, misconfiguration?
https://wiki.archlinux.org/title/NordVP … Wireguard)

I don't think we've seen any VPN realated data (config/symptoms/routing/firewall) in this thread and it would certainly be subject for another thread (since that can turn complicated)

Offline

Board footer

Powered by FluxBB