You are not logged in.

#1 2024-02-10 11:28:13

iskander9908
Member
Registered: 2022-10-30
Posts: 26

[SOLVED]Games lag

Hi!
I have a problem, when laptop on power supply. It frequently lags, while I'm playing video games. My thoughts was that tlp is the reason, but it lags even when tlp is disabled.
Please, tell how it can be fixed.

Last edited by iskander9908 (2024-02-14 06:45:57)

Offline

#2 2024-02-10 15:40:40

seth
Member
Registered: 2012-09-03
Posts: 50,891

Re: [SOLVED]Games lag

Disable your battery notification stuff.
Get a faster laptop.

Read https://bbs.archlinux.org/viewtopic.php?id=57855 and make a minimum effort to provide some details on the situation, like hardware, drivers, display server, what game and since you're stressing "power supply" whether that's actually not a problem on battery.

Offline

#3 2024-02-11 06:07:13

iskander9908
Member
Registered: 2022-10-30
Posts: 26

Re: [SOLVED]Games lag

Hardware information:

neofetch                                                
                   -`                    iskander@arch 
                  .o+`                   ------------- 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: Alpha 15 B5EEK REV:1.0 
               `+oooooo:                 Kernel: 6.7.4-zen1-1-zen 
               -+oooooo+:                Uptime: 8 mins 
             `/:-:++oooo+:               Packages: 862 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.9 
           `/++++++++++++++:             Resolution: 1920x1080 
          `/+++ooooooooooooo/`           WM: sway 
         ./ooosssso++osssssso+`          Theme: Adwaita [GTK3] 
        .oossssso-````/ossssss+`         Icons: Adwaita [GTK3] 
       -osssssso.      :ssssssso.        Terminal: kitty 
      :osssssss/        osssso+++.       CPU: AMD Ryzen 7 5800H with Radeon Graphics (16) @ 4.463GHz 
     /ossssssss/        +ssssooo/-       GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series 
   `/ossssso+/:-        -:/+osssso+-     GPU: AMD ATI Radeon RX 6600/6600 XT/6600M 
  `+sso+:-`                 `.-/+oso:    Memory: 2043MiB / 15368MiB 
 `++:.                           `-/+/
 .`                                 `/                       

Drivers installed:

mesa lib32-mesa vulkan-radeon lib32-vulkan-radeon libva-mesa-driver lib32-libva-mesa-driver mesa-vdpau lib32-mesa-vdpau mesa-utils

I have a Wayland display server and every game lags on the power supply as opposed to when it's charging.

Last edited by iskander9908 (2024-02-11 06:53:29)

Offline

#4 2024-02-11 08:51:59

seth
Member
Registered: 2012-09-03
Posts: 50,891

Re: [SOLVED]Games lag

"a wayland compositor" isn't a thing, you're running sway.

game lags on the power supply as opposed to when it's charging

That makes no sense at all.
Do you mean it's lagging on battery, ie. when you've NOT plugged a power cord in?

You've a hybrid setup:
*what* game lags on *what* GPU?
Also check the CPU frequencies between the system on battery and power supply, https://wiki.archlinux.org/title/CPU_frequency_scaling as well as the GPU profiles, https://wiki.archlinux.org/title/AMDGPU#Power_profiles

nb. that the firmware might unconditionally contrain performance when the system is on battery and you'd have to configure that in the firmware (uefi)

Offline

Board footer

Powered by FluxBB