You are not logged in.

#1 2024-03-18 19:55:25

I3eastmaster
Member
Registered: 2023-06-09
Posts: 10

Timeout waiting for device while creating a static bridge with netctl

Hello all,

I'm trying to get a VPN server running with OpenVPN.
I followed the main OpenVPN article, did some portforwarding and was able to connect with my phone from the outside world to the VPN server.
My next step was to setup Layer 2 (?, not sure here), in any case, I wanted my phone to be a real device in the network so that I would be able to connect to my servers and use their local webui interfaces, etc.

I followed the basic Setup static bridge and since I want to use DHCP I followed down the netctl, installed dhcpcd created the config file, stopped using systemd-networkd and systemd-resolved in favor of netctl.
Though when I try to start the bridge, I get the following error:

systemd[1]: Expecting device /sys/subsystem/net/devices/ens19,...
systemd[1]: sys-subsystem-net-devices-ens19\x2c.device: Job sys-subsystem-net-devices-ens19\x2c.device/start timed out.
Timed out waiting for device /sys/subsystem/net/devices/ens19,.
Dependency failed for VPN Bridge connection.
netctl@openvpn_bridge.service: Job netctl@openvpn_bridge.service/start failed with result 'dependency'.
sys-subsystem-net-devices-ens19\x2c.device: Job sys-subsystem-net-devices-ens19\x2c.device/start failed with result 'timeout'.

ens19 is a network interface on my machine, just like ens18 (which i've tried as well, giving the same result)

2: ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether bc:24:11:47:31:89 brd ff:ff:ff:ff:ff:ff
    altname enp0s18
    inet 192.168.10.11/24 brd 192.168.10.255 scope global dynamic noprefixroute ens18
       valid_lft 4325sec preferred_lft 3425sec
    inet6 fe80::be24:11ff:fe47:3189/64 scope link proto kernel_ll 
       valid_lft forever preferred_lft forever
3: tap0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether ae:93:78:1e:4e:e1 brd ff:ff:ff:ff:ff:ff
4: ens19: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether bc:24:11:8f:18:e8 brd ff:ff:ff:ff:ff:ff
    altname enp0s19
    inet 192.168.87.102/24 brd 192.168.87.255 scope global dynamic noprefixroute ens19
       valid_lft 7197sec preferred_lft 6297sec
    inet6 fe80::be24:11ff:fe8f:18e8/64 scope link proto kernel_ll 
       valid_lft forever preferred_lft forever

netctl bridge file:

Description="VPN Bridge connection"
Interface=br0
Connection=bridge
#BindsToInterfaces=(eth0 tap0)
BindsToInterfaces=(ens19, tap0)
IP=dhcp

In case it matters, this is a VM running on proxmox.

Anyone able to help?

Offline

#2 2024-03-19 06:37:54

-thc
Member
Registered: 2017-03-15
Posts: 546

Re: Timeout waiting for device while creating a static bridge with netctl

There are several points to address here:

First make sure you're OpenVPN clients support bridge mode (TAP) connections. Android for example dropped TAP support some releases ago.

Check whether your hypervisor (Proxmox) supports bridging in guests - I had to configure VMWare ESXi to allow this and Hyper-V does not allow that at all.

If your clients and your hypervisor support bridge mode connections - start with the bridge mode howto of OpenVPN (https://openvpn.net/community-resources … -bridging/). You bridge the main ethernet interface (Your ens18) with a TAP interface and set up the VPN server using the bridged TAP interface. OpenVPN in bridge mode does DHCP on it's own.

Offline

#3 2024-03-19 12:59:06

I3eastmaster
Member
Registered: 2023-06-09
Posts: 10

Re: Timeout waiting for device while creating a static bridge with netctl

Thanks, I think that's all I needed to know. I'm assuming the bridge wont come up because of the hypervisor, I'll not look into that much further as I understand (bridge mode) TAP won't work anyway.

Still have a lot to learn smile

Offline

Board footer

Powered by FluxBB