You are not logged in.

#1 2024-04-11 15:28:45

Alarming_Thing
Member
Registered: 2021-06-01
Posts: 32

[Solved] Wireless is slow on Arch but normal on Windows [ BCM4313 ]

Hello,
I dualboot Arch (kde) with Win 10 on an ancient machine. Both are fresh installations.
The download speed in Windows is about 15 Mbps (normal) while in Arch it's less than 700 Kbps. Arch often disconnects/connects multiple times - so downloading anything about 25 Mb is hard, if not impossible.

- Browser is used to measure speed (fast.com / speedtest.net). I don't have speedtest-cli.
- The network adapter is BCM4312.
- lspci -k shows "Kernel driver in use: bcma-pci-bridge | Kernel modules: bcma"
- Fast-boot is disabled in Windows (if it matters)
- I've removed iwd, and use NetworkManager/wpa (for better integration with kde)

I did some search on arch bbs, and found one of two threads in which they used drill command, output of which is in the link below. There are a couple of entries from journal as well.
http://0x0.st/X-Zr.txt

TIA & requesting for any help in fixing network speed.

Last edited by Alarming_Thing (2024-04-11 17:35:09)

Offline

#2 2024-04-11 16:29:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,384

Re: [Solved] Wireless is slow on Arch but normal on Windows [ BCM4313 ]

Test boradcom-wl and read through: https://wiki.archlinux.org/title/Broadcom_wireless

Offline

#3 2024-04-11 17:34:31

Alarming_Thing
Member
Registered: 2021-06-01
Posts: 32

Re: [Solved] Wireless is slow on Arch but normal on Windows [ BCM4313 ]

V1del wrote:

Test boradcom-wl and read through: https://wiki.archlinux.org/title/Broadcom_wireless

Thanks. I wasn't aware there's a section for Broadcom chipsets.

Update:  BCM4313 is not fully supported by open source driver, but it somewhat works.

Last edited by Alarming_Thing (2024-04-11 19:01:41)

Offline

Board footer

Powered by FluxBB