You are not logged in.

#1 2024-05-07 15:03:06

Mersikka
Member
Registered: 2024-05-07
Posts: 1

(SOLVED) Games crash after loading in to a game.

As of today, I've started experiencing an issue that crashes my game as soon as I load into a game. The main menus always seem to work fine, but as soon as I load into a match or a game the application just crashes.

So far I've tried playing BG3, Team Fortress 2 and Dark Souls 3, with Dark Souls 3 being the only one that doesn't crash for some reason. Team Fortress 2 crashing as well would suggest this is not an issue with Proton. I'll keep trying other games, but in the mean time any and all help would be greatly appreciated!

EDIT: Forgot to mention I'm using Steam runtime with Wayland and an RX 5700 XT GPU.

EDIT 2: Solved by downgrading kernel.

Last edited by Mersikka (2024-05-07 15:47:33)

Offline

#2 2024-05-07 15:08:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 22,386

Re: (SOLVED) Games crash after loading in to a game.

I'm assuming you are using amdgpu (this is one of the details in lieu of applications logs that you should provide... I'm just making a well informed guess here), there's a known kernel regression in 6.8.9/6.6.30 that has an issue in the video memory access between GPU and CPU. Either enable resizable BAR in your UEFI or downgrade the kernel to 6.8.8/6.6.29

Also please search the boards, e.g.

https://bbs.archlinux.org/viewtopic.php?id=295456
https://bbs.archlinux.org/viewtopic.php?id=295520

Last edited by V1del (2024-05-07 15:10:32)

Offline

#3 2024-05-10 17:21:18

Ihatemyself
Member
Registered: 2024-05-10
Posts: 1

Re: (SOLVED) Games crash after loading in to a game.

V1del wrote:

I'm assuming you are using amdgpu (this is one of the details in lieu of applications logs that you should provide... I'm just making a well informed guess here), there's a known kernel regression in 6.8.9/6.6.30 that has an issue in the video memory access between GPU and CPU. Either enable resizable BAR in your UEFI or downgrade the kernel to 6.8.8/6.6.29

Also please search the boards, e.g.

https://bbs.archlinux.org/viewtopic.php?id=295456
https://bbs.archlinux.org/viewtopic.php?id=295520


Holy fucking shit, you saved my sanity. I was also experiencing similar crashes in several different games, especially that run on the unity engine. The game would load to the title screen but crash when I pressed play, sometimes it would load the first area but crash as soon as I loaded into a second one. I tried everything from entire new wine prefix, reinstall all visual code libraries, reinstalling wine, reinstalling drivers, changing session to wayland. What was extremely frustrating was that the crashes were highly inconsistent and did not leave any logs on lutris or steam, any that I could find atleast, the error codes were generic ones that could not be singled out. The errors would change as I tried different proton versions but the crashes would always come back. Never had I experienced this kind of bug before.
I turned on resizable bar and Viola!, no more crashes.
Thanks for solution.
I'd suck you off if I could.

Offline

Board footer

Powered by FluxBB