You are not logged in.

#1 2004-03-25 23:44:03

From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

troubles with 3Com 3crshpw196 card (2.6.4) WLAN (solved)

hi, I finally mnaged to get arch (2.6.4-1  kernel) into my laptop without the use of floppy (its usb -so it cant load root), or cd-rom (stupid - cant boot from it)

what i did was that i put my laptop hd into my workstation, booted from cd and installed it on the little drive. then i put the hd back into my laptop and booted.. it works.. (almost..)

before i put the drive back into my laptop i did a pacman -Syu just to get things up to date.
i then installed (with pacman) wireless_tools , , pcmcia-cs , and downloaded the driver from the

the reason for these packages is that i need my 3Com 3crshpw196 pcmcia card to work since  its the only way this pc can access anything (ultraportable without standard network  card).

"enabled" the pcmcia daemon in rc.conf

cardctl ident gives me this:
Socket 0:
product info: "3Com", "3CRSHPW_96 Wireless LAN PC Card"
manfid: 0x0101, 0x0696
function: 6 (network)

cat /var/lib/pcmcia/stab gives me this :
Socket 0: unsupported card

ifconfig -a gives me :
lo   bla bla bla
sit0 Link encap:UNSPEC HWaddr 00-00-00.......

but i have no idea what the last interface it prints out is :

NOARP MTU:1480 Metric:1
RX packets:0 <and everything else is 0>

iwconfig gives me "lo" and "sit0"

in dmesg i found this :
Yenta: CArdBus bridge found at 0000:00:0b.1 [1179:0001]
Yenta: ISA IRQ mask 0x0800, PCI irq 0

it seems to me like the system identifies the socket as the yenta_socket, but I cant modprobe it, --> FATAL: Module yenta_socket not found.

cardctl identified the card corrctly, but neither cardmgr (or whatever its called) or myself are able to modprobe the atmel_cs module which from what I have read have been in the kernel since 2.5.x.

and just to top the hole thing; for some reason I couldnt compile the atmel driver from sourceforge either...
since i have to write all these system-messages for hand I'm not giveing you a printout of all the compile errors (and i should probably post that thing at the sourceforge forum too) , but it seemed like it couldt find the "mach_apicdef.h"

/lib/modules/2.6.4/build/include/asm/smp.h:71:26: mach_apicdef.h: No such file or directory

iit actually complained alot about /lib/modules/2.6.4/build/include/asm files in general...

the reason for the "apic-related errors"? might be that i dont have apic on my laptop (i dont even have a clue what apic is good for)

so basicly what I need is some tips on how to get my 3Com card working.

are the problems caused by the fact that I installed pcmcia-stuff on the harddrive while it was in another machine without pcmcia ?
or are there some bugs in a arch-pcmcia packages (perhaps not that likely since im not alone trying to run arch on a laptop)
or is this simply one of those "reinstall and everything is ok"

by the way.. i know the card works great in linux, 'cause it did just that in suse..

finally.. sorry for this huge post... i simply just wrote everything i knew about my issue..




#2 2004-03-26 02:59:39

Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797

Re: troubles with 3Com 3crshpw196 card (2.6.4) WLAN (solved)

With what you've described, I don't think you need wlan-ng (the one in the repos right now is compiled for the 2.4 series anyway, so it's not helpful).

I think your best option, at the moment, is to compile your own kernel.  Check this thread for steps to do so: … ml#SEC6.13

One thing that it's missing (and I've submitted a bug report for it) is removing the md5sums from the PKGBUILD.  After copying your custom config file, you need to edit the PKGBUILD and remove the md5sums line.

I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal


#3 2004-04-17 16:50:44

From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: troubles with 3Com 3crshpw196 card (2.6.4) WLAN (solved)

just thought i'd post an update now the problem is solved.

recompiling the kernel to get the needed modules (atmel_cs, atmel, crc32)
downloaded and installed the needed licenced atmel-binary from .
installing the binary also creates an "atmel.conf" in /etc/pcmcia which binds the cards using the atmel driver to its correct module (atmel_cs)

configure with iwconfig, ifconfig <interface> up and restart network worked like a charm...



Board footer

Powered by FluxBB