You are not logged in.

#1 2007-04-23 06:56:59

PsD
Member
Registered: 2005-11-07
Posts: 14

Problem with CPU solved. Sound problem - solved!

Hello everyone,

few days I made "pacman -Syu" and now i'm experiencing few very interesing/strange problems:
1) When my laptop is connected to ac-adapter - cpu usage is about 50% (or higher) even when i'm doing nothing (only xfce running with no programs launched), althouth load average is about 0.00. But when i leave my laptop running on battery - everything seems fine. Kernel is 2.6.20-ck

2) After the very same "pacman -Syu" xfce refuses to accept "alt" key. I can't use alt+f2, i can't use alt+left/right and so on. XFCE version is 4.4.1-1

Any suggestions?

Thanks in advance,
PsD

Last edited by PsD (2007-05-27 16:25:54)

Offline

#2 2007-05-03 01:50:03

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: Problem with CPU solved. Sound problem - solved!

For #2 I don't know anything as I'm a KDE user.

For #1, my notebook did the same thing when I got 2.6.19, and the problem has persisted into 2.6.20.  This thread: http://bbs.archlinux.org/viewtopic.php?id=28566 has the available answers.  I did have the command in my rc.local, but when I reloaded the system it turns out the system boots quicker if I use the option in the very last post.

Re: 30% CPU Usage when plugged in
Another way to solve the problem quickly.
You don't have to recompile the kernel.
You have to add the option " processor.max_cstate=1" to the boot command line.
For example, with grub I have this:

# (0) Arch Linux
title  Arch Linux  [2.6.19-Arch]
root   (hd0,4)
kernel /boot/vmlinuz26 root=/dev/hda5 vga=792 resume=/dev/hda6 processor.max_cstate=1 ro    <===== add here
initrd /boot/kernel26.img

Offline

#3 2007-05-15 17:46:02

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

QuimaxW wrote:

For #2 I don't know anything as I'm a KDE user.

For #1, my notebook did the same thing when I got 2.6.19, and the problem has persisted into 2.6.20.  This thread: http://bbs.archlinux.org/viewtopic.php?id=28566 has the available answers.  I did have the command in my rc.local, but when I reloaded the system it turns out the system boots quicker if I use the option in the very last post.

Re: 30% CPU Usage when plugged in
Another way to solve the problem quickly.
You don't have to recompile the kernel.
You have to add the option " processor.max_cstate=1" to the boot command line.
For example, with grub I have this:

# (0) Arch Linux
title  Arch Linux  [2.6.19-Arch]
root   (hd0,4)
kernel /boot/vmlinuz26 root=/dev/hda5 vga=792 resume=/dev/hda6 processor.max_cstate=1 ro    <===== add here
initrd /boot/kernel26.img

Thanks, processor.max_cstate realy helped smile

Offline

#4 2007-05-15 17:52:38

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

Althouth I've solved my old problems - I've found new ;] I can't get my headphones working!!
When I plug-in my headphones into jack - no sound comes out of the headphones. And there's no bar bor headphones in alsamixer.
At first I thought that it have something to do with my custom kernel. Then I switched to arch default kernel, but no luck.
Then the idea came that I should try to build custom package for alsa-libs and alsa-utils. Again with no luck.
Finaly I tried all the module options (model=asus, position_fix=1). Also with no luck.

Any ideas? Anyone?

Offline

#5 2007-05-15 19:27:26

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: Problem with CPU solved. Sound problem - solved!

What audio card is in the system?

BTW...kernel 2.6.21 fixed the high cpu problem on my notebook, with no work arounds required.

Offline

#6 2007-05-16 07:12:42

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

Sorry, I forgot to mention that my sound card is Intel HDA (using module snd_hda_intel)

Offline

#7 2007-05-16 17:53:30

QuimaxW
Member
From: Waukesha, WI
Registered: 2006-12-03
Posts: 218

Re: Problem with CPU solved. Sound problem - solved!

Offline

#8 2007-05-16 18:40:14

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

Thank's for a link. I added model=3stack to modprobe.conf and now I do have headphones switch.. But it's worthless as still no sound comes out of the headphones...

Offline

#9 2007-05-16 18:44:05

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

Maybe this might help:

#lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
#lsmod
snd_hda_intel         239768  0 
snd_pcm                68484  1 snd_hda_intel
snd_timer              19076  1 snd_pcm
snd                    44388  3 snd_hda_intel,snd_pcm,snd_timer
soundcore               6496  1 snd
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
 #more /etc/modprobe.conf 
#
# /etc/modprobe.conf (for v2.6 kernels)
#
#options snd-hda-intel position_fix=1 model=asus
options snd-hda-intel model=3stack
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.14rc2 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---
# uname -a
Linux psdBox 2.6.21-ARCH #1 SMP PREEMPT Sun May 6 18:33:47 CEST 2007 i686 Intel(R) Pentium(R) M processor 1.73GHz GenuineIntel GNU/Linux
# more /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.14rc3 (Wed Mar 14 07:25:50 
2007 UTC).

Offline

#10 2007-05-27 16:25:13

PsD
Member
Registered: 2005-11-07
Posts: 14

Re: Problem with CPU solved. Sound problem - solved!

Ok, solved this problem myself. I added this line to /etc/modprobe.conf

options snd-hda-intel model=auto

And now sound is working as it should (headphones/speakers). Though it's strange why model=auto works and model=asus - don't hmm

Offline

Board footer

Powered by FluxBB