You are not logged in.

#1 2004-07-06 03:31:07

fideli
Member
From: calgary
Registered: 2004-06-20
Posts: 44

adsl connected but not working

i'm having a weird problem with my adsl connection.  in fact, as with other problems that i've read about during my searching, it was working fine before and it just stopped suddenly, without any changes being made to the pppoe settings.  once it stopped, i searched around for some answers, and after that, the first thing i did was clear the /etc/ppp/options file, but that didn't do anything. 

right now i'm using mepis linux in order to connect, which is on the same machine using the same dsl line.  before, i thought it was a problem with the sympatico connection, because even mepis wasn't working with the adsl.  i've had numerous problems with sympatico in the past so i decided to cancel the service and sign up for cybernet (www.mycybernet.net).  but now, the internet is working in mepis but not in arch.  kinda rash of a decision, but i hope it's for the better.

sorry about the long story, but here are the specifics.  the adsl connects, as described by /var/log/messages:

Jul  5 22:28:01 localhost pppd[1663]: pppd 2.4.2 started by root, uid 0
Jul  5 22:28:01 localhost pppd[1663]: Using interface ppp0
Jul  5 22:28:01 localhost pppd[1663]: Connect: ppp0 <--> /dev/pts/1
Jul  5 22:28:06 localhost pppoe[1664]: PPP session is 5091
Jul  5 22:28:10 localhost pppd[1663]: PAP authentication succeeded
Jul  5 22:28:10 localhost pppd[1663]: local  IP address 67.70.89.153
Jul  5 22:28:10 localhost pppd[1663]: remote IP address 64.230.254.120
Jul  5 22:28:10 localhost pppd[1663]: primary   DNS address 206.47.244.61
Jul  5 22:28:10 localhost pppd[1663]: secondary DNS address 206.47.244.90

but if i go "ping www.google.ca" it just sits there and does nothing until i ctrl-c.  also, kde loads much slower with this faulty internet connection, as well as all other applications.  i haven't given any webpage in firefox or links more than 2 mins or so to load, but i don't think it should take this long so i just quit.  here is my pppoe.conf:

#***********************************************************************
#
# pppoe.conf
#
# Configuration file for rp-pppoe.  Edit as appropriate and install in
# /etc/ppp/pppoe.conf
#
# NOTE: This file is used by the adsl-start, adsl-stop, adsl-connect and
#       adsl-status shell scripts.  It is *not* used in any way by the
#       "pppoe" executable.
#
# Copyright (C) 2000 Roaring Penguin Software Inc.
#
# This file may be distributed under the terms of the GNU General
# Public License.
#
# LIC: GPL
# $Id: pppoe.conf,v 1.10 2002/04/09 17:28:38 dfs Exp $
#***********************************************************************

# When you configure a variable, DO NOT leave spaces around the "=" sign.

# Ethernet card connected to ADSL modem
ETH='eth0'

# ADSL user name.  You may have to supply "@provider.com"  Sympatico
# users in Canada do need to include "@sympatico.ca"
# Sympatico uses PAP authentication.  Make sure /etc/ppp/pap-secrets
# contains the right username/password combination.
# For Magma, use xxyyzz@magma.ca
USER='b1xxxx##@sympatico.ca'

# Bring link up on demand?  Default is to leave link up all the time.
# If you want the link to come up on demand, set DEMAND to a number indicating
# the idle time after which the link is brought down.
DEMAND=no
#DEMAND=300

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SERVER

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS.  Changed to
# PEERDNS for better Red Hat compatibility
PEERDNS=no

DNS1=
DNS2=

# Make the PPPoE connection your default route.  Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

### ONLY TOUCH THE FOLLOWING SETTINGS IF YOU'RE AN EXPERT

# How long adsl-start waits for a new PPP interface to appear before
# concluding something went wrong.  If you use 0, then adsl-start
# exits immediately with a successful status and does not wait for the
# link to come up.  Time is in seconds.
#
# WARNING WARNING WARNING:
#
# If you are using rp-pppoe on a physically-inaccessible host, set
# CONNECT_TIMEOUT to 0.  This makes SURE that the machine keeps trying
# to connect forever after adsl-start is called.  Otherwise, it will
# give out after CONNECT_TIMEOUT seconds and will not attempt to
# connect again, making it impossible to reach.
CONNECT_TIMEOUT=0

# How often in seconds adsl-start polls to check if link is up
CONNECT_POLL=2

# Specific desired AC Name
ACNAME=

# Specific desired service name
SERVICENAME=

# Character to echo at each poll.  Use PING="" if you don't want
# anything echoed
PING="."

# File where the adsl-connect script writes its process-ID.
# Three files are actually used:
#   $PIDFILE       contains PID of adsl-connect script
#   $PIDFILE.pppoe contains PID of pppoe process
#   $PIDFILE.pppd  contains PID of pppd process
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-adsl.pid"

# Do you want to use synchronous PPP?  "yes" or "no".  "yes" is much
# easier on CPU usage, but may not work for you.  It is safer to use
# "no", but you may want to experiment with "yes".  "yes" is generally
# safe on Linux machines with the n_hdlc line discipline; unsafe on others.
SYNCHRONOUS=no

# Do you want to clamp the MSS?  Here's how to decide:
# - If you have only a SINGLE computer connected to the ADSL modem, choose
#   "no".
# - If you have a computer acting as a gateway for a LAN, choose "1412".
#   The setting of 1412 is safe for either setup, but uses slightly more
#   CPU power.
CLAMPMSS=1412
#CLAMPMSS=no

# LCP echo interval and failure count.
LCP_INTERVAL=30
LCP_FAILURE=10

# PPPOE_TIMEOUT should be about 4*LCP_INTERVAL
PPPOE_TIMEOUT=80

# Firewalling: One of NONE, STANDALONE or MASQUERADE
FIREWALL=NONE

# Linux kernel-mode plugin for pppd.  If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so
LINUX_PLUGIN=

# Any extra arguments to pass to pppoe.  Normally, use a blank string
# like this:
PPPOE_EXTRA=""

# Rumour has it that "Citizen's Communications" with a 3Com
# HomeConnect ADSL Modem DualLink requires these extra options:
# PPPOE_EXTRA="-f 3c12:3c13 -S ISP"

# Any extra arguments to pass to pppd.  Normally, use a blank string
# like this:
PPPD_EXTRA=""


########## DON'T CHANGE BELOW UNLESS YOU KNOW WHAT YOU ARE DOING
# If you wish to COMPLETELY overrride the pppd invocation:
# Example:
# OVERRIDE_PPPD_COMMAND="pppd call dsl"

# If you want adsl-connect to exit when connection drops:
# RETRY_ON_FAILURE=no

and some relevant parts of my rc.conf:

#
# Module to load at boot-up (in this order)
#   (prefix a module with a ! to disable it)
#
MODULES=(sis900 soundcore uhci-hcd ehci-hcd evdev)

#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   (prefix an interface in INTERFACES with a ! to disable it)
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(eth0 lo)

...

# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(syslogd klogd hotplug iptables network adsl portmap fam crond cups kdm)

i've also tried it with eth0="".

if you'll allow me a reboot to get the output of my ifconfig, i'll post it soon.  this definitely seems to be an issue with my arch setup, as it's currently working fine in mepis (which doesn't seem to use rp-pppoe by they way).  i'm looking for a general solution that will also work on my new cybernet connection, which will also use pppoe.  if anyone can help this issue, thanks in advance


- fideli /-

Offline

#2 2004-07-06 04:08:18

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: adsl connected but not working

here is my rc.conf:

lo="lo 127.0.0.1"
eth0="eth0 192.168.0.1 netmask 255.255.255.0 broadcast 192.168.0.255"
DAEMONS=(!pcmcia network crond xinetd adsl firewall)

make sure you have your name servers in you /etc/resolv.conf like so:

nameserver 123.456.789.101


AKA uknowme

I am not your friend

Offline

#3 2004-07-06 05:47:37

dpb
Member
From: Cyperspace?
Registered: 2004-04-11
Posts: 231

Re: adsl connected but not working

sarah31 wrote:

make sure you have your name servers in you /etc/resolv.conf like so:

nameserver 123.456.789.101

I want a nameserver like that too!! tongue
You only can have nunbers from 0 to 255 though.  wink

Offline

#4 2004-07-06 05:52:39

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: adsl connected but not working

dpb wrote:
sarah31 wrote:

make sure you have your name servers in you /etc/resolv.conf like so:

nameserver 123.456.789.101

I want a nameserver like that too!! tongue
You only can have nunbers from 0 to 255 though.  wink


it is an example of course i am not going to post my real nameserver. quit picking at straws.


AKA uknowme

I am not your friend

Offline

#5 2004-07-06 10:43:16

fideli
Member
From: calgary
Registered: 2004-06-20
Posts: 44

Re: adsl connected but not working

sarah31 wrote:

here is my rc.conf:

lo="lo 127.0.0.1"
eth0="eth0 192.168.0.1 netmask 255.255.255.0 broadcast 192.168.0.255"
DAEMONS=(!pcmcia network crond xinetd adsl firewall)

make sure you have your name servers in you /etc/resolv.conf like so:

nameserver 123.456.789.101

should i really be assigning eth0 an ip address?  my nameservers are correct because they're the same ones that i use in mepis.  apart from the eth0 line, my rc.conf is no different than yours.


- fideli /-

Offline

#6 2004-07-06 15:34:48

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: adsl connected but not working

i have to give my card an address because i use it as a gateway for my other connections.


AKA uknowme

I am not your friend

Offline

#7 2004-07-08 02:59:40

fideli
Member
From: calgary
Registered: 2004-06-20
Posts: 44

Re: adsl connected but not working

hehe, ok, don't kill me.

the connection was fine, i just had a faulty rule in my iptables script...


- fideli /-

Offline

#8 2004-07-08 05:08:29

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: adsl connected but not working

i would have to be not lazy to have to kill you.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB