You are not logged in.

#26 2008-02-28 14:25:23

struq
Member
From: Guangzhou
Registered: 2007-12-29
Posts: 16

Re: Compiz Shadows Question

Well, i upgrade to the new driver 169.12.
Everything works perfectly

Offline

#27 2008-02-28 17:39:40

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: Compiz Shadows Question

I've still got 169.09-1, but when the next one is released I'll try to remember and report back.


Matt

"It is very difficult to educate the educated."

Offline

#28 2008-03-10 04:01:28

wickedlester
Member
From: Texas, USA
Registered: 2004-07-22
Posts: 140

Re: Compiz Shadows Question

On Ubuntu Hardy Heron and Archlinux, I have been having this problem. I have installed the nvidia 169.12 drivers from source on Ubuntu and have the shadows back to normal. I think it has something to do with libwfb but I am not positive. I have noticed that this problem occurs with Nvidia GeForce 8 series cards mostly.

Offline

#29 2008-03-10 04:52:57

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: Compiz Shadows Question

Still no shadows here with 169.12 from repo. I'm using a 8800GT card.

Offline

#30 2008-03-10 17:55:09

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: Compiz Shadows Question

Yup, 8600 GT in Laptop -- no shadows.  I have 168.12 as well.


Matt

"It is very difficult to educate the educated."

Offline

#31 2008-03-19 14:12:43

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: Compiz Shadows Question

OK, did another update of one of the Compiz packages two nights ago.  Shadows for windows works now on my 8600 nVidia card!  Yay!!


Matt

"It is very difficult to educate the educated."

Offline

#32 2008-03-19 20:47:04

Martyr
Member
From: Out there
Registered: 2006-10-04
Posts: 103
Website

Re: Compiz Shadows Question

All is well again in Compiz/Nvidia land. ;-)

Offline

#33 2008-04-07 22:32:50

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

Is this a bug after all, or just some misconfiguration? I just installed Arch this afternoon, and everything is working fine except Compiz (where I don't have many things installed though). I'm getting a pink (sometimes close to white) glow instead of the shadow, and sometimes there's nothing at all.

BTW, "metacity theme window opacity shade", which produces a transitional opacity effect for window decorations, does not work. If I turn the option on in gconf editor, window decorations would become screwed up and invisible.

I'm using a nvidia 8400 with "pacman -S nvidia" (that's the official driver, right?)

Compiz runs flawlessly (although slowly) on my Ubuntu installation. Otherwise I'm perfectly in love with Arch smile

Offline

#34 2008-04-07 22:47:41

koch
Member
From: Germany
Registered: 2008-01-26
Posts: 369

Re: Compiz Shadows Question

it is no misconfiguration. read the topic here and the linked bug reports.

Offline

#35 2008-04-07 23:12:29

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

Well, maybe I phrased it in an inaccurate way, but in this thread there are people who have got rid of the problem for no particular reason. My Arch is up to date with core, extra and community enabled. Do I also have to enable unstable?

Offline

#36 2008-04-08 17:14:13

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

I've got the shadow to work.

The short story:

The culprit seems to be the nvidia-utils package. Remove it and install the nvidia official 'run' packages instead (as you can no longer use the nvidia package in the repo). Version 169.12 works fine for my 8400 card.

The long one:

Incidentally I reinstalled my Ubuntu today, on which the compiz shadows had always looked nice. On completion I opted for the restricted nvidia (provided by Ubuntu?) instead of the manual installation I used to rely on.

The 2 methods are apparently different, as after a kernel update I could still get into the GUI with compiz running, while previously I had to reinstall the video driver after each kernel update.

And what I got with the restricted nvidia drivers from Ubuntu? The lovely PINK shadows!

So I removed the driver, and did a manual installation of the official nvidia one--and the nice dark shadow again big_smile

I realized that I installed the nvidia driver from the Arch extra repo, and that could be the problem. However, removing that driver did not do the trick. I searched in the installed packages and found nvidia-utils remaining, but I couldn't remove it without breaking xorg. So I reinstalled libgl, which nvidia-utils had previously replaced.

And then I manually reinstalled the nvidia official driver, and amazingly it does not seem to conflict with libgl. And after that, shadows look like shadows again cool

The conclusion:

It seems that the pink shadows have nothing to do with nvidia drivers from the official site, and have everything to do with the drivers shipped in the repo. Why are these 2 kinds of drivers different? And does Arch share code with Ubuntu? Why does the same problem occur to both distros?

Please try and see if you can reproduce my experience.

edit: seems Ubuntu people knew this long ago, but they have not reached a consensus. And this news has not traveled far, has it? tongue

Last edited by allbluedream (2008-04-08 17:30:20)

Offline

#37 2008-05-17 16:28:38

JaQoB
Member
Registered: 2007-04-04
Posts: 60

Re: Compiz Shadows Question

Anything new on this problem? Its kind of irritating tongue

Offline

#38 2008-05-18 18:37:43

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: Compiz Shadows Question

Mine was fixed with an update to compiz on 3/18 or 3/19 (see post above).  I now have shadows with my nVidia 8600 GT in Compiz.


Matt

"It is very difficult to educate the educated."

Offline

#39 2008-05-25 11:15:34

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

mrunion, what version of compiz are you using now? The version of my compiz-core is 0.7.4-1, and I am still experiencing the pink halo even with the nvidia-beta driver from AUR. I still have to use the official nvidia driver AND libgl (I don't know why it doesn't conflict with the official nvidia, but with the one in the repo...)

Offline

#40 2008-05-25 15:15:56

timhart
Member
From: Fukuoka, Japan
Registered: 2008-05-25
Posts: 3

Re: Compiz Shadows Question

The compiz shadow problem (which seems to affect mostly Geforce8 series?) is probably caused by a bug in the arch linux package.

Check out the following discussion:
http://www.nvnews.net/vbulletin/showthread.php?t=112098

(The above discussion is not directly about compiz shadows, but is related. Check out the last 2 messages that discuss the archlinux situation)

According to AaronP, an nvidia employee, the bug is probably caused by a bug in the Archlinux package that makes the libwfb.so symlink point to a nvidia version (libnvidia-wfb.so). This is only needed with older xorg versions, and newer versions should point to the one supplied by xorg. I fixed the shadow problem by removing the libwfb.so symlink and created a new one that pointed to libwfb.so.1.4 instead.

(The same bug was also present in the Ubuntu package, and they fixed it similarly)

Last edited by timhart (2008-05-25 15:30:37)

Offline

#41 2008-05-25 15:50:58

pestilence
Member
From: Athens
Registered: 2008-03-16
Posts: 53
Website

Re: Compiz Shadows Question

I got a new laptop with a Nvidia 9500M GS card on it, unfortunately I had major problems with compiz...animations are slow  ( -minimize, maximize effects- I tryed the different hacks proposed around forums for the nvidia owners) shadows where not working, and I experience glitches on the window borders...So i moved on and I uninstalled compiz... sad

Offline

#42 2008-05-25 17:27:29

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

Thanks, timhart, your solution works!

----------
Edit: I spoke too early. Editing the symlink leads to poor 2D performance, especially noticeable when using yaourt or pacman-color--scrolling through the results is painful, and Xorg cpu usage soars. This is exactly the behavior I get with the run package (173.08) from Nvidia website, which does not appear with nvidia-beta from AUR without touching the symlink.

Last edited by allbluedream (2008-05-25 17:35:29)

Offline

#43 2008-05-25 17:39:16

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: Compiz Shadows Question

This works here too. I must say that my compiz-fusion seems more responsive as well. Perhaps this is simply placebo affect, but the animations of the Expo plugin seem smoother. They were choppy yesterday.

Offline

#44 2008-05-25 19:00:46

timhart
Member
From: Fukuoka, Japan
Registered: 2008-05-25
Posts: 3

Re: Compiz Shadows Question

allbluedream, sorry to hear your 2D performance dropped.  It is something that I don't really notice on my system, but I've heard *a lot* of complaints by others about nvidia's 2D performace as well, so you are certainly not alone. After you changed the symlink, you will get the same 2D performance that a manual driver install (by running nvidia's .run package) will give you. It is a proper install, but 2D can get very slow. It is a known problem and even nvidia acknowledged it as you can read here:

http://www.nvnews.net/vbulletin/showpos … stcount=42

I haven't tried it myself, but you could try to run the beta driver (173.08), which has support for a glyph cache on the GeForce 8 and 9 series that may improve anti-aliased font rendering performance. Enable with nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1. Like I said, I never tried it, but it may help you.

So I'm afraid we'll have to wait... hmm

Offline

#45 2008-05-25 20:40:50

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: Compiz Shadows Question

I don't notice any slowdown on my system. Perhaps it's the use of sub-pixel fonts or another configuration that I'm not currently using. I'm running with nvidia 169.12-2 from the repos.

Give me a test procedure to try with my system and I'll see if any slowdown occurs.

Offline

#46 2008-05-25 22:45:27

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,938
Website

Re: Compiz Shadows Question

allbluedream wrote:

mrunion, what version of compiz are you using now? The version of my compiz-core is 0.7.4-1, and I am still experiencing the pink halo even with the nvidia-beta driver from AUR. I still have to use the official nvidia driver AND libgl (I don't know why it doesn't conflict with the official nvidia, but with the one in the repo...)

I am running:

compiz-core 0.7.4-1
nvidia 169.12-2

I have not messed with any symlinks concerning libgl.so.  What I HAVE done is add the following to /etc/modprobe.conf to speed up performance:

# options to make nVidia card run at max perf/power when connected to AC
# Use "...=0x2222" for max power all the time
# Use "...=0x3322" for max power when on AC but not batteries
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x3322"

This comes at the expense of battery life.  Anyway, this stuff speeds up the switching of tabs in Firefox and other "compiz" stuff.  It has something to do with the card not switching into a higher speed fast enough or something like that.

Last edited by mrunion (2008-05-25 22:45:49)


Matt

"It is very difficult to educate the educated."

Offline

#47 2008-05-25 23:52:02

allbluedream
Member
Registered: 2008-04-06
Posts: 155

Re: Compiz Shadows Question

Actually the 16x series drivers are fine, the problem is with the beta driver. If it's not for the recent kernel update I wouldn't really bother to try the beta, but since someone suggests that the beta works well with kernel 2.6.25, I was tempted to give it another go. Like timhart has suggested, there are certain tweaks--I have tried them but they lead to other problems... Thanks for the tip all the same smile

Offline

Board footer

Powered by FluxBB