You are not logged in.

#1 2004-08-08 00:33:31

Dagreat1
Member
Registered: 2004-07-27
Posts: 16

sshd error.

I believe I updated openssl and with that came 'libcrypto.so.0.9.7' As the locate shows:

 [root@b0x4 lib]# locate libcrypto
/usr/lib/libcrypto.a
/usr/lib/libcrypto.so.0
/usr/lib/libcrypto.so.0.9.7
/usr/lib/libcrypto.so
[root@b0x4 lib]# 

After a restart, sshd failed to start. So I tried starting it or running ssh and I was greeted with,

[root@b0x4 lib]# ssh
ssh: error while loading shared libraries: libcrypto.so.0.9.6: cannot open shared object file: No such file or directory
[root@b0x4 lib]# 

I believe sshd is looking for that library, which it cant find. So I tried to create a link to 0.9.6,

[root@b0x4 lib]# ln -s libssl.so.0.9.7 libssl.so.0.9.6
[root@b0x4 lib]# ln -s libcrypto.so.0.9.7 libcrypto.so.0.9.6

But still the same libcrypto error.
This is the gazzilionth lubrary error I am getting with almost all applications. Xchat, Xchm, sshd, previously, xmms, you name it. And I use pacman to download/install packages.
Thank you.


We dont waste words, we paint pictures.

Offline

#2 2004-08-08 00:42:51

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: sshd error.

It sounds like you aren't running pacman -Syu to update your system before installing new programs.  If you don't keep the system up to date you're begging for trouble. If you're on dialup, it's a pain, but not as bad as you would guess.

Dusty

Offline

#3 2004-08-08 02:36:59

neotuli
Lazy Developer
From: San Francisco, CA
Registered: 2004-07-06
Posts: 1,201
Website

Re: sshd error.

Errr...if I remember correctly... I had to force the first update with pacman...so pacman -Syuf , to get libcrypto working right, and of course, as Dusty said, always bring your system up to date before installing anything new.


The suggestion box only accepts patches.

Offline

#4 2004-08-08 09:12:39

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: sshd error.

openssh is not up to date.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#5 2004-08-09 07:32:59

Dagreat1
Member
Registered: 2004-07-27
Posts: 16

Re: sshd error.

Dusty, did that. For two days pacman downloaded the packages(With getting dc and resuming ofcourse) and at the end updated everything. Rebooted and startx wont work. Apparently I am getting the same intelAPG GART errors I did before.
I tried, like previously I had,

modprobe intel-agp

to load the module but I get,

FATAL: Could not load /lib/modules/2.6.3/modules.dep: No such file or directory

What has happened? Has the updated reseted all my settings? Would I have to configure my system from scratch?
Thank you for any help.


We dont waste words, we paint pictures.

Offline

#6 2004-08-12 02:24:00

Dagreat1
Member
Registered: 2004-07-27
Posts: 16

Re: sshd error.

Mon Aug 09

It's been 3 days and my system is down. Still no reply. Google has no idea about that error.
Do I need to re-install Arch? Install another distro and wait for Arch 0.7? I really need the system up and running.
Any help?


We dont waste words, we paint pictures.

Offline

#7 2004-08-12 06:37:10

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: sshd error.

sounds like you did not edit your lilo or some config file. Depending how behind your system was there have been some rather big changes in some package functioning. Have you gone through the Arch news on the homepage  to see if any of the announcements apply to you?

Have you done a forum search i have heard of this error before and it ususally relates to not upgrading lilo or grub or something along those lines.


AKA uknowme

I am not your friend

Offline

#8 2004-08-12 15:08:45

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: sshd error.

Now you have a new kernel version (assuming that you've rebooted since then), but your system is booting into the old one.  I would guess, as sarah did, that you didn't run lilo after upgrading, like the package told you to.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

Board footer

Powered by FluxBB