You are not logged in.

#1 2004-08-13 20:41:54

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

spamd error

Is it just me that's getting this error after upgrading spamassassin?:

dusty:~ $ /etc/rc.d/spamd start
:: Starting spamd                                                                                                                                               [BUSY] Can't locate URI.pm in @INC (@INC contains: ../lib /usr/lib/perl5/site_perl/current/i686-linux-thread-multi /usr/lib/perl5/site_perl/current /usr/lib/perl5/5.8.5/i686-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin/SpamCopURI.pm line 4.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin/SpamCopURI.pm line 4.
Compilation failed in require at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin/PerMsgStatus.pm line 41.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin/PerMsgStatus.pm line 41.
Compilation failed in require at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin.pm line 62.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/current/Mail/SpamAssassin.pm line 62.
Compilation failed in require at /usr/bin/spamd line 33.
BEGIN failed--compilation aborted at /usr/bin/spamd line 33.
                                                                                                                                                                [FAIL] 
dusty:~ $ 

I just ran pacman -Syu so everything should be up to date... Why the error?

Dusty

Offline

#2 2004-08-13 20:58:18

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: spamd error

[root@Asteraceae /]# /etc/rc.d/spamd restart
:: Stopping spamd                                                        [DONE] 
:: Starting spamd                                                        [DONE] 
[root@Asteraceae /]# locate URI.pm
/usr/lib/perl5/site_perl/current/URI.pm
/root/.cpan/build/URI-1.24/blib/lib/URI.pm
/root/.cpan/build/URI-1.24/URI.pm
[root@Asteraceae /]# pacman -Qo /usr/lib/perl5/site_perl/current/URI.pm
/usr/lib/perl5/site_perl/current/URI.pm is owned by perl-uri 1.30-1
[root@Asteraceae /]# 

do you have perl-uri installed?


The impossible missions are the only ones which succeed.

Offline

#3 2004-08-13 21:07:11

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: spamd error

pacman -S perl-uri fixed it. spamassassin doesn't depend on it, apparently it should now.  I'll submit a bug report.

Dusty

Offline

#4 2004-08-14 17:47:26

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: spamd error

Dusty wrote:

pacman -S perl-uri fixed it. spamassassin doesn't depend on it, apparently it should now.  I'll submit a bug report.

Dusty

smart archlinux user!


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB