You are not logged in.

#1 2002-08-13 09:18:14

tohdol
Member
From: South Korea
Registered: 2002-08-13
Posts: 6

bftpd

i can't figure out bftpd
please help me out   yikes

[root@pacman rc.d]# bftpd start
421-Could not open /var/run/bftpd/bftpdutmp
421 Server disabled for security reasons.
-- it seems to be easy for me tongue
[root@pacman rc.d]# ls -l /var/run
total 28
drwxr-xr-x    2 root     root         4096 Aug 13 17:22 daemons
-rw-r--r--    1 root     root            4 Aug 13 14:53 inetd.pid
-rw-r--r--    1 root     root            3 Aug 13  2002 klogd.pid
-rw-r--r--    1 root     root          512 Aug 13 14:48 random-seed
-rw-r--r--    1 root     root            4 Aug 13 14:53 sshd.pid
-rw-r--r--    1 root     root            3 Aug 13  2002 syslogd.pid
-rw-r--r--    1 root     root         3840 Aug 13 14:53 utmp
[root@pacman rc.d]# mkdir /var/run/bftpd
[root@pacman rc.d]# touch /var/run/bftpd/bftpdutmp
[root@pacman rc.d]# pwd       
/etc/rc.d
[root@pacman rc.d]# bftpd start
421-Could not get peer IP address.
421 Socket operation on non-socket.
-- i'm not able to run bftpd  :?
[root@pacman rc.d]# proftpd start
[root@pacman rc.d]#

Offline

#2 2002-08-13 09:36:45

ody
Member
From: Manchester, UK
Registered: 2002-08-12
Posts: 212
Website

Re: bftpd

have you got networking setup? try ifconfig to check

Offline

#3 2002-08-13 10:03:39

Guest
Guest

Re: bftpd

i set up network already. it works properly
now i logged in this bbs with mozilla on AL
proftpd runs well
does your bftpd  work without problem ?

ody wrote:

have you got networking setup? try ifconfig to check

#4 2002-08-13 10:04:50

ody
Member
From: Manchester, UK
Registered: 2002-08-12
Posts: 212
Website

Re: bftpd

I use vsftpd myself..

Offline

#5 2002-08-13 11:21:44

Guest
Guest

Re: bftpd

ok, i switched to vsftpd
but bftpd problem would be fixed later for Arch's honor big_smile

ody wrote:

I use vsftpd myself..

#6 2002-08-13 16:59:13

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: bftpd

It's just missing a directory, that's all.  Just make it and try logging in again.

[root@earth root]# /etc/rc.d/bftpd start
[ Starting bftpd Server                                                   DONE ]
[root@earth root]# ftp localhost
Connected to localhost.localdomain.
421-Could not open /var/run/bftpd/bftpdutmp
421 Server disabled for security reasons.
ftp> quit
[root@earth root]# mkdir /var/run/bftpd && touch /var/run/bftpd/bftpdutmp
[root@earth root]# ftp localhost
Connected to localhost.localdomain.
220 bftpd 1.0.22 at 127.0.0.1 ready.
Name (localhost:judd): anonymous
230 User logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> quit
221 See you later...
[root@earth root]#

Offline

Board footer

Powered by FluxBB