You are not logged in.

#1 2008-09-30 04:58:32

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

cannot find required binary 'mkfs.msdos'

Hey there!

I'm new to Arch Linux.  How can I install mkfs.msdos?

In general, how can I find the answer to a problem like this?  Is there some way to ask pacman which package contains mkfs.msdos?

Many thanks if you can help,

-Dave

Offline

#2 2008-09-30 05:09:28

AD28
Member
Registered: 2008-09-16
Posts: 161

Re: cannot find required binary 'mkfs.msdos'

dosfstools probably has it. There might be a better way of doing it, but I just tried pacman -Ss on some keywords until I ran across dosfstools from pacman -Ss dos.

Offline

#3 2008-09-30 06:12:40

fukawi2
Ex-Administratorino
From: .vic.au
Registered: 2007-09-28
Posts: 6,208
Website

Re: cannot find required binary 'mkfs.msdos'

There's a package in AUR called pkginfo (I think that's the one) that allows you to search NON-installed packages to find which package owns a particular file (eg, mkfs.msdos)

Offline

#4 2008-09-30 09:01:28

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: cannot find required binary 'mkfs.msdos'

Hey thanks for the suggestions.  dosfstools did the trick.

I tried pkginfo.  It installed but will not run:

[dave@starbuck ~]$ pkginfo --help
/usr/lib/ruby/site_ruby/1.8/libglade2.rb:11:in `require': no such file to load -- gtk2 (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/libglade2.rb:11
        from /usr/sbin/pkginfo.rb:8:in `require'
        from /usr/sbin/pkginfo.rb:8

Offline

#5 2008-09-30 09:09:49

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,204
Website

Re: cannot find required binary 'mkfs.msdos'

fukawi2 got confused...  This thread is what you are looking for http://bbs.archlinux.org/viewtopic.php?id=50129

Offline

#6 2008-09-30 23:33:57

fukawi2
Ex-Administratorino
From: .vic.au
Registered: 2007-09-28
Posts: 6,208
Website

Re: cannot find required binary 'mkfs.msdos'

Whoops, my bad. thanks Allan smile

Offline

Board footer

Powered by FluxBB