You are not logged in.

#1 2004-09-12 15:52:37

Registered: 2004-09-12
Posts: 110

D-Link DWL-650+ and ndiswrapper

Hello everyone  big_smile 

So after days and days of researching and fiddling around and still no wireless, I figured it's about time I should simply ask and see if I can get it to work.

Let me start with short summary of my dilenma:
The computer I have is a Dell Inspiron 8200 with P4M 2.2Mhz CPU, 756MB RAM, nVidia GeForce4 440 Go with 64MB RAM, 40G HD laptop, dual-booting with WinXP (wireless works on XP, and I need this connection for studies and research. Windows resides on my HD only because of that). I use a D-Link DWL-650+ AirPlus card (yes, not so Linux friendly card, I know sad), works perfectly fine on Windows, and ndiswrapper installs the driver and hardware is detected on Arch. Installation, modprobe have been already done, and iwconfig tells me

lo        no wireless extensions.

sit0      no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:"IHTTIWIFI"
          Mode:Managed  Frequency:2.442GHz  Access Point: 00:80:C8:17:2C:44
          Bit Rate:22Mb/s   Tx-Power:0 dBm   Sensitivity=0/3
          RTS thr:4096 B   Fragment thr:4095 B
          Encryption key:A720-B32C-03   Security mode:open
          Power Management:off
          Link Quality:100/100  Signal level:-65 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

The key, mode and security mode were put in by me, ESSID, AP and others were picked up by the card. So the card is scanning and picks up the signal. iwlist wlan0 scan shows:

[root@Brahms ndiswrapper-0.10]# iwlist wlan0 scan
wlan0     Scan completed :

          Cell 01 - Address: 00:80:C8:17:2C:44
                    Protocol:IEEE 802.11FH
                    Quality:0/100  Signal level:71/154  Noise level:0/154
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Bit Rate:22Mb/s

All is good so far, so I do "ifconfig wlan0 up" and this shows up:

eth0      Link encap:Ethernet  HWaddr 00:08:74:3E:89:54
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::208:74ff:fe3e:8954/64 Scope:Link
          RX packets:4081 errors:0 dropped:0 overruns:1 frame:0
          TX packets:1217 errors:0 dropped:0 overruns:0 carrier:0
          collisions:1 txqueuelen:1000
          RX bytes:1191108 (1.1 Mb)  TX bytes:161197 (157.4 Kb)
          Interrupt:11 Base address:0xec80

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:500 (500.0 b)  TX bytes:500 (500.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:80:C8:18:7A:E0
          inet6 addr: fe80::280:c8ff:fe18:7ae0/64 Scope:Link
          RX packets:2669 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:266188 (259.9 Kb)  TX bytes:378 (378.0 b)
          Interrupt:11 Memory:31010000-31010fff

Looks okay. So I kill the eth0 connection, and try to ping, I get:

[root@Brahms ndiswrapper-0.10]# ping
ping: unknown host

Okay...So I suppose even though the card picks up the signal, it's not connected, right? /etc/rc.d/network start (or restart for that matter) comes up "fail". I am lost at this point. Probably some configuration error somewhere but I don't know much about networking and I've been trying different things, check the web for clue, but so far nothing worked. While trying to connect through wireless, no firewall was used.

If someone could point me to the right direction, I would really appreciate it. Not all things iwconfig and ifconfig make sense to me really. At one point, I got so discouraged, I was contemplating on installing Mandrake again (I'm still a newbie though. I used Mandrake 10 Official for a couple of weeks back in June, and then moved to Arch, getting my hands dirty. It has been a wonderful experience for me so far smile )

Before it gets too long, I would like to thank you in advance  yikes


p.s. What are those TX/RX Packets errors?! yikes I suppose...errors, eh?


#2 2004-09-12 16:12:44

From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 489

Re: D-Link DWL-650+ and ndiswrapper

Those errors occur when the WEP key is wrong, or there is noise causing trouble. Don't the HostAP drivers work with that card? I'd give those a shot first. smile


#3 2004-09-12 16:52:31

Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797

Re: D-Link DWL-650+ and ndiswrapper

Notice how the eth0 section has this line 'inet addr: Bcast: Mask:'?

You never give your wlan0 device an inet address, so it doesn't know how to use it to access your network.  You probably also don't have a default route for it.

I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal


#4 2004-09-14 08:34:23

Registered: 2004-04-21
Posts: 884

Re: D-Link DWL-650+ and ndiswrapper

I use DWL-650 with ndiswrapper. Check your route and your IP settings (as Xentac says).

The trouble is not the WEP key because the card finds the ESSID: "IHTTIWIFI".

The card works perfect for me except for one thing:

The link quality, signal level and noise level don't monitor enything. Link quality is allways 100%, signal level is always -60dBm, Noise Level is allways -256dBm

Is there a way to make this monitors work?


#5 2004-10-01 03:58:02

Registered: 2004-09-12
Posts: 110

Re: D-Link DWL-650+ and ndiswrapper

I'm very sorry for the late reply! First of all, thank you so much for the pointers.

Just today, I finally got it to work. I have been busy and I was actually away from computer for a couple of weeks, finally got around to get some going. I've copied and pasted the default gw, inet addr and so on from my Windows wireless configuration program, and talaan! It worked  big_smile 

Thank you so much.



Board footer

Powered by FluxBB