You are not logged in.

#1 2008-11-21 11:09:18

QeSaRNeRON
Member
Registered: 2008-03-11
Posts: 2

[LUMP] modulo php

ciao.. ho installato apache e php sul mio pc.... pero ho un problema nella conficgurazione... credo che il problema sia in questo segmento...


<IfModule mod_php5.c>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
</IfModule>

se commento queste tre righe mi viene visualizzato il sorgente delle pagine php mentre se le tengo decommentate visualizza solo la pagina bianca...
da cosa potrebbe essere causato?

grazie smile
Alessandro

Offline

#2 2008-11-21 14:08:20

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: [LUMP] modulo php

Open up /etc/httpd/conf/httpd.conf and just before this:

# Various default settings
Include conf/extra/httpd-default.conf

add:

# PHP 5
Include conf/extra/php5_module.conf

Then, around line 119 and below all the other LoadModule directives, add this:

LoadModule php5_module modules/libphp5.so

Restart Apache and enjoy. smile

However, if you've configured PHP as described above and you're still getting a blank page, make sure your script isn't using short tags (<? instead of <?php) as they are disabled in /etc/php/php.ini. Furthermore, you can try enabling error reporting by changing the display_errors directive in /etc/php/php.ini.

PS: Also, have a look at the wiki entry regarding LAMP.

Last edited by foutrelis (2008-11-21 14:19:31)

Offline

#3 2008-11-21 15:26:53

finferflu
Forum Fellow
From: Manchester, UK
Registered: 2007-06-21
Posts: 1,899
Website

Re: [LUMP] modulo php

Sposto nella sezione "Other Languages".

Questo e' un forum internazionale, se cerchi una comunita' italiana, c'e' sempre Archlinux.it wink


Have you Syued today?
Free music for free people! | Earthlings

"Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away." -- A. de Saint-Exupery

Offline

Board footer

Powered by FluxBB