You are not logged in.

#1 2008-11-12 00:41:50

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Intel HDS (ICH9 Family) - Stuttering Audio

I'm at my wits end trying to get this sound card to work. It's the last outstanding problem on my new laptop!

I've spent ages trying to get this going, but I've only gotten part of the way there.

The problem at the moment is, when I try to play a WAVE file as per below, the first (I'm guessing here) 500ms of the file just loop and stutter over and over again.

fukawi2 ~  $ aplay /usr/share/sounds/purple/login.wav 
Playing WAVE '/usr/share/sounds/purple/login.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Stereo
^CAborted by signal Interrupt...
fukawi2 ~  $

It keeps going until I ^C the process.

Same thing if I try to play and MP3 in VLC... VLC says it's playing, but only the first half-a-second stutters over and over again sad

rc.conf:

MODULES=(r8169 !snd-mixer-oss !snd-pcm-oss !snd-hwdep !snd-page-alloc !snd-pcm !snd-timer !snd snd-hda-intel !soundcore)
DAEMONS=(@syslog-ng !network hal dhcdbd networkmanager netfs @crond @sshd @openntpd @alsa @fail2ban)

lspci | grep Audio:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

aplay -l

**** List of PLAYBACK Hardware Devices ******** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L

default:CARD=Intel
    HDA Intel, STAC92xx Analog
    Default Audio Device
front:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    Front speakers
surround40:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
    HDA Intel, STAC92xx Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
null
    Discard all samples (playback) or generate zero samples (capture)

EDIT:
http://www.alsa-project.org/db/?f=5a1ab … 06dc977308

Last edited by fukawi2 (2008-11-12 04:09:09)

Offline

#2 2008-11-12 00:51:50

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

Why do you have all the disabled modules in rc.conf? I am running my ICH7 fine just by letting udev sort it all out.
Could just be the alsa is bugged in whatever kernel your using, you can grab git snapshots from http://git.alsa-project.org/?p=alsa-ker … ;a=summary if you feel like trying out the bleeding edge stuff wink

Offline

#3 2008-11-12 00:59:30

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

shazeal wrote:

Why do you have all the disabled modules in rc.conf?

That's my latest attempt at getting it to work this morning after reading another post on the forum. It make no difference - up until just before I posted, there was nothing disabled in there and it still performed exactly the same sad

Offline

#4 2008-11-12 01:59:08

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

Will be an alsa problem then I would say. You could try a snapshot from the link i put above. There are a load of hda fixes in it. Its just the current vanilla kernel (2.6.28-rc4-git1 last i checked) with all the current alsa patches/fixes applied so any other custom kernel patches should work fine on it.

Nvidia driver is a bit of a hassle with the new kernel though, Ive done all the googling for you earlier today when I built mine wink

For the PKGBUILD you need this (the bit with the comments around it) after the cd $startdir line. Its a total hack so I didn't worry about it being pretty wink
It relies on the src/linux-xxx dir being there, as the alsa kernel is packed into alsa.kernel or something, just rename it to linux-2.6.28.

  cd $startdir/pkg/usr/src/linux-${_kernver}/include && ln -s asm-$KARCH asm    
                                                                                
  ###########                                                                   
  # HACK : NV 177.80                                                            
  cp -R $startdir/src/linux-${_basekernel}/arch/$KARCH/* \
    $startdir/pkg/usr/src/linux-${_kernver}/arch/$KARCH/
  mv asm-$KARCH/asm-offsets.h ../arch/$KARCH/include/asm/
  rm -rf asm-$KARCH
  ln -s ../arch/$KARCH/asm asm-$KARCH
  ###########

Then whack this patch in the nvidia PKGBUILD where it says to put patches.
http://andrew.nelless.net/patches/nvidi … 6_28.patch

Last edited by shazeal (2008-11-12 02:03:59)

Offline

#5 2008-11-12 02:03:08

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

I'm a little lost - I'm not that good with Alsa and Kernel stuff (as you know from my other kernel thread!)

I need to recompile my kernel to include the latest Alsa? That sounds way over my head :S  Maybe I'll just wait for 2.6.28 or something...

I got my Nvidia drivers working again no problem - just recompiled from ABS against my custom kernel.

Offline

#6 2008-11-12 02:21:07

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

Hrmmm how to put it simply lol

The snapshots are the full linux kernel, you just need to unpack it the same way you did with linux-2.6.27.tar.bz2 or whatever it was you downloaded before. Put it in <kernel26 build dir>/src/ and rename the directory to linux-2.6.28, then update your PKGBUILD.

Or in commands the way I do it. (I use a static source dir so I can switch back and fourth without having to change anything in the sources=(...) in the PKGBUILD so you dont have to follow exactly what I do).

cd kernel26/src/
mv linux-2.6.27 l27 #backup old src first.
tar xf ~/downloads/alsa-kernel.git-<really big number here>.tar.gz
mv alsa-kernel.git linux-2.6.28
cd ..
vim PKGBUILD
(also Im guessing you PKGBUILD is pretty standard so might want to back it up before all this)
<insert the stuff I posted above>
  change these.

_basekernel=2.6.28                                                              
pkgver=2.6.28  
source=(# the main kernel config files                                                 
        config config.x86_64                                                    
        # standard config files for mkinitcpio ramdisk                          
        kernel26<!! put whatever name you are using in here !!>.preset)                                                 
md5sums=()

makepkg

That help, or just as scary? lol

Offline

#7 2008-11-12 02:30:26

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

shazeal wrote:

That help, or just as scary? lol

Yes - thanks for trying though.

I'm more concerned about screwing my kernel26-PAE that I've just got working than I am about getting sound working.

I'll give it a try though - see how I go. If I come back cursing and screaming - it's nothing personal big_smile tongue

Will whatever is in this package be included in 2.6.28? I'm going to have to recompile my custom kernel anyway once that's released...

Offline

#8 2008-11-12 02:48:11

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

Best way then would to be to start a new kernel package kernel26alsa and keep your pae one going for now then that way you can stuff up all you like and your main kernel is not affected. Just copy your pae dir and change all the places it says pae to alsa.

And yeah Ill be trolling the boards more than usual since I cant code atm due to taking the skin off my knuckles while doing some house work yesterday if you need someone to yell at lol. Typing one handed is fine.. coding no way tongue

Will whatever is in this package be included in 2.6.28?

It is 2.6.28 just an early RC version with alsa patches that have not been added yet, but yes its pretty close to what 2.6.28 final will be.

Last edited by shazeal (2008-11-12 02:50:17)

Offline

#9 2008-11-12 02:52:57

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

I think I get it...

Take the kernel source, and apply the RC4 'snapshot' against it using patch, THEN compile?

(Are you on IRC?)

Offline

#10 2008-11-12 03:09:21

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

OK, question time, and I haven't even started yet sad

1) Which kernel source do I need to download from kernel.org?  2.6.27 or 2.6.28?
2) Where to I find the alsa-kernel<really big number>.git file to download? All I can find is changelogs and commit information :s

Offline

#11 2008-11-12 03:26:16

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

1) You dont need to, the snapshot contains the kernel pre-patched.
2)   sound: x86 - Make CONFIG_OLPC dependent on CONFIG_MGEODE_LX  master  commit | commitdiff | tree | snapshot <--- click on this link on the page to download a snapshot, the server just packs up everything for you on demand smile

Offline

#12 2008-11-12 11:08:03

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

Ok, well I've done that, but there's no change in what happens sad

I think I'll just wait until 2.6.28 is released. I'll reinstall with 64-bit at the same time so I don't need to use PAE.

Offline

#13 2008-11-12 11:30:35

shazeal
Member
From: New Zealand
Registered: 2007-06-05
Posts: 341

Re: Intel HDS (ICH9 Family) - Stuttering Audio

https://bugs.launchpad.net/ubuntu/+bug/269586

Couple of "fixes" for it in there, but yea otherwise your going to have to wait for the ALSA guys to fix it, seems to be alot of working being done on hda recently so you might be lucky smile

Offline

#14 2008-12-08 06:03:47

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,296
Website

Re: Intel HDS (ICH9 Family) - Stuttering Audio

w00t... FTR:

Adding this line to /etc/modprobe.d/sound seems to have fixed my problems (well, the ones related to the Intel sound card anyway!) big_smile:D:D

fukawi2 ~  $ cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=1

Last edited by fukawi2 (2008-12-08 06:05:54)

Offline

Board footer

Powered by FluxBB