You are not logged in.

#1 2004-11-02 20:30:54

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Old mysql working ok, new install doesn't work

I just brought up a computer on a fresh install of Arch, and am trying to get mysql installed.

There have been more than the usual number of minor annoyances, like having to create a group for mysql and slocate... (why is it asking for pw when I add groups now?!)

But now when I try to install mysql as per the wiki instructions, I get this error:

[root@box2 ~]# mysql_install_db --user=mysql
Installing all prepared tables
Fill help tables
ERROR: 1153  Got a packet bigger than 'max_allowed_packet' bytes
041102 13:31:12 [ERROR] Aborting

041102 13:31:12 [Note] /usr/sbin/mysqld: Shutdown complete

Offline

#2 2004-11-03 00:47:28

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: Old mysql working ok, new install doesn't work

The mysql package adds the user and group the first time you run it...


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#3 2004-11-03 22:26:50

kleptophobiac
Member
From: Sunnyvale, CA
Registered: 2004-04-25
Posts: 481

Re: Old mysql working ok, new install doesn't work

Not successfully for the group, it asks for root pw and then group pw. I must be done manually.

Then I get the error about max allowed packet bytes and it doesn't matter anyway. slocate is screwed up too. In other words, there are a bunch of little issues that have made my current install of arch completely broken. Yes, I tried reinstalling from my local FTP, which I rsync to the main arch server every day.

Offline

#4 2004-11-03 22:46:08

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Old mysql working ok, new install doesn't work

which cd did you install from? the most recent beta has a slocate bug that was discussed on the forum just today. take a look at the install forum.

as for mysql ... i would guess that it my have something to do with the issues that slocate has.  i would suggest bringing this issue up on the bug tracker. i don't think the mysql maintainer frequents the boards.

in fact any of these annoyances you speak of should be brought up in the bug tracker  or to the maintainers of whatever package. if you just live with them or work around them they will persist.

anyway just my few cents. i hope the slocate post in the other forum helps you out.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB