You are not logged in.

#1 2009-04-23 09:16:29

mrbug
Member
Registered: 2007-07-17
Posts: 221

[NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

I have created packages (regular and nightly releases) in the AUR for a new program called Arista.

http://programmer-art.org/projects/arista-transcoder

An easy to use multimedia transcoder for the GNOME Desktop. Arista focuses on being easy to use by making the complex task of encoding for various devices simple. Pick your input, pick your target device, choose a file to save to and go.

Arista has been in development since early 2008 as a side project and was just recently polished to make it release-worthy. The 0.8 release is the first public release and includes a to-do of items that will be completed for the 1.0 final release.
Features

    * Presets for iPod, computer, DVD player, PSP, and more
    * Live preview to see encoded quality
    * Automatically discover available DVD drives and media
    * Rip straight from DVD media easily (requires libdvdcss)
    * Simple terminal client for scripting

Requirements

Arista is written in Python and requires the bindings for GTK+ 2.16 or newer, GStreamer, GConf, GObject, Cairo, and DBus. If you are an Ubuntu user this means you need to be using at least Ubuntu 9.04 (Jaunty). The GStreamer plugins required depend on the presets available, but at this time you should have gst-plugins-good, gst-plugins-bad, gst-plugins-ugly, and gst-ffmpeg. If you are on Ubuntu don't forget to install the multiverse packages.
Development

All development will happen on Launchpad, which provides bug tracking, distributed version control, milestone / roadmap planning and tracking, a forum and translation utilities.

EDIT: I guess I should add AUR links =-)

Regular release: http://aur.archlinux.org/packages.php?ID=25872
Bazaar (nightly) release: http://aur.archlinux.org/packages.php?ID=25876

arista-futurama.png
arista-shiki.png

Last edited by mrbug (2009-04-23 09:20:19)


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#2 2009-04-23 10:43:14

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,393
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

Nice... Binary of the nightly available for x86_64 on my repo for the lazy ones  smile tongue

[fukawi]
http://repo.falconn.nl/x86_64

I also replaced the "python-gconf" dependency with "gnome-python" as python-gconf conflicts with gnome-python which is required by several other packages I have installed.

Offline

#3 2009-04-23 11:21:31

Allan
Supreme Leader
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,588
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

Looks good.  I think I will give this a spin (ogmrip just does not cut it...)

Offline

#4 2009-04-23 22:50:33

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,393
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

Binary of the nightly available for i686 now too:

[fukawi]
http://repo.falconn.nl/i686

Offline

#5 2009-04-23 23:21:37

mrbug
Member
Registered: 2007-07-17
Posts: 221

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

I replaced the gnome-python dependency in both PKGBUILDS. I wasn't sure which one I'd need, but it looks like I originally picked the wrong one!

Is libdvdcss a required or optional dependency?


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#6 2009-04-24 00:14:25

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,393
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

mrbug wrote:

Is libdvdcss a required or optional dependency?

I'd say yes, since it is optional (only if you want to transcode from DVD) smile

Offline

#7 2009-04-24 07:24:06

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,870
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

fukawi2 wrote:
mrbug wrote:

Is libdvdcss a required or optional dependency?

I'd say yes, since it is optional (only if you want to transcode from DVD) smile

"Yes" is a strange answer to an "Or" question tongue


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#8 2009-04-24 09:14:01

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,393
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

Rasi wrote:

"Yes" is a strange answer to an "Or" question tongue

Whoops, I mis-read....

I'd say an optional dependancy since some users won't have a DVD drive hence won't be able to rip from DVD.

Offline

#9 2009-04-25 03:26:40

mrbug
Member
Registered: 2007-07-17
Posts: 221

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

I've updated the PKGBUILDs to reflect the optional dependencies...


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#10 2009-04-25 03:56:36

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

looks promising, lets see if it delivers wink

Offline

#11 2009-04-26 16:29:50

mrbug
Member
Registered: 2007-07-17
Posts: 221

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

eldragon wrote:

looks promising, lets see if it delivers wink

Hey, feel free to submit bugs/fixes and the audio/video settings for various devices! Dan could also use some testers for target devices -- I believe that he's currently looking for someone who can test the Playstation 3 output.


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#12 2009-04-27 14:09:21

mrbug
Member
Registered: 2007-07-17
Posts: 221

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

I have updated the bazaar package at http://aur.archlinux.org/packages.php?ID=25876

New features include:

V4L input support (allows for direct camera-to-file encoding)
Internationalization support through gettext
Preset tweaks
Automatic updating of presets to the latest versions in a repository (user-configurable)


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#13 2009-04-27 20:13:14

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

awesome! i'm going to install this and give it a try when i get home from work.

Offline

#14 2009-04-28 20:17:47

mrbug
Member
Registered: 2007-07-17
Posts: 221

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

Updated to version 0.9! Check the aur page for details.


dvdtube - download all uploads from a YouTube user and then optionally create a DVD.
(Regular version AUR link / SVN version AUR link)

Offline

#15 2015-09-13 12:52:24

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

I tried arista before 2 months in arch linux and now with manjaro and doesn't convert anything. The program starts fine, let you choose the file for conversion, preset etc, but when push "Create" it just do nothing.
I get the following output  when running from terminal:

arista-gtk
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib/python2.7/site-packages/arista/discoverer.py:245: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  if not self.set_state(gst.STATE_PLAYING):
/usr/lib/python2.7/site-packages/arista/discoverer.py:245: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  if not self.set_state(gst.STATE_PLAYING):

(arista-gtk:1634): GStreamer-CRITICAL **: gst_tag_register_static: assertion 'type != 0 && type != GST_TYPE_LIST' failed

(arista-gtk:1634): GStreamer-CRITICAL **: gst_tag_register_static: assertion 'type != 0 && type != GST_TYPE_LIST' failed
sys:1: Warning: specified class size for type 'GstFaad' is smaller than the parent type's 'GstAudioDecoder' class size
sys:1: Warning: g_once_init_leave: assertion 'result != 0' failed

(arista-gtk:1634): GStreamer-CRITICAL **: gst_element_register: assertion 'g_type_is_a (type, GST_TYPE_ELEMENT)' failed
/usr/lib/python2.7/site-packages/arista/transcoder.py:542: Warning: specified class size for type 'GstLameMP3Enc' is smaller than the parent type's 'GstAudioEncoder' class size
  "aencoder")
/usr/lib/python2.7/site-packages/arista/transcoder.py:542: Warning: g_once_init_leave: assertion 'result != 0' failed
  "aencoder")

(arista-gtk:1634): GStreamer-CRITICAL **: gst_element_register: assertion 'g_type_is_a (type, GST_TYPE_ELEMENT)' failed
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/arista/transcoder.py", line 228, in _got_info
    self._setup_pass()
  File "/usr/lib/python2.7/site-packages/arista/transcoder.py", line 542, in _setup_pass
    "aencoder")
gst.ElementNotFoundError: lame

Seems that doesn't find lame, but all dependencies are installed and the

gst-inspect-0.10 | egrep "lame|xvid"

gives the following:

lame:  lamemp3enc: L.A.M.E. mp3 encoder
lame:  lame: L.A.M.E. mp3 encoder
xvid:  xvidenc: XviD video encoder
xvid:  xviddec: XviD video decoder

Has anyone else using arista? Do you have this problem?

Offline

#16 2015-09-14 23:12:05

fukawi2
Forum Moderator
From: .vic.au
Registered: 2007-09-28
Posts: 5,393
Website

Re: [NEW RELEASE] Arista - Easy to use transcoder for the GNOME Desktop

dancer69 wrote:

I tried arista before 2 months in arch linux and now with manjaro and doesn't convert anything.

First, Manjaro is not Arch, please ask on the Majaro forums. Second, please leave the dead to rest in peace.

Closing.

Offline

Board footer

Powered by FluxBB