You are not logged in.

#1 2008-08-11 08:44:16

Aprz
Member
From: Newark
Registered: 2008-05-28
Posts: 277

Slow Internet

I recently upgraded from dial-up to Speakeasy DSL and I am having issues with the speed on this computer. On my Mac, it runs very smoothly and fast, but on here, it is very slow. Two things I am having trouble with at the moment, it doesn't connect on boot and when I do connect then it is slow.

To connect, I type in:

[andrew@Aprz ~]$ su root
Password:
[root@Aprz andrew]ifconfig eth0 69.17.55.5 netmask 255.255.255.0 up
[root@Aprz andrew]route add default gw 69.17.55.1

I like to connect to things through my terminal, not by default, but I also want to be able to say that I can connect by default and actually have done it so that's why I am bringing this up, however, this post is really more about my Internet being slow (with Static IP) which probably has to do with this.

I thought it would've connected on boot with these configuration to rc.conf, resolv.conf, and hosts:

rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Canada/Pacific"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(8139too ndiswrapper)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="Aprz"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
eth0="eth0 69.17.55.5 netmask 255.255.255.0"
INTERFACES=(lo eth0 wlan0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 69.17.55.1"
ROUTES=(gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(@dbus @alsa)

...and I just noticed I left wlan0 in there, hehe. I'll remove that. I can connect to wireless locations just fine by the way.

resolv.conf

# Generated by dhcpcd for interface eth0
nameserver 192.168.1.1
nameserver 64.81.79.2
nameserver 216.231.41.2

hosts

#
# /etc/hosts: static lookup table for host names
#

#<ip-address>    <hostname.domain.org>    <hostname>
127.0.0.1    localhost.localdomain    localhost Aprz
69.17.55.5    Aprz.domain.org        Aprz
# End of file

I am sure that within these three files it also explains why my Internet speed is so slow. To show you how slow it is using DSL, I'll copy and paste my ping output:

PING www.l.google.com (74.125.19.99) 56(84) bytes of data.
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=1 ttl=249 time=13.1 ms
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=2 ttl=249 time=13.1 ms
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=3 ttl=249 time=13.9 ms
--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 10078ms
rtt min/avg/max/mdev = 13.128/13.406/13.928/0.392 ms

Which is very slow.

For all the configurations I did to these three files, I refered to the Beginners Guide. When I first bumped into this problem, I thought it might have been /etc/hosts because the guide made it very clear that making a mistake in /etc/hosts could make my Internet very slow.

At the moment, I have no problems with Internet connections that I can use DHCP on.

Oh, I almost forgot to provide you with the information Speakeasy sent me with my DSL modem:

IP Address: 69.17.55.5
Subnet Mask: 255.255.255.0
Gateway: 69.17.55.1
Primary DNS: 64.81.79.2
Secondary DNS: 216.231.41.2
Configuration Required: Yes
UID: go2asapnow

I don't think the last two lines of that is necessary to know, but I provided it anyways.

I have one more issue, but I don't want to focus on that yet. I'll mention it here anyhow though. I am having trouble setting up my wireless network with Speakeasy. I went out and bought a wireless router, Linksys WRT54Gl, and it came with a CD and all the parts for the router. Now, I plugged up the router all right and I see the Internet light on for it which is good. I can connect to it which is awesome. However, I have no Internet connection. I can't connect by plug with it either. I am assuming this is because it needs to be configured to work with my DSL modem which I figured this is what the CD is for (other than setting up a password also). I didn't use the CD first, haha, even though it said I needed to use it first because the CD doesn't work on my Mac or Linux (it contains only *.exe files and *.dll with some directories that contains other files like READ ME.txt (I can provide a list of what the CD exactly containts if needed be). I removed my Windows for Linux, haha so using it on a Windows computer is out of the question! So anyhow, I tried to get the CD to work using wine, but after going though multiple processes, in the end, the CD tries to look for the router and it can't find it. So I am wondering how the hell can I set this up, of course, assuming that I have wired it in all correctly (I could take a picture if needed be to provide proof that I plugged it up right). I've actually called both Speaskeasy and Cicso on this, but you know how those Tech Support guys always are. Well, at least my experience, if it is not Windows then they are clueless and the building is on fire. My wireless network works fine (I can connect at other places like at my friends house).

[root@Aprz andrew]ifconfig wlan0 up
[root@Aprz andrew]# iwconfig wlan0 essid "linksys"
[root@Aprz andrew]# dhcpcd wlan0

Last edited by Aprz (2008-08-11 09:13:13)

Offline

#2 2008-08-14 13:49:33

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,212
Website

Re: Slow Internet

Try without the second (uncommented) line in your hosts-file, because I don't think you need it: it is redundant and might cause your problems.

You also might want to switch to netcfg. It requires some changes in your rc.conf and in setting up a profile, but it is the recommended way to (automatically or manually) connect to a network. Check out the wiki for 'net-profiles'.

Zl.

Last edited by zenlord (2008-08-14 13:52:29)

Offline

#3 2008-08-14 14:53:02

SiC
Member
From: Liverpool, England
Registered: 2008-01-10
Posts: 429

Re: Slow Internet

Looking at your ping, I am struggling to find out what part of your access is slow.  Can you do a ping from the Mac and see what results you get there and post them back here.

Offline

#4 2008-08-14 15:53:57

xvalentinex
Member
Registered: 2008-05-31
Posts: 22

Re: Slow Internet

It's hard to know your exact network setup, but I'm guessing it has to do with your nameservers in resolv.conf.  Specifically the first one.
nameserver 192.168.1.1

That's a Private IP Address, and I notice you are using a Public IP Address.  This would explain why you think your pings are slow, because as you copy pasted them, they look very quick.  Each ping will try a reverse DNS lookup, and if you have an unresponsive DNS server, it would feel really slow in real time.

Try using this for your resolv.conf.
nameserver 4.2.2.2
nameserver 4.2.2.4

If that speeds things up, test your test your DNS servers and see which is the faulty one and remove it.
dig @192.168.1.1 www.google.com
dig @64.81.79.2 www.google.com
dig @216.231.41.2 www.google.com

Offline

#5 2008-08-16 04:46:16

Aprz
Member
From: Newark
Registered: 2008-05-28
Posts: 277

Re: Slow Internet

Zenlord, I commented and it didn't make a difference, which is weird, I thought I had to add that in because of what it said in the Beginner Guide, but it didn't make a difference either way.

Xvalentinex, you were correct. It was the first DNS that was bad. I think I kept it because it came as an example when I installed Archlinux. It wasn't until now that I have really needed to setup static IP, but honestly need to find a way to make this dynamic so I can hook up my Linksys. Anyhow, Xvalentine, you were right. Thank you very much, the Internet is a million times faster. Well, not a million, but I notice a significant increase in speed.

As for my original ping:

PING www.l.google.com (74.125.19.99) 56(84) bytes of data.
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=1 ttl=249 time=13.1 ms
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=2 ttl=249 time=13.1 ms
64 bytes from cf-in-f99.google.com (74.125.19.99): icmp_seq=3 ttl=249 time=13.9 ms
--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 10078ms
rtt min/avg/max/mdev = 13.128/13.406/13.928/0.392 ms

and now:

PING www.l.google.com (74.125.19.147) 56(84) bytes of data.
64 bytes from cf-in-f147.google.com (74.125.19.147): icmp_seq=1 ttl=250 time=12.4 ms
64 bytes from cf-in-f147.google.com (74.125.19.147): icmp_seq=2 ttl=250 time=14.4 ms
64 bytes from cf-in-f147.google.com (74.125.19.147): icmp_seq=3 ttl=250 time=13.4 ms

--- www.l.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2006ms
rtt min/avg/max/mdev = 12.436/13.469/14.498/0.847 ms

Which if I am right about that being total ping time (by the way, the Mac doesn't have that), then the numbers say I am going 5x faster, right? It feels a lot faster, honestly. Thank you all very much. smile

The slowness wasn't just on ping, but actual web browsing. The ping I used it as evidence because saying "My Internet is slow" may not be enough for you guys. You know, provide what I can. big_smile

Oh, sorry for the long time away too. I thought people didn't care (it was up for a few days) and then I got lazy at looking at it and I just dealed with the slow Internet.

Last edited by Aprz (2008-08-16 09:39:39)

Offline

#6 2009-05-03 19:18:34

shagrath
Member
Registered: 2008-12-23
Posts: 15

Re: Slow Internet

I had almost the same problem.
the internet was slow and I had the following /etc/resolv.conf

nameserver 217.77.53.237
nameserver 217.77.52.252
search sampo.ru

then I commented the first nameserver and now everything is fine (don't now why) smile
thank you wink

Last edited by shagrath (2009-05-03 19:18:56)


ArchLinux x86-64 KDE 4.3 Beta

Offline

Board footer

Powered by FluxBB