You are not logged in.

#1 2003-08-14 12:16:06

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Help: can't ssh in as root!

Hello All,

I have had arch up and running for a while  and everything is working great.  My only problem is that I can't login to my arch box as root.  I have been login is as a regular user and used "su -".

I have tried to read as much as I can before posting and it seems that the only thing that I need to do is to set "PermitRootLogin yes", which I have done.  I stil can't ssh in as root:

kellwood@delos kellwood $ ssh -l root deadface
root@deadface's password:
Permission denied, please try again.

Is there something else that I am supposed to set somewhere?  Below I have included my sshd_config file.

Thanks
Kevin

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 3600
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 120
PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile    .ssh/authorized_keys

# rhosts authentication should not be used
#RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

#AFSTokenPassing no

# Kerberos TGT Passing only works with the AFS kaserver
#KerberosTgtPassing no

# Set this to 'yes' to enable PAM keyboard-interactive authentication 
# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
#PAMAuthenticationViaKbdInt no

#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes

#MaxStartups 10
# no default banner path
#Banner /some/path
#VerifyReverseMapping no

# override default of no subsystems
Subsystem    sftp    /usr/lib/ssh/sftp-server

Offline

#2 2003-08-14 12:28:52

Gyroplast
Member
From: Germany
Registered: 2002-09-03
Posts: 166
Website

Re: Help: can't ssh in as root!


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert

Offline

#3 2003-08-14 14:04:05

Guest
Guest

Re: Help: can't ssh in as root!

Thanks for the reply.  I am at work now and I will check to make sure but I am virtually certain that I removed all of the contents of /etc/hosts.deny  -- that machine is behind a firewall.  I am pretty sure that  hosts.deny is not the issue because I can ssh to that machine as a normal user.

Thanks
Kevin

#4 2003-08-14 15:23:25

Gyroplast
Member
From: Germany
Registered: 2002-09-03
Posts: 166
Website

Re: Help: can't ssh in as root!

Yah, duh. Mea culpa, didn't parse your original post correctly.

However, there's this nifty little thing called "debug mode" which spills pages of useful information to your screen. Try that out. The parameter is -v, as in "ssh -v root@deadface"

See if that output helps you any, if not post the important part (where it fails) and a little "glue" to make sense of it.

Good luck,
  Dennis


"That's the problem with good advice. Nobody wants to hear it."
-- Dogbert

Offline

#5 2003-08-14 19:46:02

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Help: can't ssh in as root!

I will go home and give the debug mode a try.  I will post the outcome. 

Thanks again for all your help,
Kev

Offline

#6 2003-08-14 20:36:41

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: Help: can't ssh in as root!

If you really want to login as root, you'll want to edit the PAM stack for sshd:

[judd@earth judd]$ cat /etc/pam.d/sshd 
#%PAM-1.0
auth            required        pam_securetty.so        #Disable remote root
auth            required        pam_unix.so
auth            required        pam_nologin.so
auth            required        pam_env.so
account         required        pam_unix.so
account         required        pam_time.so
password        required        pam_unix.so
session         required        pam_unix_session.so
session         required        pam_limits.so

Comment out the pam_securetty.so line and it should let you in.

Offline

#7 2003-08-15 21:05:00

iKevin
Member
From: Ann Arbor, MI
Registered: 2003-07-20
Posts: 130

Re: Help: can't ssh in as root!

Hi There,

I just had a chance to try out the "pam" stuff and it worked.   I guess I should read about pam so that I can understand what I did.

All the best and thanks
Kevin

I survived the blackout of 2003.

Offline

Board footer

Powered by FluxBB