You are not logged in.

#1 2004-12-13 15:00:37

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

gst-plugins ld.so errors

I have tried starting today amarok and it froze.
I've started it in a konsole, and saw the output. I concluded that it must be a gstreamer problem. I've remembered that many plugins appeared in separate packages... (RSS notifications)...

I've looked for a group "pacman -Sg" and there was it "gstreamer-plugins".
I ended up doing a "pacman -Sy gstreamer-plugins", yes.. and waited. After all the packages were downloaded, the installing process started.

This is the last output I got:

installing gst-plugins-sidplay... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-sndfile... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-speex... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-theora... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-vorbis... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-xvid... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

I passed over it and assumed maybe something would work.
Did a "gst-register" but it suddenly stopped after registering a buch of plugins with

Added plugin ffmpegcolorspace with 1 feature.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

Anyone else encountered this?

I have a P4 Prescott @ 3GHz. It seems like a compilation issue.
I don't know exactly what happens in the install process (not that I've looked at it yet).

Hmm... I will file a bug if it turns out that it isn't on my system only.
I'll try a restart now.

Offline

#2 2004-12-13 16:39:41

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gst-plugins ld.so errors

I think gst-plugins needs a recompile because of the new glibc that moved from testing to current last week.

I haven't seen these problems myself, but Blaasvis reported them to me. Do gstreamer programs abort because of it, or is it only a warning?

Hmm, when looking at this one: I don't have gst-ffmpeg, and your error shows up when gst-ffmpeg is loaded. I will do some package upgrades and fixes tonight, I will take gst-ffmpeg with me then.

Edit2: It looks like I can't reproduce this on my laptop.

Offline

#3 2004-12-13 17:31:29

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gst-plugins ld.so errors

Restart & reinstall didn't help.
Starting amarok with the GStreamer output plugin returns an error, saying GStreamer has no registered plugins (and amarok is right, because gst-register halts when it finds the first error)

It seems I get more errors this time on the following install-attempts:

# yes | pacman -Syf gstreamer-plugins
:: Synchronizing package databases...
:: current is up to date
extra                    [################] 100%     175K    14.7K/s  00:00:11
:: group gstreamer-plugins:
    gst-plugins-1394 gst-plugins-a52dec gst-plugins-aalib gst-plugins-arts
    gst-plugins-audiofile gst-plugins-cdaudio gst-plugins-cdparanoia
    gst-plugins-dv gst-plugins-dvd gst-plugins-esd gst-plugins-faac
    gst-plugins-faad gst-plugins-flac gst-plugins-gdkpixbuf
    gst-plugins-gnomevfs gst-plugins-hermes gst-plugins-jack gst-plugins-ladspa
    gst-plugins-lame gst-plugins-mad gst-plugins-mikmod gst-plugins-mng
    gst-plugins-mpeg2dec gst-plugins-mpeg2enc gst-plugins-musepack
    gst-plugins-musicbrainz gst-plugins-ogg gst-plugins-sdl gst-plugins-shout
    gst-plugins-sidplay gst-plugins-sndfile gst-plugins-speex
    gst-plugins-theora gst-plugins-vorbis gst-plugins-xvid
    Install whole content? [Y/n] :: gst-plugins-1394-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-a52dec-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-arts-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-audiofile-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-cdaudio-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-cdparanoia-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-dv-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-dvd-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-esd-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-faac-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-faad-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-flac-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-gdkpixbuf-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-gnomevfs-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-hermes-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-jack-0.8.6-2:is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-ladspa-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-lame-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-mad-0.8.6-2: is up to date.Upgrade anyway? [Y/n] :: gst-plugins-mikmod-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-mng-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-mpeg2dec-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-mpeg2enc-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-musepack-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-musicbrainz-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-ogg-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-sdl-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-shout-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-sidplay-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-sndfile-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-speex-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-theora-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-vorbis-0.8.6-2: is up to date.  Upgrade anyway? [Y/n] :: gst-plugins-xvid-0.8.6-2: is up to date.  Upgrade anyway? [Y/n]
Targets: gst-plugins-1394-0.8.6-2 gst-plugins-a52dec-0.8.6-2
         gst-plugins-aalib-0.8.6-2 gst-plugins-arts-0.8.6-2
         gst-plugins-audiofile-0.8.6-2 gst-plugins-cdaudio-0.8.6-2
         gst-plugins-cdparanoia-0.8.6-2 gst-plugins-dv-0.8.6-2
         gst-plugins-dvd-0.8.6-2 gst-plugins-esd-0.8.6-2
         gst-plugins-faac-0.8.6-2 gst-plugins-faad-0.8.6-2
         gst-plugins-flac-0.8.6-2 gst-plugins-gdkpixbuf-0.8.6-2
         gst-plugins-gnomevfs-0.8.6-2 gst-plugins-hermes-0.8.6-2
         gst-plugins-jack-0.8.6-2 gst-plugins-ladspa-0.8.6-2
         gst-plugins-lame-0.8.6-2 gst-plugins-mad-0.8.6-2
         gst-plugins-mikmod-0.8.6-2 gst-plugins-mng-0.8.6-2
         gst-plugins-mpeg2dec-0.8.6-2 gst-plugins-mpeg2enc-0.8.6-2
         gst-plugins-musepack-0.8.6-2 gst-plugins-musicbrainz-0.8.6-2
         gst-plugins-ogg-0.8.6-2 gst-plugins-sdl-0.8.6-2
         gst-plugins-shout-0.8.6-2 gst-plugins-sidplay-0.8.6-2
         gst-plugins-sndfile-0.8.6-2 gst-plugins-speex-0.8.6-2
         gst-plugins-theora-0.8.6-2 gst-plugins-vorbis-0.8.6-2
         gst-plugins-xvid-0.8.6-2

Total Package Size:   0.8 MB

Proceed with upgrade? [Y/n]
checking package integrity... done.
loading package data... done.
upgrading gst-plugins-1394... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-a52dec... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
installing gst-plugins-aalib... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-arts... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-audiofile... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-cdaudio... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-cdparanoia... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-dv... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-dvd... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-esd... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-faac... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-faad... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-flac... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-gdkpixbuf... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-gnomevfs... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-hermes... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-jack... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-ladspa... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-lame... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-mad... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-mikmod... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-mng... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-mpeg2dec... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-mpeg2enc... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-musepack... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-musicbrainz... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-ogg... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-sdl... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-shout... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-sidplay... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-sndfile... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-speex... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-theora... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-vorbis... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
upgrading gst-plugins-xvid... done.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

Sorry for the long paste.
I really have no idea what to do with it (besides recompiling.. which looks pretty difficult to handle taking into account the big number of plugins - some kind of script would be useful).

Offline

#4 2004-12-13 18:17:44

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: gst-plugins ld.so errors

why not just cd into the abs directory that contasins these plugins and runa makeworld on them if you want to rebuild them. or if that is not possible put them in one directory locally and then cd into that directory and makeworld them.


AKA uknowme

I am not your friend

Offline

#5 2004-12-13 18:18:43

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: gst-plugins ld.so errors

why not just cd into the abs directory that contasins these plugins and runa makeworld on them if you want to rebuild them. or if that is not possible put them in one directory locally and then cd into that directory and makeworld them.


AKA uknowme

I am not your friend

Offline

#6 2004-12-13 19:25:12

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gst-plugins ld.so errors

Could you do a "pacman -Q | grep ^gst" for me and place the list in this topic? I installed all gstreamer plugins now and I still can't reproduce the problem.
The only thing I've seen this with is the gst-plugins-0.8.7-1 releases of the plugins, which got compiled with --enable-plugin --disable-plugin which caused the plugins to be compiled but not linked. This has been resolved in the -2 release which has been in testing for a week before it went to extra.

Another thing is that you could have the gst-plugins-xine plugin in your system. You should remove that one if you have it on your system, since it does nothing but producing segmentation faults.

Offline

#7 2004-12-13 20:14:37

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gst-plugins ld.so errors

@sarah31
I didn't know "makeworld" exists. I like making islands...

@JGC
on ftp://ftp.archlinux.org/extra/os/i686/
Isn't it strange that gstreamer is 0.8.7-2 and all gst-* packages are "0.8.6-?"?
Is this correct? I also can't find gst-plugins-0.8.6-*

Offline

#8 2004-12-13 20:50:48

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gst-plugins ld.so errors

Yes, those versions are right. The gst-plugins-* files are on the FTP, so that shouldn't be a problem. Personally I think it's one of the codecs causing the problem, the problem is only: which one...

Offline

#9 2004-12-13 21:27:04

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gst-plugins ld.so errors

Well.. it was great installing each plugin by hand, in the order given by <pacman -Ss | grep "gst-">
Surprisingly, I found that one of the plugins listed there is not added in the gstreamer-plugins group. I'm talking about "gst-ffmpeg" (0.8.2).

I only found faulty package when installing everything by hand in the order mentioned above. The faulty package is "extra/gst-plugins-sidplay 0.8.6-2". I have removed it after it was installed with errors (ld.so error) and I have continued installing the others. gst-register worked and now amarok works too.

Thanks.

Offline

#10 2004-12-13 22:12:11

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gst-plugins ld.so errors

gst-ffmpeg is not part of gst-plugins, so that one doesn't belong to the gstreamer-plugins group yet (it will on next package upgrade if we don't forget it).

I will try to find out about the sidplay. Probably the sidplay codec and the sidplay plugin need a recompile.

Offline

#11 2005-01-06 13:28:07

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gst-plugins ld.so errors

The error returns:

# pacman -Q | grep ^gst
gst-ffmpeg 0.8.3-1
gst-plugins 0.8.7-1
gst-plugins-1394 0.8.7-1
gst-plugins-a52dec 0.8.7-1
gst-plugins-aalib 0.8.7-1
gst-plugins-arts 0.8.7-1
gst-plugins-audiofile 0.8.7-1
gst-plugins-cdaudio 0.8.7-1
gst-plugins-cdparanoia 0.8.7-1
gst-plugins-dv 0.8.7-1
gst-plugins-dvd 0.8.7-1
gst-plugins-esd 0.8.7-1
gst-plugins-faac 0.8.7-1
gst-plugins-faad 0.8.7-1
gst-plugins-flac 0.8.7-1
gst-plugins-gconf 0.8.7-1
gst-plugins-gdkpixbuf 0.8.7-1
gst-plugins-gnomevfs 0.8.7-1
gst-plugins-hermes 0.8.7-1
gst-plugins-jack 0.8.7-1
gst-plugins-ladspa 0.8.7-1
gst-plugins-lame 0.8.7-1
gst-plugins-mad 0.8.7-1
gst-plugins-mikmod 0.8.7-1
gst-plugins-mng 0.8.7-1
gst-plugins-mpeg2dec 0.8.7-1
gst-plugins-mpeg2enc 0.8.7-1
gst-plugins-musepack 0.8.7-1
gst-plugins-musicbrainz 0.8.7-1
gst-plugins-ogg 0.8.7-1
gst-plugins-sdl 0.8.7-1
gst-plugins-shout 0.8.7-1
gst-plugins-sidplay 0.8.7-1
gst-plugins-sndfile 0.8.7-1
gst-plugins-speex 0.8.7-1
gst-plugins-theora 0.8.7-1
gst-plugins-vorbis 0.8.7-1
gst-plugins-xvid 0.8.7-1
gstreamer 0.8.8-1

This time.. the error is only one, but critical:

# gst-register
Rebuilding global_registry (/var/cache/gstreamer-0.8/registry.xml) ...
Added plugin gstvideo with 0 features.
Added plugin audiorate with 1 feature.
Added plugin colorspace with 1 feature.
Added plugin y4menc with 1 feature.
Added plugin gstresample with 0 features.
Added plugin smpte with 1 feature.
Added plugin alpha with 1 feature.
Added plugin gstindexers with 2 features.
Added plugin mpegaudioparse with 1 feature.
Added plugin gnomevfs with 2 features.
Added plugin gstoptomegascheduler with 1 feature.
Added plugin gstbasicgthreadscheduler with 1 feature.
Added plugin textoverlay with 1 feature.
Added plugin mpegaudio with 1 feature.
Added plugin videocrop with 1 feature.
Added plugin volume with 1 feature.
Added plugin videoscale with 1 feature.
Added plugin playondemand with 1 feature.
Added plugin videorate with 1 feature.
Added plugin cdaudio with 1 feature.
Added plugin mikmod with 1 feature.
Added plugin xvimagesink with 1 feature.
Added plugin multipart with 2 features.
Added plugin alphacolor with 1 feature.
Added plugin videobox with 1 feature.
Added plugin interleave with 2 features.
Added plugin gstdataprotocol with 0 features.
Added plugin video4linux with 4 features.
Added plugin spectrum with 1 feature.
Added plugin gstoptgthreadscheduler with 1 feature.
Added plugin gsttags with 1 feature.
Added plugin ac3parse with 1 feature.
Added plugin volenv with 1 feature.
Added plugin faac with 1 feature.
Added plugin efence with 1 feature.
Added plugin gstaudiofilter with 0 features.
Added plugin switch with 1 feature.
Added plugin level with 1 feature.
Added plugin gstoptscheduler with 1 feature.
Added plugin dvdreadsrc with 1 feature.
Added plugin xvid with 2 features.
Added plugin debug with 5 features.
Added plugin ladspa with 0 features.
Added plugin lame with 1 feature.
Added plugin audioscale with 1 feature.
Added plugin vcdsrc with 1 feature.
Added plugin videotestsrc with 1 feature.
Added plugin gstequalizer with 1 feature.
Added plugin theora with 2 features.
Added plugin typefindfunctions with 53 features.
Added plugin tta with 2 features.
Added plugin trm with 1 feature.
Added plugin monoscope with 1 feature.
Added plugin udp with 2 features.
Added plugin mpeg2sub with 1 feature.
Added plugin vbidec with 1 feature.
Added plugin jpeg with 5 features.
Added plugin tcp with 7 features.
Added plugin gstentryomegascheduler with 1 feature.
Added plugin ximagesink with 1 feature.
Added plugin passthrough with 1 feature.
Added plugin auparse with 1 feature.
Added plugin rtp with 4 features.
Added plugin shout2send with 1 feature.
Added plugin gstfairgthreadscheduler with 1 feature.
Added plugin sdlvideosink with 1 feature.
Added plugin gdkpixbuf with 2 features.
Added plugin gstbasicomegascheduler with 1 feature.
Added plugin chart with 1 feature.
Added plugin mulaw with 2 features.
Added plugin sine with 1 feature.
Added plugin decodebin with 1 feature.
Added plugin dvdnavsrc with 1 feature.
Added plugin gstentrygthreadscheduler with 1 feature.
Added plugin median with 1 feature.
Added plugin aasink with 1 feature.
Added plugin videomixer with 1 feature.
Added plugin smooth with 1 feature.
Added plugin mad with 4 features.
Added plugin wavenc with 1 feature.
Added plugin rtjpeg with 2 features.
Added plugin video4linux2 with 2 features.
Added plugin artsdsink with 1 feature.
Added plugin qcamsrc with 1 feature.
Added plugin gstmultifilesink with 1 feature.
Added plugin playbin with 1 feature.
Added plugin speed with 1 feature.
Added plugin jack with 3 features.
Added plugin mpeg1videoparse with 1 feature.
Added plugin gstelements with 15 features.
Added plugin gstspider with 2 features.
Added plugin deinterlace with 1 feature.
Added plugin overlay with 1 feature.
Added plugin stereo with 1 feature.
Added plugin festival with 1 feature.
Added plugin gst_arts with 1 feature.
Added plugin gstvideofilter with 0 features.
Added plugin gstgetbits with 0 features.
Added plugin hermescolorspace with 1 feature.
Added plugin gstidct with 0 features.
Added plugin effectv with 8 features.
Added plugin gstaudio with 0 features.
Added plugin cdparanoia with 1 feature.
Added plugin gstbytestream with 0 features.
Added plugin alsa with 3 features.
Added plugin silence with 1 feature.
Added plugin filter with 3 features.
Added plugin alaw with 2 features.
Added plugin dvdec with 1 feature.
Added plugin ffmpegcolorspace with 1 feature.
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

No matter how many times I'd run it, it always stops there.
Removing gst-plugins-sidplay as I did last time doesn't help.

# locate ffmpegcolorspace
/usr/lib/gstreamer-0.8/libgstffmpegcolorspace.la
/usr/lib/gstreamer-0.8/libgstffmpegcolorspace.so

# pacman -Qo /usr/lib/gstreamer-0.8/libgstffmpegcolorspace.la
/usr/lib/gstreamer-0.8/libgstffmpegcolorspace.la is owned by gst-plugins 0.8.7-1

# pacman -R gst-plugins-sdl gst-plugins
removing gst-plugins-sdl... done.
removing gst-plugins... done.

After removing gst-plugins and dependencies, it registers ok the features, but the list seems pretty small.

Rebuilding user_registry (/root/.gstreamer-0.8/registry.xml) ...
Loaded 41 plugins with 256 features.

How many plugins/features does your list have?

Last time it might have not hurt very much because it was only one plugin, but this time I think gst-plugins is not that insignificat.

Offline

#12 2005-01-06 13:41:06

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: gst-plugins ld.so errors

This is a bug in glibc NPTL and gets triggered by libs that use TLS (Thread local storage) and load a lib via dlopen() calls that fail with unresolved symbols or library dependencies.

The nvidia TLS lib is such a lib that can trigger this bug. All people having problems with gst-plugins and this dl-tls.c warning/crash thing have a nvidia card with the nvidia drivers.

http://bugs.archlinux.org/index.php?do=details&id=1974

Offline

#13 2005-01-06 15:24:09

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: gst-plugins ld.so errors

Thank you for this information.

Offline

Board footer

Powered by FluxBB