You are not logged in.

#1 2004-12-17 03:55:31

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Xdefaults and man page fonts

So I seem to have done something to mess up my bold terminal fonts... in man pages and dir listings they're all blocky under xterm... I've tried fixed and 6x10 settings...

I *think*, but am not sure, that this happens under wmi and not fluxbox...
For now I'll stick with aterm, but I'd still like to know what is doing this and I have a feeling it's an .Xdefaults setting, but aterm/xterm are identical....

blegh!

Offline

#2 2004-12-17 19:47:10

Win
Member
Registered: 2004-03-04
Posts: 155

Re: Xdefaults and man page fonts

Hi phrakture.

Could you have modified the CONSOLEFONT variable in /etc/rc.conf (which sets the default console font)?

Regards,

Win

Offline

#3 2004-12-17 21:33:50

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Xdefaults and man page fonts

No, I did not.  It's not the font in the actual ttys, but in pseudo terminals... and only in xterm.

I checked and it DOES do this in fluxbox, so it's not a setting being fudged by the WM.
It's only the "bold" font attribute that is effected... it really looks like a totally different font... and this only happens in xterm, not in aterm

Offline

#4 2004-12-18 13:21:11

oscar
Member
From: Linköping, Sweden
Registered: 2004-08-13
Posts: 457

Re: Xdefaults and man page fonts

Since I'm a great fan of TTF and XFT, I use Bitstream Vera Sans Mono in every terminal I can find (ie, xterm and rxvt-unicode).
This is how I fixed my fonts:

XTerm*faceName: Bitstream Vera Sans Mono:size=11
XTerm*boldFont: Bitstream Vera Sans Mono:style=Bold:size=11

(I can put my .Xdefaults somewhere, if you want to see more)


To err is human... to really foul up requires the root password.

Offline

Board footer

Powered by FluxBB