You are not logged in.

#1 2004-12-24 04:46:52

ruwach
Member
Registered: 2004-06-14
Posts: 143

help me with eth1 and dhcp !

Hey there, i think i am close on this one. i have searched from pillar to post on forums everywhere. so here goes..

i connect to the internet via cablemodem to eth0
i want to serve out dhcp to another computer via eth1
(yep, using crossover cable)
it worked with assigning a static ip but i cant get it to do dhcp.
firestarter fails when i try to set it up like that.
i have dnsmasq and all the stuff i think i need.
anyone have some advice ?

Offline

#2 2004-12-24 04:55:33

ruwach
Member
Registered: 2004-06-14
Posts: 143

Re: help me with eth1 and dhcp !

maybe this will help
from rc.conf
# Networking
#
HOSTNAME="Arch"

#
# Module to load at boot-up (in this order)
#   (prefix a module with a ! to disable it)
#
MODULES=(!usbserial !ide-scsi 8139too natsemi sis lp parport_pc sd-mod ohci-hcd snd-pcm-oss snd-ens1371 )

#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   (prefix an interface in INTERFACES with a ! to disable it)
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
eth1="eth1 192.168.1.1 netmask 255.255.255.0 broadcast 192.168.1.255"

INTERFACES=(lo eth0 eth1)

#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   (prefix a route in ROUTES with a ! to disable it)
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

#
# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(syslogd klogd !pcmcia iptables network netfs alsamixer crond hotplug httpd dnsmasq cups gdm)

# End of file


From Iptables.rules

# Generated by iptables-save v1.2.11 on Tue Dec 14 15:03:28 2004
*nat
:PREROUTING ACCEPT [163:9508]
:POSTROUTING ACCEPT [12:628]
:OUTPUT ACCEPT [0:0]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Tue Dec 14 15:03:28 2004
# Generated by iptables-save v1.2.11 on Tue Dec 14 15:03:28 2004
*filter
:INPUT ACCEPT [1455:1486827]
:FORWARD ACCEPT [6279:4965423]
:OUTPUT ACCEPT [1318:140982]
COMMIT
# Completed on Tue Dec 14 15:03:28 2004


from /etc/dhcp.conf

# DHCP configuration generated by Firestarter
ddns-update-style interim;
ignore client-updates;

subnet 192.168.1.0 netmask 255.255.255.0 {
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;
option domain-name-servers 24.116.0.157;
option ip-forwarding on;
range dynamic-bootp 192.168.1.2 192.168.1.100;
default-lease-time 21600;
max-lease-time 43200;
}
bogus-priv
dhcp-range=192.168.0.50,192.168.0.150,12h
cache-size=150
log-queries

ok, lemme know where i may be screwed up here.
thanks

Offline

#3 2004-12-24 10:13:17

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: help me with eth1 and dhcp !

looks like you are not starting the dhcpd deamon. Is that on purpose?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#4 2004-12-24 10:21:23

Notze
Member
From: Germany
Registered: 2004-12-22
Posts: 46

Re: help me with eth1 and dhcp !

ruwach wrote:

MODULES=(!usbserial !ide-scsi 8139too natsemi sis lp parport_pc sd-mod ohci-hcd snd-pcm-oss snd-ens1371 )

I think /etc/modprobe.conf is a better place to put your ethernet driver modules into.
like this:
alias eth0 natsemi
or something like this.
I think it is more standard to do it in this way.

Notze

Offline

#5 2004-12-24 16:55:01

ruwach
Member
Registered: 2004-06-14
Posts: 143

Re: help me with eth1 and dhcp !

i put the  dhcpd deamon in rc.conf and it worked ! THanks so much. you guys dont know how long i have wrestled with this one.
thanks a lot.
merry Christmas !

Offline

#6 2004-12-24 20:25:33

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: help me with eth1 and dhcp !

8)
Ho ho ho!


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

Board footer

Powered by FluxBB