You are not logged in.

#1 2004-12-30 09:06:56

giddygiddyBA
Member
From: Montreal
Registered: 2004-12-30
Posts: 66

libXfixes.so.3 trouble using xorg 6.7.0-1

after a recent update, i find that alot of my favorite apps are buggered.

when trying to start gnuttella, bluefish, gaim, rox, streamtuner etc... i get this error message (this example is with bluefish)

bluefish: error while loading shared libraries: libXfixes.so.3: cannot open shared object file: No such file or directory

im using gcc 3.4.3, xorg 6.7.0-1  (i need this to use ati-radeon drivers), and the 6.8.1 kernel. 

all apps were workin before the update

happy, happy new years!

MOD: subject edited to suit problem - dp

Offline

#2 2004-12-30 10:13:32

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

Maybe this helps:

[11:10:06] root@ferro:/ $ ldconfig

I don't know what it exactly does, but it's got something to do with re-initializing the dynamic links. Since you did some upgrades, it might help.


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#3 2004-12-30 11:20:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

FUBAR wrote:

Maybe this helps:

[11:10:06] root@ferro:/ $ ldconfig

I don't know what it exactly does, but it's got something to do with re-initializing the dynamic links. Since you did some upgrades, it might help.

http://wiki.linuxquestions.org/wiki.pht … s#ldconfig

ldconfig should be run by pacman for packages, that need ldconfig updating shared lib. links ... and additionally, ldconfig is run at boottime per default

try this:

[damir@Asteraceae /]$ locate libXfixes
/usr/X11R6/lib/libXfixes.so.3
/usr/X11R6/lib/libXfixes.so
/usr/X11R6/lib/libXfixes.so.3.0
[damir@Asteraceae /]$ pacman -Qo /usr/X11R6/lib/libXfixes.so.3
/usr/X11R6/lib/libXfixes.so.3 is owned by xorg 11R6.8.1-1
[damir@Asteraceae /]$ 

you get different things?
i guess, it has to do with gtk2-update (all apps in your list are gtk2 apps) ... maybe gtk2 must have a depends=(xorg>=6.8.1) ...


The impossible missions are the only ones which succeed.

Offline

#4 2004-12-30 12:28:46

giddygiddyBA
Member
From: Montreal
Registered: 2004-12-30
Posts: 66

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

locate does not come up with anything.

is "libXfixes" something unique to  xorg>6.7.0 ?

i tried reinstalling my xorg package as well, still no luck

Offline

#5 2004-12-30 12:46:25

tranquility
Member
From: Portugal
Registered: 2004-08-06
Posts: 136

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

I've had this problem too. Here is the bug report: http://bugs.archlinux.org/index.php?do=details&id=1924

Offline

#6 2004-12-30 13:18:07

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

giddygiddyBA wrote:

locate does not come up with anything.

is "libXfixes" something unique to  xorg>6.7.0 ?

from this bug report, i see, that YES, it is something unique to xorg>=6.8.0


The impossible missions are the only ones which succeed.

Offline

#7 2004-12-30 13:32:54

giddygiddyBA
Member
From: Montreal
Registered: 2004-12-30
Posts: 66

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

hmmmm, im not really sure what to do then

i just installed the lastest ati-drivers-3.14.6 and gave xorg-6.8.1 a try but it crashed...

i dont really want to install two xservers like in teh bug fix

stupid ati card, stupid snow.... #mumble mumble mumble#...

Offline

#8 2005-01-02 03:18:01

iBertus
Member
From: Greenville, NC
Registered: 2004-11-04
Posts: 2,228

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

I read on here somewhere that the Xfree86 4.4 patches work to patch xorg 6.7 to have those libs included. Search the forum and see if you can find that thread and compile xorg yourself to fix the problem.

Offline

#9 2005-01-18 20:11:37

starthis
Member
Registered: 2004-12-25
Posts: 45

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

As I'm also using an ATI card, I ran into the same problems after updating.
I tried the oldest trick in the book, and it works fine so far...

I updated xorg to 6.8, saved all libXfixes* files to another dir, upgraded xorg to 6.7, and put the copied files back. Restart X and all GTK apps work again.

So far I encountered only one problem since, archlinux forum crashes firefox...
really weird, no such behaviour on any other site I tried so far. This is the error I get :

run-mozilla.sh: line 159: 4121 Segmentation fault "$prog ${1+$@"}

Offline

#10 2005-01-19 03:27:55

qwerty
Member
Registered: 2004-12-17
Posts: 183

Re: libXfixes.so.3 trouble using xorg 6.7.0-1

ATI drivers 8.8.25 have been released just yesterday, i've made them work with archlinux and now i'm able to use xorg 6.8.0, you can find PKBGUILDs here:

http://bbs.archlinux.org/viewtopic.php?t=9264


c ya

Offline

Board footer

Powered by FluxBB