You are not logged in.

#1 2005-01-21 12:54:51

Benedict_White
Member
From: Sussex, UK
Registered: 2004-05-27
Posts: 326
Website

how do I make sure the kernel is not upgraded with pacman -S

how do I make sure the kernel is not upgraded with pacman -S

Only I have a few custom kernels and need to manually makepkg and install, I don't want pacman to upgrade it, though I do need to upgrade.


Kind regards

Benedict White

Offline

#2 2005-01-21 12:57:55

Insight_45
Member
Registered: 2004-12-13
Posts: 40

Re: how do I make sure the kernel is not upgraded with pacman -S

In the [options] section of /etc/pacman.conf file, add a line like
IgnorePkg   = kernel26


Maybe wait until someone can confirm. Or try it with backup procedures

Offline

#3 2005-01-21 13:04:17

Benedict_White
Member
From: Sussex, UK
Registered: 2004-05-27
Posts: 326
Website

Re: how do I make sure the kernel is not upgraded with pacman -S

Many thanks for that.

Next question, I have postfix and pacman installed, and do not want to overwrite anything in those directories.

Can I add a line:

NoUpgrade   = etc/postfix/*
NoUpgrade   = etc/mail/spamassassin/*

or do I need to list each file?


Kind regards

Benedict White

Offline

#4 2005-01-21 13:21:11

Insight_45
Member
Registered: 2004-12-13
Posts: 40

Re: how do I make sure the kernel is not upgraded with pacman -S

I would say each file but you can put more than 1 file per line with a space like:
NoUpgrade   = etc/lilo.conf boot/grub/menu.lst

It is an excerpt from my file


But I am not sure about the .../*  I have no idea

Offline

#5 2005-01-21 16:07:51

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how do I make sure the kernel is not upgraded with pacman -S

my guess is that /* would not work and you would have to list the specific files. Besides there likely are files in there that will need to be upgraded when  a new package is available. You can list more than one file per line though.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB