You are not logged in.

#1 2005-01-22 21:50:16

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

pacman questions

Yes, I'm a newbie  :oops:

1. I see that there are some newly added xfce packages on the front page of Arch (e.g. Terminal).  But when I do a "pacman -Syu" followed by "pacman -S Terminal", it says it can't find it.

2. I'm trying to get the package "pyxdg" from punkrockguy318's tur repository. I added it to the pacman.conf file, did "pacman -Syu" and then did a "pacman -S pyxdg" - again, it says it can't find it.

Here is my pacman.conf:

[options]
LogFile     = /var/log/pacman.log
NoUpgrade   = etc/passwd etc/group etc/shadow etc/sudoers
NoUpgrade   = etc/fstab etc/raidtab etc/ld.so.conf
NoUpgrade   = etc/rc.conf etc/rc.local
NoUpgrade   = etc/modprobe.conf etc/modules.conf
NoUpgrade   = etc/lilo.conf boot/grub/menu.lst
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

#[testing]
#Server = ftp://ftp.archlinux.org/testing/os/i686

[current]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/current

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/extra

[punkrockguy318]
Server = ftp://ftp.archlinux.org/tur/punkrockguy318

What am I doing wrong??


I am a gated community.

Offline

#2 2005-01-22 22:22:47

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: pacman questions

looks fine to me. Don't know what the issue is. Might be a problem with his repo.db file not being updated.
You could always download the package yourself, and 'pacman -A packagefile'


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-01-23 01:10:13

stonecrest
Member
From: Boulder
Registered: 2005-01-22
Posts: 1,190

Re: pacman questions

Thanks cactus, that did work for the pyxdg package. However I still can't get the packages listed on the main Archlinux page to work. And if I try to use the same method of downloading the .bz2 file, I get:

# pacman -A Terminal-0.2.2.tar.bz2
loading package data... load_pkg: missing package info file in Terminal-0.2.2.tar.bz2

How could that be?


I am a gated community.

Offline

#4 2005-01-23 01:49:14

contrasutra
Member
From: New Jersey
Registered: 2003-07-26
Posts: 507

Re: pacman questions

That's not a pacman package. It's probably the source. Pacman packages end in ".pkg.tar.gz". (e.g. "terminal-0.2.2-1.pkg.tar.gz")

And all package names have lowercase letters, so it should be "pacman -S terminal". You were using Terminal.

If that still doesn't solve the problem, you're probably using a mirror which hasn't synced with the master server yet (the terminal package is brand new). Wait a day or two.

EDIT:

And pyxdg is in STAGING, not in punkrockguy's TUR. That's your problem: two different repos.


"Contrary to popular belief, penguins are not the salvation of modern technology.  Neither do they throw parties for the urban proletariat."

Offline

#5 2005-01-23 01:56:49

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: pacman questions

You sometimes have to wait a little for the newest packages to appear in the mirror you use. This is especially true for the latest additions.

Check which mirror you use and you can change it if you like or just wait a few hours and try again. Mirror lists for all main arch repos are in /etc/pacman.d/. The first one from the top is used.

The newest version of pyxdg is in staging repo. You should enable it or downlad it from there. http://xentac.net/~tur/repos.php
Maybe it's now gone from punckrockguy or is not present in the db file. You can check what pacman can see in /var/lib/pacman/_repo_name (after you do pacman -Syu). I would use the version from staging unless you need older version for some good reason.

You also used a wrong file for Terminal. You downloaded sources instead of the package :-) so it's quite natural pacman doesn't know what to do with it. Don't overuse pacman -A (BTW pacman -U is "better"). To download the package use any ftp program. You will also need other packages too (as dependencies).

Offline

#6 2005-01-23 02:03:59

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: pacman questions

contrasutra wrote:

And pyxdg is in STAGING, not in punkrockguy's TUR. That's your problem: two different repos.

It's not in the repo db but it's present on the ftp and http://xentac.net/~tur/repos.php
It also needs a little time to synchronize.

Offline

Board footer

Powered by FluxBB