You are not logged in.

#1 2003-09-02 20:46:45

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

error: the following file conflicts were found:

[root@Asteraceae damir]# uuuu
:: Synchronizing package databases...
 current.db.tar.gz        [####################################] 100% |     32K
 unofficial.db.tar.gz     [####################################] 100% |     61K
 unstable.db.tar.gz       [####################################] 100% |      2K
:: ed2k-gtk-gui-0.6.0-1: local version is newer
:: hotplug-2003_08_05-1: local version is newer
:: Above packages will be skipped.  To manually upgrade use 'pacman -S <pkg>'

Targets: pygtk-2.0.0-1 gnome-python-2.0.0-1 gtkhtml-3.0.8-1 libgpg-error-0.3-1
         libgcrypt-1.1.42-1

Proceed with upgrade? [Y/n]
loading package data... done.
checking for file conflicts...
error: the following file conflicts were found:
  usr: exists in "pygtk" (target) and "gnome-python" (target)
  usr/lib: exists in "pygtk" (target) and "gnome-python" (target)
  usr/lib/pkgconfig: exists in "pygtk" (target) and "gnome-python" (target)
  usr/lib/python2.3: exists in "pygtk" (target) and "gnome-python" (target)
  usr/lib/python2.3/site-packages: exists in "pygtk" (target) and "gnome-python" (target)
  usr/lib/python2.3/site-packages/gtk-2.0: exists in "pygtk" (target) and "gnome-python" (target)
  usr/share: exists in "pygtk" (target) and "gnome-python" (target)
  usr/share/pygtk: exists in "pygtk" (target) and "gnome-python" (target)
  usr/share/pygtk/2.0: exists in "pygtk" (target) and "gnome-python" (target)
  usr/share/pygtk/2.0/defs: exists in "pygtk" (target) and "gnome-python" (target)
  usr: exists in "pygtk" (target) and "libgpg-error" (target)
  usr/bin: exists in "pygtk" (target) and "libgpg-error" (target)
  usr/include: exists in "pygtk" (target) and "libgpg-error" (target)
  usr/lib: exists in "pygtk" (target) and "libgpg-error" (target)
  usr/share: exists in "pygtk" (target) and "libgpg-error" (target)
  usr: exists in "pygtk" (target) and "libgcrypt" (target)
  usr/bin: exists in "pygtk" (target) and "libgcrypt" (target)
  usr/include: exists in "pygtk" (target) and "libgcrypt" (target)
  usr/lib: exists in "pygtk" (target) and "libgcrypt" (target)
  usr/share: exists in "pygtk" (target) and "libgcrypt" (target)
  usr: exists in "gnome-python" (target) and "libgpg-error" (target)
  usr/lib: exists in "gnome-python" (target) and "libgpg-error" (target)
  usr/share: exists in "gnome-python" (target) and "libgpg-error" (target)
  usr: exists in "gnome-python" (target) and "libgcrypt" (target)
  usr/lib: exists in "gnome-python" (target) and "libgcrypt" (target)
  usr/share: exists in "gnome-python" (target) and "libgcrypt" (target)
  usr: exists in "libgpg-error" (target) and "libgcrypt" (target)
  usr/bin: exists in "libgpg-error" (target) and "libgcrypt" (target)
  usr/include: exists in "libgpg-error" (target) and "libgcrypt" (target)
  usr/lib: exists in "libgpg-error" (target) and "libgcrypt" (target)
  usr/share: exists in "libgpg-error" (target) and "libgcrypt" (target)
  usr/share/aclocal: exists in "libgpg-error" (target) and "libgcrypt" (target)

[root@Asteraceae damir]#

... are these the same files? what package should i first install? it's only me having this conflict? (use pacman2.6)


The impossible missions are the only ones which succeed.

Offline

#2 2003-09-02 21:00:45

kritoke
Member
From: Texas, USA
Registered: 2003-08-01
Posts: 211
Website

Re: error: the following file conflicts were found:

I had a bit fewer conflicts than you, but today there definately were a bunch.  I have nerves of steel, so I just did a pacman -Sfyu.  I hope I didn't totally screw anything up by doing so, I really wonder how these conflicts came about.  I had them before I upgraded to new pacman and afterwards.  So I don't think thats the issue.

Kritoke


http://counter.li.org/ Registered Linux User #318963 kritoke@jabber.org

Offline

#3 2003-09-02 21:03:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: error: the following file conflicts were found:

it's for sure not pacman ... i had to upgrade another machine working on the old pacman, so i wanted to find out if ... but no, the same conflicts came


The impossible missions are the only ones which succeed.

Offline

#4 2003-09-02 21:06:44

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: error: the following file conflicts were found:

why have pygtk and gnome-python the same files compiled with them?

maybe we should remove one copy from one of these packages --- if they are really the same ... so that no conflicts come up

someone who knows more about gnome-python should comment my post, please


The impossible missions are the only ones which succeed.

Offline

#5 2003-09-02 21:15:31

orelien
Forum Fellow
From: France
Registered: 2002-12-05
Posts: 220
Website

Re: error: the following file conflicts were found:

If you look at the messages, you'll see pacman is only(!) complaining about directories, not files.
As a consequence, I don't think packages themselves are the root cause of these messages.
For now, a possible workaround would be to upgrade packages one by one...
We'll have a closer look at it ASAP.

Offline

#6 2003-09-02 21:46:54

Toth
Member
Registered: 2002-12-04
Posts: 82

Re: error: the following file conflicts were found:

Yeah, upgrading one by one worked fine for me. At first I thought it was because I have a custom gnome-python package for use with gdesklets. (Has to be built after installing pyorbit for gdesklets to work).

Offline

#7 2003-09-03 02:23:39

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: error: the following file conflicts were found:

I've found the bug in makepkg.  It's from a recent change that produces the .FILELIST differently.  The new method omits the necessary trailing slash on directory names.

This will be fixed in 2.6-3

Offline

#8 2003-09-03 02:49:29

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: error: the following file conflicts were found:

and all the packages released with the new pacman are being rebuilt


AKA uknowme

I am not your friend

Offline

#9 2003-09-03 06:56:39

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: error: the following file conflicts were found:

ok, the upgrade with the new pacman went smothly (i didnt force the upgrade when the conflicts came up ... just waited, and see: it is solved ... thank you)


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB