You are not logged in.

#1 2005-01-31 03:22:58

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

USB printer periodically loses connection

I have a server running cups that connects via usb to a Brother 1440 Laser printer. It works great, except every so often (in a days time or sometimes even as many as three) cups says it cannot make a connection, and /dev/usb/lp0 disappears. The printer has a sleep mode, which I thought was my issue however, it does actaully wake from its sleep when I print something assuming /dev/usb/lp0 is still present.
I'm using custom kernel 2.6.10 (problem seemed more frequent in 2.6.9). My current temporary fix is unplugging it from the usb port and plugging it back in so it is recognized again.

Any thoughts?


--
JSkier

Offline

#2 2005-02-02 11:37:25

joe
Member
From: Folsom, CA
Registered: 2004-07-27
Posts: 51
Website

Re: USB printer periodically loses connection

Weird.  I have the same printer (using CUPS) and ocassionally print jobs won't go through and I've been solving the problem just by turning the printer off and then back on.  It hasn't happened as often as you mention, however, perhaps once every other month, but I don't print all that often.

I have had a similar issue in winXP as well.

Offline

#3 2005-02-03 01:58:31

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

Re: USB printer periodically loses connection

I have had a similar issue in winXP as well.

I assume you mean sharing it with Windows file sharing?

Good to know someone else is having the same issue. I just switched the server over to udev a few days ago and it's been fine but I'm sure it will go sooner or later as with every other attempt to alter it and hope it just fixes itself.

I also usually print anywhere from 5-20 pages daily, so maybe that is causing it to be more frequent.

If I hear anything more I will post, until then, happy resetting  big_smile


--
JSkier

Offline

#4 2005-02-22 16:32:33

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 356
Website

Re: USB printer periodically loses connection

It seems using the device URI below works better than the one that has the name of the printer in it (how cups set it up). I'm not very fimilar with USBFS or whatever it is but my printer has been fine the past two weeks after I manually set the URI to lp0.

Device URI: usb:/dev/usb/lp0

--
JSkier

Offline

Board footer

Powered by FluxBB