You are not logged in.

#1 2005-01-19 20:03:08

slackhack
Member
Registered: 2004-06-30
Posts: 738

xfce4 mixer question

does anyone know how to change the mixer on the panel to use the master volume instead of master1? (or alternatively, i guess, change applications to be volume controlled by master1 instead of master? tongue)

before the latest upgrade i could control overall volume and things like web browser plugin volume, etc. with the indicator on the panel, now i have to actually open the mixer (which kind of defeats the purpose of having the level meter on the panel tongue). i checked the various ~/.xfce4 config files, but i didn't see anything that assigned that in any of them. i changed the libmixer.so value in xfce4rc to id="0" and id="1" (default seems to be id="-1") but that didn't work. (i'd like to change the icon too, if anyone knows how.)

otherwise xfce4 4.2.0 rocks! icons on the context menu are awesome, and a lot of the interface is much better. kudos to the xfce4 team!

Offline

#2 2005-01-19 21:33:59

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: xfce4 mixer question

slackhack wrote:

does anyone know how to change the mixer on the panel to use the master volume instead of master1? (or alternatively, i guess, change applications to be volume controlled by master1 instead of master? tongue)

mixer on the panel = volume control ?
What is master1 ? I only have Master;0

You can choose "wannabe master" in the properties of volume control item.
You can also mark "useful controls" in sound section of xfce settings manager.

I guess I don't really understand what's your problem with mixer settings (I'm assuming you have xfce4-mixer 4.2.0-1). You can't see
all mixer controls in xfce sound settings and/or mixer (volume control) properties ?

slackhack wrote:

i checked the various ~/.xfce4 config files, but i didn't see anything that assigned that in any of them.

BTW it's now ~/.config/xfce4

slackhack wrote:

otherwise xfce4 4.2.0 rocks! icons on the context menu are awesome, and a lot of the interface is much better. kudos to the xfce4 team!

You can also try new xfce4-terminal:
http://bbs.archlinux.org/viewtopic.php?t=9306

The only problem I'm having with 4.2 is that it now starts on all screens and displays (I have :0.0 (crt) and :0.1 (tv)) and I don't know how to start it only on crt (I don't need it on the tv). The previous version didn't do it. I already modified all settings and I'm using my own .xinitrc (startx). When I remove session manager it still starts xfdesktop on the tv. Anyone knows a solution????

Offline

#3 2005-01-19 21:50:40

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: xfce4 mixer question

thanks, i just found it in the properties. all that looking through config files and it was right in front of my face. tongue  [edit: to clarify, the problem was that the panel volume control was set to wannabe Master,1 instead of Master,0 and was therefore failing to control my apps.]

BTW it's now ~/.config/xfce4

thanks! that would explain a few things, too.

don't know about multiple displays, as i only use one. is it an X setting by any chance?


p.s. if anyone cares, the icon that's associated with the panel mixer is xfce-sound, not xfce4-mixer (makes sense, right? roll ). cheers.

Offline

#4 2005-01-19 22:06:00

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: xfce4 mixer question

slackhack wrote:

BTW it's now ~/.config/xfce4

thanks! that would explain a few things, too.

Read http://www.xfce.org/~benny/file-locations.html for all the details.

slackhack wrote:

don't know about multiple displays, as i only use one. is it an X setting by any chance?

Yes and no. It's connected with session management and new mulihead support in xfce. I only hope they didn't forget to include some switch to turn it off :-)
Looks like I need to read more to find some solution...

Offline

#5 2005-01-20 04:34:45

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: xfce4 mixer question

what's in your ~/.config/xfce4/mcs_settings/display.xml file?

Offline

#6 2005-01-21 01:01:12

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: xfce4 mixer question

Not much. At least nothing useful.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE mcs-option SYSTEM "mcs-option.dtd">

<mcs-option>
    <option name="XDisplay/bgamma" type="int" value="100"/>
    <option name="XDisplay/ggamma" type="int" value="100"/>
    <option name="XDisplay/rate" type="int" value="0"/>
    <option name="XDisplay/rgamma" type="int" value="100"/>
    <option name="XDisplay/size" type="int" value="0"/>
    <option name="XDisplay/syncGamma" type="int" value="1"/>
</mcs-option>

I know the problem is related to session management. It should be possible to eliminate taskpad and panel but not xfdesktop (only one instance).

I'll keep searching but this is a new release and xfce forums is not very helpful.
This is the closest solution that I've found:
http://lunar-linux.org/pipermail/xfce/2 … 11939.html
But it's still not exactly what I want. I'll try to experiment with sessions.

Also lineakd doesn't want to start with sessions enabled. I guess I have finally move to xbindkeys :-)

Other things work quite well. A nice thing is that you can manipulate brightness of the wallpaper from desktop settings (good for transparency). BTW I can see two subtabs here for each screen (screen0 and screen1). I guess this controls xfdesktop but it can't turn it off for a given screen.

Offline

#7 2005-02-06 14:46:30

skeeter
Member
From: Woodstock, CT
Registered: 2003-02-01
Posts: 77

Re: xfce4 mixer question

slackhack Q:
I'm having a similiar problem. I have sound for xmms and whatever program but my panel mixer doesn't have any "wannabe" device listed at all.  My ~/.config/xfce4/panel/contents.xml doesn't have any device listed.  I think this is where I need to put the "Master,0" at but would like some confirmation b4 I really mess anythng up. Any clarification would be welcome! wink

Edit: Well, I guess all I needed was to reboot and then all my settings were available. Patience! Yep, that's what I need. lol


Skeeter

Rule #1:  There are NO RULES!

Offline

Board footer

Powered by FluxBB