You are not logged in.

#76 2009-12-29 22:33:29

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: kernel 2.6.32: How to enable ATI KMS?

TemplarGR wrote:

Just because in the past support was poor doesn't mean it will always be this way. Ati open source drivers are quickly maturing.

I completely agree, the amount of progress made over the last year by just 2-3 developers is impressive.

@linuxgod & wantilles: really, stop trolling, it's annoying and unconstructive in any way. wantilles, the 5.5 years statement is nonsense since this project started in the summer of 2007.


ᶘ ᵒᴥᵒᶅ

Offline

#77 2009-12-29 22:56:54

ChemBro
Member
Registered: 2008-10-22
Posts: 691

Re: kernel 2.6.32: How to enable ATI KMS?

With kernel 2.6.32.2-2 in [core] and kms for radeon disabled by default, how do I enable it? Frontpage news says, early start is broken, so how do I enable it for late start?

Frontpage:

Please use the modeset option to enable it.

What is the exact modeset option? Wiki only says how to disable it.

Wiki:

(1) Add "radeon.modeset=0" into the kernel append line in /boot/grub/menu.lst or the lilo configuration file (without the quotation marks!).

So it should be "radeon.modeset=1"?

Offline

#78 2009-12-29 23:02:08

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kernel 2.6.32: How to enable ATI KMS?

Yes, it should wink I'm fixing the wiki right now, be patient.

Offline

#79 2009-12-30 08:28:57

riivo
Member
Registered: 2008-08-25
Posts: 112

Re: kernel 2.6.32: How to enable ATI KMS?

KMS works with that option added, but now there's no DRI. Xorg.0.log

(EE) RADEON(0): [dri] RADEONDRIGetVersion failed because of a version mismatch.
[dri] This chipset requires a kernel module version of 1.17.0,
[dri] but the kernel reports a version of 2.0.0.[dri] If using legacy modesetting, upgrade your kernel.
[dri] If using kernel modesetting, make sure your module is
[dri] loaded prior to starting X, and that this driver was built
[dri] with support for KMS.
[dri] Disabling DRI.

Using xf86-video-ati-git compiled today.

Offline

#80 2009-12-30 15:05:51

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: kernel 2.6.32: How to enable ATI KMS?

Have you followed the ATi wiki ?

Offline

#81 2009-12-30 15:30:51

linuxgod
Member
Registered: 2009-05-06
Posts: 50

Re: kernel 2.6.32: How to enable ATI KMS?

Is it Impossible to enable KMS on R300 chips?

Offline

#82 2009-12-30 15:55:45

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: kernel 2.6.32: How to enable ATI KMS?

No.

Offline

#83 2010-01-10 21:00:45

hicham.haouari
Member
Registered: 2010-01-09
Posts: 2

Re: kernel 2.6.32: How to enable ATI KMS?

KMS is working on R300 chipsets. First do this :
http://bugs.archlinux.org/task/17461

Then, append radeon.modeset=1 to kernel parmeters.

Now u will have KMS, but without DRI.

To enable dri, recompile libdrm with --enable-radeon-experimental-api.

Recompile Mesa.

Fetch latest xf86-video-ati git and install it.




Et voila, you should have now radeon KMS for R300

Last edited by hicham.haouari (2010-01-10 21:01:55)

Offline

Board footer

Powered by FluxBB