You are not logged in.

#1 2005-02-22 03:57:25

nehsa
Member
Registered: 2003-01-14
Posts: 159

Getting postfix to work

Hi,

I followed the wiki tutorial on setting up postfix.  I dont get any errors but when I try to telnet (from another computer on the network) I just get a black screen.  Any ideas what I did wrong?  I guess arch doesn't come with telnet so I couldn't try it from within arch.

Thanks for any help!

Offline

#2 2005-02-22 04:40:03

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

sure it does.

$ pacman -Ss telnet
current/netkit-telnet 0.17-6
    A telnet client (and server)
extra/putty 0.56-1
    A terminal integrated SSH/Telnet client known from Windows.

$ pacman -S netkit-telnet

try telnetting to the localhost on the server itself. Report back on your results..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-02-22 04:46:23

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

This is all I get:

[root@server1300 ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
who
hepl
help
blah
/?
list

Basically, it lets me on but I dont get any welcome message and can't seem to do anything.  I may have jumped the gun though, a post about 4 down is probably the same problem, i'm going to go through that one.

Offline

#4 2005-02-22 04:56:16

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Found this in /var/log/mail.log:

Feb 20 04:48:30 server1300 postfix/master[4438]: warning: process /usr/lib/postfix/smtpd pid 4488 exit status 1
Feb 20 04:48:30 server1300 postfix/master[4438]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Feb 20 04:49:30 server1300 postfix/smtpd[4489]: fatal: unsupported dictionary type: mysql
Feb 20 04:49:31 server1300 postfix/master[4438]: warning: process /usr/lib/postfix/smtpd pid 4489 exit status 1
Feb 20 04:49:31 server1300 postfix/master[4438]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling


Don't know if that helps.  I'm super over my head, but I want a mail server.. smile

Offline

#5 2005-02-22 05:12:29

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

which postfix package did you install? The one that comes in the arch repo does not support mysql databases.
I have compiled in support for mysql access for the one that is in my repo.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#6 2005-02-22 23:45:02

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Ohh OK, how do I get it from you?

Offline

#7 2005-02-22 23:57:12

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, sorry.. I figured it out.  Archlinux is the nicest distro ever because I don't get yelled at for not reading things first.

Offline

#8 2005-02-22 23:59:38

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

wink


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#9 2005-02-23 00:26:04

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, so, one more problem.  I got your package but can't get pacman to install it.  I used something and think I got it installed into the database, but when I try to install it is says:

postfix-2.1.5-4: local version is newer.  Upgrade anyway? [Y/n] n

Can't get it to install your copy.

Offline

#10 2005-02-23 00:31:23

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

try
pacman -R postfix
then
pacman -A postfix-package-file
also, add postfix to the list of ignore packages or next upgrade of postfix will wipe it out.

you could just add my repo to the start of your pacman.conf file, but if you are only using one build, then it doesn't make much sense..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#11 2005-02-23 00:32:08

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Heya, hehe, -Af worked.. Ok.. I think I might be in now.  Got this when telnetting to localhost:

220 mail.server ESMTP Postfix

Going to try and send a test email now

Offline

#12 2005-02-23 23:39:34

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

SO, I restarted the server and it frozed on start FAM.  I reinstalled.  Maybe I'll try qmail this time.  smile

Offline

#13 2005-02-23 23:49:55

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

hmm..maybe you didn't configure FAM correctly. FAM (file alteration monitor) is used by courier, not postfix.

Sad to see you had such bad luck with my how-to. If you see any areas where it could be improved, updated, or fixed, let me know.
Good luck with qmail.  8)


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#14 2005-02-24 03:31:23

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Getting postfix to work

nehsa wrote:

SO, I restarted the server and it frozed on start FAM.  I reinstalled.  Maybe I'll try qmail this time.  smile

fam needs portmap to be running


The impossible missions are the only ones which succeed.

Offline

#15 2005-02-25 02:20:37

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, your tutorial was awsome.  I redid the same setup (although I didn't follow tutorial as closely, as I actually want to be able to use a client instead of webmail).  Anyways.. I just about got it working, the only problem I have is when I send people email it says in the reply-to address:

In-Reply-To: <3092.192.168.0.1.1109124496.squirrel@192.168.0.1>


I assume the setting for that is in /etc/postfix/main.cf but I can't figure out where that is.  I assume that's why no one can respond to my emails.

Thanks for any direction.. smile

Offline

#16 2005-02-25 02:23:42

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey.. just noticed, I can't send mail to my account either.  This is what yahoo responds with:

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following
addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)


Any direction would be great.  I can telnet into port 143 from an external source so I thought I was all good.

Offline

#17 2005-02-25 02:39:07

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

nehsa wrote:

Hey, your tutorial was awsome.  I redid the same setup (although I didn't follow tutorial as closely, as I actually want to be able to use a client instead of webmail).  Anyways.. I just about got it working, the only problem I have is when I send people email it says in the reply-to address:

In-Reply-To: <3092.192.168.0.1.1109124496.squirrel@192.168.0.1>


I assume the setting for that is in /etc/postfix/main.cf but I can't figure out where that is.  I assume that's why no one can respond to my emails.

Thanks for any direction.. smile

weird. that should be the "message id" field. Are you sure you configured squirrelmail properly? That is where my guess would be.
maybe post a copy of your squirrelmail/conf/config.php for inspection.
I recommend making a copy of the file, renaming as a txt, and putting it on webspace somwhere and just linking to it from here. No need to fill up a post with that.  wink


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#18 2005-02-25 02:40:25

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

nehsa wrote:

Hey.. just noticed, I can't send mail to my account either.  This is what yahoo responds with:

Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following
addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

Sorry, I couldn't find a mail exchanger or IP address. (#5.4.4)


Any direction would be great.  I can telnet into port 143 from an external source so I thought I was all good.

Looks like either you don't have dns setup properly, or it just hasn't propagated yet.
You need an mx record for your domain.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#19 2005-02-25 04:11:47

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, thanks for your help. 

1st message:
http://www.niftyass.com/config.txt

SMTP is set to localhost, is that right?  I set it that way thinking that that would stop any relaying from happening.


2nd message:
I have the DNS setup like this, niftyass.com has an A record pointed to my computer.  and an MX record going to:
p0p.niftyass.com

The website thats doing my DNS (not sure I want to tackle BIND yet) said that for the MX record "we need to know the fully-qualified domain/host name of your mail server.".  Does p0p.niftyass.com sound like a good answer?  smile

Offline

#20 2005-02-25 07:18:37

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

part1:

$domain                 = 'cactuswax.net';
$imapServerAddress      = 'localhost';
$imapPort               = 143;
$useSendmail            = false;
$smtpServerAddress      = 'localhost';
$smtpPort               = 25;
$sendmail_path          = '/usr/sbin/sendmail';
$pop_before_smtp        = false;
$imap_server_type       = 'courier';
$invert_time            = false;
$optional_delimiter     = '.';

This is what I have for the related part in question. domain is where you want email to look like it is coming from. You generally want the imapServerA to be localhost, unless squirrel is connecting to a remote box.

Also very important is the imap_server_type being set to courier. This sets other things correctly for you...use the config interface perl script to make changes to the file...it will save you alot of headache down the line...

update the link after you make changes, so I can check it again, if things continue to be no worky..

part2:
you need a corresponding a record for the mx record.
A record points to pop0.niftyass.com
MX record points to pop0.niftyass.com
the A record to niftyass.com doesn't cover pop0, unless they are doing "wildcard dns", of which I have no experience.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#21 2005-02-25 21:25:24

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey.. I modified SM with the settings and have recopied the config file to the location above.  Still same thing.  I'm starting to think.. smile.. that there might not be a problem with that though.  Shouldn't I be able to telnet to p0p.niftyass.com from an external source?  (telnet p0p.niftyass.com 143) I can do it locally (although I can't seem to do anything.. just responds with

NO Error in IMAP command received by server.

I can't even quit out, have to use CTRL-] to break the connection.

Could it be a setting with hosts, hosts.allow, hosts.deny or resolv?  I have opened port 143 on my router so it should be accessible from outside.

Here are copies of those files:
http://www.niftyass.com/resolv.txt
http://www.niftyass.com/hosts.txt
http://www.niftyass.com/hosts_allow.txt
http://www.niftyass.com/hosts_deny.txt


Also:  here is what nslookup returns.. smile

C:nslookup type=mx p0p.niftyass.com

DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 24.21.66.7: Timed out
Server:  UnKnown
Address:  24.21.66.7

DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
Please nobody haxor me as I probably am complete open to attack.

How I have DNS setup.. made a host p0p.niftyass.com, added an a-record going to my IP address, then made a MX-record pointing to p0p.niftyass.com. <-- note the . at the end, someone said I needed that.

Offline

#22 2005-02-25 21:35:16

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

nehsa wrote:

Shouldn't I be able to telnet to p0p.niftyass.com from an external source?
[/code]
yes, you should be able to.

(telnet p0p.niftyass.com 143) I can do it locally (although I can't seem to do anything.. just responds with

NO Error in IMAP command received by server.

I can't even quit out, have to use CTRL-] to break the connection.

Does telnet localhost smtp work ok?
If so, then it is a matter of configuring courier-imap then.
Check your mail log for error messages. It would seem that something is amiss indeed.

Could it be a setting with hosts, hosts.allow, hosts.deny or resolv?

Unlikely. Most likely it is a configuration issue with courier.

Make sure your /etc/courier-imap authdaemonrc, authmysqlrc, and imapd files are appropriately configured. You also need fam and portmap installed, and it looks like your hosts.allow is properly configured for portmap, so no worries there..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#23 2005-02-25 21:58:42

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, what log file does imap use?  SMTP seems to work great.  I can telnet in and send messages fine. 

Now, I am not using authdaemonrc or the mysql.  I didn't think I needed to since they were MYSQL related and I figured I'd keep it simple to start with.  I'll verify my settings of imapd tho.

Offline

#24 2005-02-25 22:33:24

nehsa
Member
Registered: 2003-01-14
Posts: 159

Re: Getting postfix to work

Hey, here are some things with imapd that I don't understand:

ADDRESS=127.0.0.1
ADDRESS=0

That look right?

I've tried removing the ADDRESS=0 but it didn't seem to change anything either way.  Also tried 192.168.0.3 which is the servers network address.

Hey.. I also got this from mail.log:
Feb 23 15:22:09 serverass1300 imapd: LOGIN, user=nehsa, ip=[::ffff:127.0.0.1], protocol=IMAP
Feb 23 15:22:09 serverass1300 imapd: Failed to create cache file: maildirwatch (nehsa)
Feb 23 15:22:09 serverass1300 imapd: Error: Input/output error
Feb 23 15:22:09 serverass1300 imapd: Check for proper operation and configuration
Feb 23 15:22:09 serverass1300 imapd: of the File Access Monitor daemon (famd).
Feb 23 15:22:09 serverass1300 imapd: LOGOUT, user=nehsa, ip=[::ffff:127.0.0.1], headers=198, body=0, time=0


I went into famd.conf but theres only like 5 options and all seem ok.  I'll post it in the same place fam.txt incase you'd like to look at it.


http://www.niftyass.com/fam.txt

Offline

#25 2005-02-26 00:04:21

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Getting postfix to work

fam.conf looks fine. just make sure you are running everything you need (portmap, fam, etc).

DAEMONS=(syslog-ng hotplug !pcmcia iptables network netfs crond portmap fam sshd mysqld clamav amavisd postfix courier-imap httpd)

the above is an example. the order can be important in some cases. ie. portmap before fam, fam before courier, mysql before postrix and courier, etc..

As for the address line, setting to 0 accepts connections from all ip addresses. Setting to 127.0.0.1 sets it to accept local connections only. I use the ADRESS=127.0.0.1 in my conf file..

I would focus on looking at the config files for courier, and making sure they are in line with the wiki doc.

Now, I am not using authdaemonrc or the mysql. I didn't think I needed to since they were MYSQL related and I figured I'd keep it simple to start with. I'll verify my settings of imapd tho.

Ahh. I don't know how user information is handled in courier normally. My experience with courier is only using external authentication, namely why I chose to set it up using mysql. This way, I don't have to duplicate information for postfix, courier, and squirrelmail. There was a method to my madness...
Eventually, I will probably migrate my setup to ldap, or maybe hula. I have been fiddling with hula, and just downloaded a 450 pg pdf from novell about netmail (where much of hula code came from)..which I am loathe to start reading..  :?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

Board footer

Powered by FluxBB