You are not logged in.

#1 2005-03-22 18:19:45

ovihc
Member
Registered: 2004-06-16
Posts: 62

NFS nightmare

I always had touble setting up NFS on my computer.
i want to run the nfs server so that i can access the cd, but when i run

/etc/rc.d/nfsd start

i get nothing, no output, nothing, just [FAIL]
i only want to share the nfs mount in my home network, nothing fancy.

this are my files:

/etc/hosts.allow

# /etc/hosts.allow
#
#portmap: 192.168.31.5
#portmap: 192.168.31.6
portmap: ALL
nfs: 192.168.123.107
# End of file


/etc/hosts.deny

# /etc/hosts.deny
#

ALL: ALL: DENY

# End of file

/etc/exports

# /etc/exports
#
# See exports(5) for a description.

# use exportfs -arv to reread
#/export    192.168.1.10(rw,no_root_squash)
/mnt/cd     192.168.123.107(ro,insecure,all_squash,sync)

then i run:

/etc/rc.d/portmap start
:: Starting Portmap    [done]

/etc/rc.d/nfslock start
:: Starting nfslock  [done]

/etc/rc.d/nfsd start
:: Starting nfsd          [fail]

that's as far as i get.

Offline

#2 2005-03-22 19:42:58

filoktetes
Member
From: Skien, Norway
Registered: 2003-12-29
Posts: 286

Re: NFS nightmare

I remember having trouble with the

ALL: ALL: DENY in host.deny

Here are my settings, that works fine for me:

# /etc/exports
#
# See exports(5) for a description.

# use exportfs -arv to reread

/               192.168.1.2(rw,no_root_squash,async)
/home           192.168.1.2(rw,no_root_squash,async)
/mnt/maxtor     192.168.1.2(rw,no_root_squash,async)
/mnt/pendrive   192.168.1.2(rw,no_root_squash,async)
/mnt/asono      192.168.1.2(rw,no_root_squash,async)
#
# /etc/hosts.deny
#

portmap: ALL
lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL

# End of file
#
# /etc/hosts.allow
#

portmap: 192.168.1.2
lockd: 192.168.1.2
rquotad: 192.168.1.2
mountd: 192.168.1.2
statd: 192.168.1.2

# End of file

Offline

Board footer

Powered by FluxBB