You are not logged in.

#1 2010-05-29 18:18:53

xstaticxgpx
Member
Registered: 2008-10-22
Posts: 48

[SOLVED] nvidia 256.2{5,9} 32bit library segmentation faults

With the latest two nvidia driver betas I cannot launch any 32bit games or opengl apps because of a segmentation fault in my /opt/lib32/usr/lib/libGL.so.1

I have never had a issue like this and ive been using the latest nvidia drivers since about versions ~173xx

Last edited by xstaticxgpx (2010-06-07 21:17:12)

Offline

#2 2010-05-30 22:52:52

xstaticxgpx
Member
Registered: 2008-10-22
Posts: 48

Re: [SOLVED] nvidia 256.2{5,9} 32bit library segmentation faults

Ok, after messing around with these drivers for a bit I've found the problem. Apparently there's been some change in the 64bit kernel module that makes the libraries from the x86 driver pkg (the one used in lib32-nvidia-utils*) segfault. Instead, you take the 32bit libraries from the 64bit .run with compat32. Here's my pkgbuild for anyone interested, this provides both 64bit and 32bit nvidia libraries: http://pastebin.com/LzYtqKC1

Last edited by xstaticxgpx (2010-05-30 22:55:22)

Offline

#3 2010-06-06 10:56:36

Berseker
Member
From: Near Lecco, Italy
Registered: 2008-04-24
Posts: 252

Re: [SOLVED] nvidia 256.2{5,9} 32bit library segmentation faults

many thanks for the solution.

I think that since this is a great change for 64bit users who uses also 32bit apps which require 3d, that PKGBUILD should be put on AUR as an alternative to lib32-nvidia-utils or something like that

Offline

#4 2010-06-07 23:34:35

xstaticxgpx
Member
Registered: 2008-10-22
Posts: 48

Re: [SOLVED] nvidia 256.2{5,9} 32bit library segmentation faults

Berseker wrote:

many thanks for the solution.

I think that since this is a great change for 64bit users who uses also 32bit apps which require 3d, that PKGBUILD should be put on AUR as an alternative to lib32-nvidia-utils or something like that

http://aur.archlinux.org/packages.php?ID=37902

Offline

Board footer

Powered by FluxBB