You are not logged in.

#1 2005-04-02 06:32:18

ruwach
Member
Registered: 2004-06-14
Posts: 143

neeeed help please with lan

hello there
i use pppoe to connect to the internet using eth0 as the card
i am trying to share an internet connection with another linux computer via eth1
i do an ipconfig eth1 192.168.1.1 netmask 255.255.255.0 up when i reboot
i have firestarter installed and went through the gui setup but i dont think my eth1 or nat or iptables are set up right.
i can ping eth1 (192.168.1.1) but not the computer connected to it. (192.168.1.2)
i have given it permission through firestarter, but still cannot get through.
it worked in debian. just one last hurtle to being able to use Arch permanently.

here is the rc.conf

lo="lo 127.0.0.1"
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
#eth1="eth1 192.168.1.1 netmask 255.255.255.0"
INTERFACES=(lo !eth0 !eth1)

#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   (prefix a route in ROUTES with a ! to disable it)
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

#
# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(syslog-ng hotplug !pcmcia adsl iptables network netfs httpd crond)


and ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:BF:93:D0:81
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:308 errors:0 dropped:0 overruns:0 frame:0
          TX packets:291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:231087 (225.6 Kb)  TX bytes:27930 (27.2 Kb)
          Interrupt:16 Base address:0x2000

eth1      Link encap:Ethernet  HWaddr 00:11:D8:2B:41:A7
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::211:d8ff:fe2b:41a7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0xec00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:160 errors:0 dropped:0 overruns:0 frame:0
          TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11847 (11.5 Kb)  TX bytes:11847 (11.5 Kb)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:63.97.188.33  P-t-P:63.97.188.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:251 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:222731 (217.5 Kb)  TX bytes:19948 (19.4 Kb)


and modprobe.conf

# OSS Compatibility
install snd-pcm modprobe -i snd-pcm ; modprobe snd-pcm-oss ; true
install snd-seq modprobe -i snd-seq ; modprobe snd-seq-oss ; true

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
options snd  device_mode=0666
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx
# --- END: Generated by ALSACONF, do not edit. ---
alias eth0 via_rhine
alias eth1 8139too

any ideas on how to set up nat here ? i need to share the net with the other computer.

thanks

Offline

#2 2005-04-02 07:57:22

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: neeeed help please with lan

Try

ROUTES=(gateway)

?

Offline

#3 2005-04-02 12:57:27

ruwach
Member
Registered: 2004-06-14
Posts: 143

Re: neeeed help please with lan

wow thanks, but it didnt work.
another wierd issue about this... i could only connect to dls through eth1 when i did the adsl-setup. that may have something to do with it. Perhaps the computer does not see the onboard lan (via_rhine) very well.
debian did, so it isnt the hardware. perhaps i am loading the wrong module.

any more suggestion? i am at a loss here.

Offline

#4 2005-04-02 13:04:44

sudman1
Member
From: Huntingdon, UK
Registered: 2005-02-18
Posts: 143

Re: neeeed help please with lan

Can you post the output of the route command (without arguments)?


v/r
Suds

Offline

#5 2005-04-02 13:29:32

ruwach
Member
Registered: 2004-06-14
Posts: 143

Re: neeeed help please with lan

ok here you go

[ruwach@Arch ~]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
63.97.188.1     *               255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     *               255.255.255.0   U     0      0        0 eth1
default         63.97.188.1     0.0.0.0         UG    0      0        0 ppp0
[ruwach@Arch ~]$

Offline

#6 2005-04-02 13:40:14

vacant
Member
From: downstairs
Registered: 2004-11-05
Posts: 797

Re: neeeed help please with lan

Not quite sure why you want to start your interfaces manually (eth0, eth1 are commented out and interfaces has a "!" before both). Perhaps adding a route during startup before adding interfaces manually is stopping things working?

Try stopping the firewall, probably:

/etc/init.d/firewall stop

do a "route -n"
mine gives

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 eth0
0.0.0.0         10.0.0.2        0.0.0.0         UG    0      0        0 eth0
[root@night rc.d]#  

To get an internet connection working requires only three things:

an interface
a default route/gateway
a name server


Once you've got an interface, you should be able to "ping" that interface 192.168.1.1 and (I believe) anything on that subnet 192.169.1.2 to 192.169.1.254.

Once your got a default route/gateway, you should be able to ping any IP address such as 66.249.87.104 (www.google.com)

Once you've got your name servers IP addresses in /etc/resolv.conf you should be able to lookup and ping www.google.com

Offline

#7 2005-04-02 13:51:11

ruwach
Member
Registered: 2004-06-14
Posts: 143

Re: neeeed help please with lan

ok here is the route -n

[root@Arch ruwach]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
63.97.188.1     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
0.0.0.0         63.97.188.1     0.0.0.0         UG    0      0        0 ppp0
[root@Arch ruwach]#

i uncommented the interface eth1 in rc.conf
pppoe uses eth0 to do ppp on
i can ping 192.168.1.1 just fine but i cannot ping 192.168.1.1 (address of other computer on eth1)

dont know whether to comment eth0 or not. i have set it to "dhcp" before but when the computer boots, it takes forever looking for the internet on eth0 before it goes on to do things the dsl way.

hope this helps

Offline

Board footer

Powered by FluxBB